Follow us @bensoftware

SecuritySpy

Multi-camera CCTV software for the Mac


Download Previous Versions of SecuritySpy

Please note that these older versions of SecuritySpy are no longer officially supported, so we we are not able to provide support for them.

If you own a SecuritySpy version 1, 2 or 3 license, you may like to upgrade to SecuritySpy version 4, which is a major update with many significant improvements and new features.


Released 10 March 2016.
System requirements: Intel only, Mac OS X 10.4 - 10.11.
This is the last 3.x version.

Released 7 December 2013.
System requirements: Intel or PPC, Mac OS X 10.4 - 10.9.
This is the last version of SecuritySpy that supports PPC Macs.

Released 18 January 2013.
System requirements: Intel or PPC, Mac OS X 10.4 - 10.8.
This is the last 2.x version.

Released 15 November 2012.
System requirements: Intel or PPC, Mac OS X 10.4 - 10.7.
This is the last 1.x version.

Back to top