Skip to content

Urgent help needed accessing SS remotely

I've just set up an instance of SS in a house in Spain, I live in Ireland, but I'm in Spain right now, although departing for Ireland today.

What I'm doing is setting up some cams in the house in Spain so they can be monitored from Ireland. Until recently (today perhaps), everything was working fine, but I've tried to log in to the web server xxx.viewcam.me:8001, and it's no longer working.


I've tried :8000 and :8001, but Safari on my MacBook Air won't connect. Nor will my iPhone. However, the iPhone SS app connects fine, and I can even view the captures.


I've rebooted the machine SS is on (a Mac mini) and rebooted the server, but nothing. Connecting to SS using anything other than the iPhone app doesn't work.

I thought I had this all sorted, but now not! I get on a plane in a few hours back to Ireland, so it's a little urgent I get this issue fixed!


Any help that can be offered will be greatly appreciated!

Comments

  • It's difficult to debug this without knowing some further specific information and further investigation, but if this was working before then usually a reboot of the router can solve such issues (you said that you rebooted the Mac, but not that you rebooted the router).

    This FAQ contains troubleshooting steps that solve the issue for most users: I'm unable to access my system remotely - how can I troubleshoot this?

    We can help you with this directly if you email us and include SecuritySpy's debug file (SecuritySpy menu > Debug > Create Debug File On Desktop), as well as the make/model of your router, but if you ned to leave Spain a few hours we are unlikely to be able to solve this for you in time.

    So, my recommendation is to install TeamViewer on this Mac in Spain, and make sure it is set up with a permanent password (not the temporary ones it gives you by default), and set to start automatically with the machine (so that it is on all the time). Make a note of the login ID and passcode. Then, when you are back in Ireland you will be able to access this machine remotely in order to resolve this problem when you have more time (TeamViewer is free to use for non-commercial applications).

  • Hi Ben. Sorry for not posting back sooner, it’s been a chaotic day!


    I got it working in the end. Turns out any device on the same network as the SS mini can’t connect to the server. So for instance, as soon as I put my iPhone onto 5G , it connected.

    i spent an hour checking the router settings and nothing struck me as odd. But for now it’s all working fine.


    I did plan to put Apple Remote Desktop on the mini, so I can troubleshoot from Ireland but ran out of time. I’m back out there in a few weeks so will get it sorted then.


    incidentally, you mention TeamViewer. What’s your opinion on it? I was going to just jump straight to Remote Desktop, but always keen to take advice from those more Knowledgeable.

  • Oh, should mention I did add remote access to the router (it was a built in feature that just needed turning on).


    The ISP is Jazztel, which is part of Orange. They installed the Livebox 3 router. So I will drop you an email once I’m back in Ireland and sorted, and maybe you can help troubleshoot any potential router issues.

  • Good to hear this is now sorted!

    In order to access a device using its WAN (Internet) address while you are on the same local network as the device requires a particular feature in your router called "loopback", which most, but not all, routers have. So you are unlucky that your router lacks this, which made it look like remote access was not working.

    In terms of remote access to control the Mac, SecuritySpy has this feature built into its web interface, so you could use this now that you have confirmed that remote access to SecuritySpy works. Otherwise, Apple Remote Desktop or TeamViewer should work perfectly well for this and I'm not familiar enough with each to recommend one over the other. You could also use the built in Screen Sharing option that is available in the Sharing system preference panel, but this requires you to forward port 5900 to the Mac in your router so there is some extra setup here.

  • >but this requires you to forward port 5900 to the Mac in your router so there is some extra setup here.

    I'm familiar with screen sharing, but had no idea it could be done remotely with just a port forward. I'll look into that when back out there, as it's a native and free solution.


    Thanks for all your help Ben, here and on email. Much appreciated.

  • Something happened to my access today, too.

    The licensed version on the mini is running fine.

    I can access all the cameras via the iPhone app and via Safari on my laptop.

    The unlicensed version of SS on my laptop can not connect, and the licensed version of ViewCam on my laptop can not connect.

    I'm not sure where to start looking for the problem.

  • Fixed.

    Restarting the apps on the laptop, and restarting the laptop itself did not fix it.

    Restarting SS on the mini fixed it.

Sign In or Register to comment.