Skip to content

SecuritySpy, SV3C 5MP bullet cams, Eero mesh WiFi & 2014 i7 Mac Mini

As the title says, my system consists of SecuritySpy, several SV3C 5MP bullet cams, an Eero mesh WiFi system and a 2014 i7 Mac Mini.

I've run into a number of difficulties setting this up, and, yes, I'm aware that WiFi isn't the best way to connect these cameras.

I'm trying to cover a 2 acre property, and WiFi is where I am starting.

A few observations...

The Eero mesh networks adapt to local conditions over a period of time. From the Eero website:

_____________________________________________

The Eero system is constantly optimizing to maximize performance. There are 3 different time scales in which your system optimizes:

• Short Term - Your mesh takes between fifteen seconds and a minute to figure out the best path for data to travel through your network when any new request is made.

• Medium Term - The system takes about an hour to learn what kind of interference you have around your home, and learn to tune it out as best it can.

• Long Term - It takes between two days and a week to select the best channels for your network. This is very disruptive to your network so we try not to do it too often.

_____________________________________________

It took me a while to understand this, and realize that re-booting the system should probably not be the first thing I do when troubleshooting a problem.

And that, if necessary, re-booting an individual Eero is preferable to re-booting the entire network.

I have one Eero mesh system dedicated to SecuritySpy. When I first set it up, (4 cameras), the cameras were dropping out frequently, and were sometimes hard to get back online.

Over time, those problems have disappeared, and all 4 cameras are now on what appears to be very solid connections.

I attribute that to the various adjustments the Eero system has made to route the cam data in the best way possible for my mesh, which consists of four Eero Pro 2nd Gen TriBand units. (The last Pre-Amazon buyout of Eero models)

Once all the cameras were connected well, I tried installing the NTP server on the Mini, and I could not get it to work. Although the Eero indicated it had internet connection, I could not get any internet connectivity at all from the Mini. I spent some time with Eero support, swapped out the Eero hub unit, replaced network cables, but still couldn't get connectivity or install the server.

I turned off the firewall, made sure nothing else would interfere with network traffic, but still no go.

While looking at my network settings, I saw the DNS window had an Eero subnet address instead of a valid DNS address. I entered 1.1.1.1 there and applied that, and that fixed the internet connection, and gave me the green light in SecuritySpy's Dynamic DNS test window.

That's how far I got today...

I don't know how that subnet IP address got entered into the DNS setting, whether it was populated by the Eero, SecuritySpy, or something I caused. I did not manually enter it, and in order to change it I had to enter a password. Perhaps the Mini asks its network for it, and Eero just gives it the next available IP address.

It's surely something that should be on your checklist to verify if you can't install the SecuritySpy server.

I still haven't been able to access the server with my iPhone SecuritySpy app, that is my next project.

I'm posting this as an FYI for anyone who may have the same limited ability to understand how all these things work, but who may be using some of the same components, and who may find a bit or two of this information helpful for what they are doing.

Feel free to ask about this setup, if you have questions.

This is also an invitation for anyone who has bits of information I may not have about these components, that they think might be helpful for me, or others who read this.

Comments

  • Thank you for reporting your experiences with your setup. It's curious why that errant DNS server address got in there - this is certainly something that SecuritySpy doesn't edit. It would have to have been entered manually, or some software you ran (with admin privileges) would have to have specifically edited your connection settings. In any case, I'm glad things are working well now. I hope the setup for remote access goes smoothly, let us know if we can be of any help with this. This FAQ outlines solutions to common problems with this: I'm unable to access my system remotely - how can I troubleshoot this?

  • My first attempts at remote access were not successful. My modem is a Zyxel XMG3563-B10A.

    UPnP is turned on.

    The Zyxel is assigning local IP numbers in the 192.168.200.X range.

    Behind that, I have 3 separate Eero mesh networks, one for the house, one for the business and one for the cameras. None are in Bridge mode, and each creates its own subnet. (192.168.4.X, 192.168.0.X and 10.0.4.X.)

    All 3 of those show their WAN IP addresses in the Zyxel 192.168.200.X range.

    I assume that what I need to do is set the Hub Eero on the cam network to Bridge Mode, in order for SecuritySpy to be able to "see" the WAN IP address the Zyxel has.

    I also assume that will result in all four Eeros, all 4 cams and the Mini being reassigned IP addresses by the Zyxel modem in its 192.168.200.X range.

    I had set the Eeros to give the cameras fixed IP numbers, and am assuming I should tell the Eeros to have the cameras go back to DHCP to make sure they don't get stuck on the wrong subnet.

    I'm assuming the other 2 Eero meshes will be fine as-is, staying on their own subnet behind the modem, and that making the cam network a bridge next to the other 2 networks that aren't bridged will be OK.

    I'm a little nervous about doing this and will appreciate any further information and hand-holding you can provide.

  • Did I read somewhere that I can set up the mini to be on two networks at the same time?

    Might that be a possible solution, to have it on the WiFi subnet for the cameras, and on the Zyxel router subnet via ethernet for the WAN?

  • Baby steps...

    I bridged the Eero network the cams are on. That put all 4 cameras, 4 Eeros and the Mini on the Zyxel subnet.

    As soon as I told SecuritySpy the new IPs for the cameras, all the cameras were visible on the Mini.

    The other two Eero networks are not bridged, and still have their own subnets, after the Zyxel subnet.

    From those two subnets, I can now see the webcams with an unlicensed SecuritySpy on my laptop. It's able to find the cams on the Zyxel subnet from the Eero subnet.

    It had not been able to find the cams from an Eero subnet through the Zyxel subnet to a second Eero subnet.

    Still no server visible to the iPhone app, even though UPnP is enabled on the Zyxel.

    Next task will be to attempt port forwarding on the Zyxel.

  • I set up port forwarding on the Zyxel, not sure I did it correctly, and am unable to see the cams using the iPhone app unless I am on the Cam WiFi network.

    Don't know where to go from here.

  • One setting change did it!

    In the Zyxel, for the "WAN Interface" pull-down, selecting "EthWAN-Internet_only" did it for me.

    The IP addresses it asks for are kind of cryptic...

    Server IP address is the IP address the Xyxel has assigned to the Mini.

    I used the check box to activate "Select originating IP" and filled in the Xyxel's self-assigned subnet IP.

    Now it works using the iphone app, and via web browser from outside my local network.

  • Great to hear you have successfully set this up. Just two things to check:

    • The Server IP should indeed be the IP of the Mac running SecuritySpy. Make sure that this is either a manual/static IP that you have set up on the Mac (using the "Manually") option under System Preferences > Network, or that the Mac is set to DHCP and the router is specifically set to give the Mac this same IP address all the time (often called a "DHCP reservation").
    • It is unusual to have to specify an originating IP - usually any such option should be left blank.
  • edited March 9

    Thank you for the info on "Originating IP".

    I deselected the originating IP checkbox, which erased that IP address, and it works fine without it.

    Edit: I do have the router set so the Mini has a fixed IP.

  • Great to hear that, all sounds good to me now.

  • Can SS get access to the PTZ functions on this camera?

    I just received an SV3C HX Series 5MP PTZ (digital zoom) camera.

    https://www.amazon.com/dp/B09V15K1JC

    The PTZ works on SV3C's app, but they caution some functions may not work with other's software:

    "IP camera works with HiP2P, Blue Iris, Ispy, VLC or some other 3rd party software. .. The PTZ WiFi camera can work with many NVRs like other SV3C cameras, some functions may not fully compatible"

    I don't see any access to PTZ controls in SecuritySpy.

    I did see the recent discussion and fix for Amcrest cams to make their PTZ work through SS.

    Is there any hope for a similar fix for this one?

  • PTZ should work in SecuritySpy with the right settings. What "Profile" setting are you currently using under Preferences > Cameras > Device? Try the ONVIF profile - does this give access to the PTZ controls?

  • Yes, I'm using ONVIF profile, but don't see PTZ controls

  • When you click the "PTZ" button at the top-right of any video window, the PTZ drawer should slide out. Could you please post a screenshot of this?

  • I just didn't know where to look for the PTZ button.

    The pan & tilt both work, looks like the digital zoom doesn't, but probably because it's only digital zoom.

    Thanks for showing me where to find the PTZ button.

  • Good to hear that the pan/tilt works. The zoom function in the PTZ panel will only operate the camera's optical zoom, if it offers this feature. SecuritySpy itself offers digital PTZ in any video window, so if you want to zoom digitally you can use this. You activate this by holding the Command key on the keyboard and scrolling up/down on the mouse/trackpad. Release the Command key while zoomed and scroll left/right/up/down to pan around the zoomed image.

  • Got it.

    For the audio, I see I can listen by turning on audio preview...is there a way to have 2-way audio so I can access the cam's speaker?

  • BenBen
    edited May 26

    Sorry but two-way audio is currently supported only for Axis, Amcrest, Dahua and Hikvision cameras at this time. We are working on a universal ONVIF implementation, which I hope we will be able to release soon.

Sign In or Register to comment.