Mac Mini M1 dropping off the network
  • I have a new Mac Mini M1 running SecuritySpy with a wired ethernet connection and I've been going crazy trying to figure out why it's just disappearing from my network every 1-2 days, so I'm curious if anyone else is seeing similar behavior. I'm already working with Apple Support but they've not been very helpful. There's not much else running on the system.
    When this happens, it's not pingable and can't get to anything else though it still thinks it has an IP address and seems to have carrier on the switch port too. It's really weird. The only solution I've found is a reboot.
  • That does sound weird. When this happens, are you able to go to the machine and interact with it as normal (does it have a screen/keyboard/mouse that you can use to try this?) From the machine itself are you then able to connect to the network (e.g. access web pages via Safari)? Does anything else appear abnormal, or is it purely the network?

    I would be tempted to try a system re-install to see if this has any effect, as I'm not sure what other troubleshooting steps you could try. What has Apple Support themselves recommended?
  • Yes, the machine appears to be working normally but there is no network connectivity at all, even if I disable and re-enable the ethernet interface, flush DNS, create a new location...I've tried it all.
    Apple took the machine for a day and claims they were able to reproduce the problem, then created a new network location and the problem went away. When I told them that I'd tried that already they suggested that I must have done that wrong and told me to give it a try. This afternoon it dropped off the network again.
    I think you're right that a reinstall is the next logical step.
  • That's a weird one. Have not had issues with my mini.
    It has been rock solid.

    @sot, what is the mini connected to upstream? Perhaps the switch port is detecting a loop somewhere. Have you had anything else connected to that port prior to the mini, or is this a new connection?
  • @Neurobit I've been scouring the switch and router logs for clues about that but haven't found anything. I've got commercial-grade equipment, but with that said my configuration wasn't quite what Ben recommends: the Mini was on the wired network with cameras on an isolated wifi network designated for IOT devices. That way, all video streams were passing through the router. There was no indication that that was causing a problem anywhere.

    I've since moved all of the cameras to the same subnet as the Mini and so far it hasn't dropped again. It's been two days, where previously it was dying about every two days so we'll see.

    Thanks for your input.
  • Thanks for the update. Strange indeed.

    Your configuration was like mine. I have separate VLANs for production and cameras, and the mini is on my DMZ, so the mini is on it’s own subnet and we only allow the ports required to access the camera feeds (and icmp). That’s it.

    Ping me if you have any other issues and I’ll be happy to help.

    Cheers,
  • UPDATE: After putting the Mini on the same subnet as the cameras (removing the router from the path between them), it's been stable for over 5 days now - previously 2 at most. No idea yet why the router would be at fault here but wanted you guys to know that SecuritySpy on my M1 Mini is performing great when you build your network right. :)
  • Great to hear it's working well now. I can't imagine what the problem could have been - this is highly unusual!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!