I wanted all the features of the web admin account
  • SS IPHONE app connects fine to my web enable SS on my Mac, inside and outside the network. That's good.
    On my Mac however only inside my network and the web browser says SS refused connection blah blah blah from outside.
    All the boxes have been ticked in the web preferences and an 1 admin account. Security set to 0 and 2 for connection testing.
    I wanted all the features of the web admin account from my 'puter but no go.
    makes no sense seeing as how the iPhone SS can connect outside the network.
  • If you can connect from outside your network on your iPhone, then everything is set up correctly for remote access, and the problem must be with the URL you are using to attempt to connect to SecuritySpy outside your network using a web browser.

    Assuming you are using default ports, and you have enabled the HTTPS service (which is what you should be using for remote access, as it's secure), and assuming you have set up a DDNS name in SecuritySpy in the form example.viewcam.me, then here is what you will need to enter into a web browser in order to connect from the web:

    https://example.viewcam.me:8001

    Does that work? If not, please email us and provide a screenshot of your Web settings in SecuritySpy, and we'll be able to advise you further.
  • yeah I can connect from outside on my iphone, but not from my 'puter on a web browser. I set up port forwarding on my router for this to happen using https. I have firewall off for testing but still, Even locally my browser will deny entry right away into SS because it says i'm vulnerable to attacks and I have to ignore the browser's warning and plunge in through (the learn more link). I'm thinking this is also happening from the outside without the added benefit to ignore the warning, but I don't see where I can fix that. Otherwise I will have to email you with the screen shots
  • Hey I don't know what happened but it's working now right after I made that last post I checked again and voila. I changed nothing fo the previous post. Did you do anything there? Thanks
  • Ok update: I was only able to connect with my Opera web browser which has a VPN setting. Safari, Firefox, and Chrome were no able to connect and I don't easily see a VPN setting on them
  • It sounds like there are two things going on here:

    1. Under HTTPS, the address used to connect to a server needs to match the address encoded in the server's certificate, which in this case will be your name.viewcam.me address. So, if you attempt to connect over your local network (LAN) using any other address (e.g. a Bonjour or IP address), the browser will give you that warning about an invalid certificate.

    2. The name.viewcam.me address is an Internet (WAN) address. In order for this address to work from within your LAN requires that your router support a specific feature called "loopback", and it sounds like your router does not support this.

    Therefore, while you are on your LAN, the best thing would be to use SecuritySpy's HTTP (non-secure) web interface, and use the Bonjour address to connect (as shown when you click the How Do I Access This Server? button under Preferences - Web).

    For security, keep using HTTPS for WAN access (only the HTTPS port 8001 should be forwarded in your router for Internet access, not the HTTP port 8000).

    Our iOS app gets around these issues by automatically using the best address depending on whether it is on LAN or WAN, and asking the user (once) to accept invalid certificates if it encounters them, hence you are seeing these problems in web browsers but not our iOS app.
  • Update: Now the IOS won't connect over WAN (LAN ok). I have all the boxes checked in the SS web prefs and am copying and pasting the WAN and LAN address on "How do I access this server" button unto Opera which also has stopped working on WAN (LAN ok).
    On my router I have https port forwarding :8001 and not :8000.
    I need this to work on a remote mac too not just the Iphone.
    I'm thinking there must be something wrong with DDNS server being used - probably I have been timed out or something because of my constant attempts and configuration changes.
    Thanks
  • Could you please email us and supply screenshots to show all settings, and all errors? I think we can more effectively help you directly at this point - it's difficult to know what's going wrong from descriptions alone. Usually port forwarding is more prone to problems than DDNS, but we'll be able to verify this once we receive your screenshots. Thanks.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!