Problems Running SecuritySpy on Apple M1 Mac Mini
  • I have to admit that my experience with the new Mac Mini M1 to run SecuritySpy hasn't been a pleasant one. First I learn that you can't run it headless as I did with the previous Intel version. Had to hook it up to a monitor with keyboard and trackpad to run the darn thing. And now I'm receiving a panic roughly every 1 to 2 days.

    panic(cpu 7 caller 0xfffffe00194e87dc): "apcie[2:lan-1gb]::handleCompletionTimeoutInterrupt: completion timeout linksts=0xa9000200 pcielint=0x00804010 linkcdmsts=0x00000100 (ltssm 0x19=DISABLED)\n"

    Appears to be related to an issue with the built-in LAN port if I reading it correctly, though I'm certainly no expert. I rebooted and ran a diagnostic and the machine comes up clean. Have also run First Aid on the disk drives. OS is up to date. I have very little software running on it other than SecuritySpy.

    Before I contact Apple to work with this issue, I was wondering if anyone might has some insight on this problem.

    Thanks
  • I'm running a Mac mini 2020 M1 in headless mode and it's running fine, except for some errors due to hardware decoding of Hikvision cameras that Ben is investigating.
  • So you don't have a monitor, keyboard and a trackpad/mouse connected at all? I can't remote in to control the Mac until I complete the login sequence. I've even tried several dummy HDMI dongles. Mind sharing with me how you have yours set up? Under system settings, sharing, do you have remote login and remote management checked? Thanks.
  • I just double-checked and my Mac mini's computer name isn't available for a Share Screen session via Finder's sidebar, Locations/Network until you do the first login via a connected monitor and keyboard. I have Remote Login and Remote Management checked via System Preferences. There is no monitor attached. Only the RJ45 and power connections are in place. I've also tried using a 4K dummy HDMI plug. No difference either way.

    The only way to get it to work is the complete the initial login via a physical connection with a monitor. I can pull the monitor cable after initial login and then operate it headless mode.

    Am I missing something? I never used a monitor, keyboard, trackpad/mouse with my previous 2018 Intel Mac Minis except for initial OS loading.

    Thanks.
  • Remote management - yes
    Remote login - yes
    User permissions set for each item as administrator level.
    I'm using both Remote Desktop and TeamViewer (remote) to connect.
    Only ethernet and drives connected. No keyboard, no mouse, no monitor.
    There was a user account issue that I had to resolve. I found it online, where if you upgrade via Time Machine the user accounts don't work properly, so I had to delete the prior user accounts and create new accounts under new user names to get the permissions to work.
  • Upon further research if you have File Vault turned on, and I do, you must enter username and password at startup before any other services are started. So that explains the headless issue.

    Any ideas on the panic?
  • I’m also on a headless mini.

    No issues connecting remotely via TeamViewer or VNC.

    Only issues I’ve encountered is that sometimes issuing a remote reboot doesn’t really work, which I can only resolve by physically shutting down and rebooting the machine. Seems like a bug which I hope gets resolved on the next macOS update, but other than that, the mini has exceeded all expectations.

    What a rocket of a machine. Love it!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!