Running SS behind login screen - issue with Big Sur update?
  • Hi, I updated to Big Sur yesterday on my Mac mini

    I had to reboot the computer this morning b/c of some kind of crash and it seems that the script found here:

    generates this message in Terminal:

    The default interactive shell is now zsh.
    To update your account to use zsh, please run `chsh -s /bin/zsh`.
    For more details, please visit
    Pulin-Mac:~ pulin$ /Users/pulin/Desktop/Go\ To\ Login\ Window.command ; exit;
    /Users/pulin/Desktop/Go To Login Window.command: line 1: /System/Library/CoreServices/Menu Extras/ No such file or directory

    and the Mac didn't return to the login screen

    I haven't tried a second reboot yet to see if it was just a one off thing, but was wondering what I need to do to get the script working again? Does the script need to be updated?

    Thank you
  • It looks like this script doesn't work on Big Sur. Thanks for letting us know, we'll look into this and hope to have a replacement soon.
  • Ok thanks, please let us know when it’s updated - it’s very useful!
  • Hi @Ben, any progress on getting this working again? Thank you
  • The reason why this now fails is that Apple has removed the tool in Big Sur. If you google "CGSession -suspend", you'll find more. I found a way around but this requires that you set "Require password immediately after sleep or screen saver begins" in 'Security and Privacy' settings. If you do that and you open in WinEdt the "Go to login window.command" script that you downloaded from bensoftware and replace the text with "pmset displaysleepnow" on the first line and "exit" on the second, it does what it needs to do. (The 'pmset displaysleepnow' puts your screen to sleep and your security settings then require a login. The 'exit' just ends the terminal session.) I created a separate 'standard user' account (with no admin privileges and no iCloud login) that just runs SecuritySpy.
    (PS This is just a hack by someone with intermediate knowledge of macOS. I'm sure that there may be better ways. But it works :) )
  • Thanks for this comment and the message @evds001

    So is the standard user account the one that you have login automatically and then return to the login screen?
  • Yes, because that account is always logged in and active (with a server running etc) and goes through this automatic start-up sequence, it seems safer to not give it admin privileges or iCloud access. And it does not diminish SecuritySpy's performance. (If you want to integrate with HomeKit, you may need to log into iCloud.)
  • The Go To Login Window script has now been updated for macOS 11: download it here. After download, make sure to right-click and select the Open option, and give it all permissions asked for. This only needs to be done once.
  • Thank you @Ben, will check it out
  • Hi @Ben, this does not seem to be working - I get the same 'default interactive shell is zsh' message in Terminal after a reboot

    I d/l'd your linked file above, right clicked it and selected Open; it asked for a single permission regarding Terminal I believe and that was it

    I also saw the original instructions where it says to drag the d/l'd file into the Login Items in System Preferences Users and Groups, so I did that too

    But, no luck
  • Strange, I'm not sure why this didn't work.

    We have done more work on this, and now switched to a standalone utility app called Lock Screen to do the locking, rather than a shell script. This gives us more flexibility over implementation, and avoids the need for the ugly Terminal window. New info can be found in the FAQ Can SecuritySpy run behind the lock/login screen?

    Please report back and let me know if this now works correctly for you.
  • Update: after some more testing, this only seems to work if there is actually a keyboard attached to the Mac. This is because the tool achieves screen lock using the ⌃⌘Q keystroke, and it seems that under Big Sur, all keyboard shortcuts are disabled if there is no keyboard attached!

    A workaround is to enable the Accessibility keyboard is turned on (System Preferences > Accessibility > Accessibility Keyboard). We're hoping to update the tool to avoid the need for this workaround. Stay tuned...
  • Thanks @Ben - does the keyboard have to be wired? I have a BT keyboard 'attached'
  • Update 2: I think we now have overcome this limitation. Please download a fresh copy of the Lock Screen applet via the link in the FAQ (Can SecuritySpy run behind the lock/login screen? - if you Get Info on the Lock Screen applet in the Finder you should see that it is version 1.0.1).

    Please report back once you've had a chance to test.
  • Seems to have worked, thank you
  • Thanks Ben this fixed it!
  • @Ben,

    The update worked great! No issues since we installed this about a week ago.


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!