Time Lapse and other problems
  • I recently started using Security Spy, I ran a demo system on a older Mac Mini with a Logitech c910 and a DLink 931L, both set up for motion capture and time lapse 1 frame per minute movies. It worked well and I bought a license, and added a third camera, a DLink 2332L.

    The main problem I've had is I can't create the same 1 frame every minute time lapse movies with the 2332L. When I try it creates multi-GB temporary files and the only time it's finished a movie, the movie file was over 8GB (compared to 1-30 MB movies for the other cameras). When I watched it, it appeared to be a single frame repeated over and over for hours. I've increased the time between frames from 60 to 120 to 3600 seconds, no change. For now I've had to shut off time lapse movies for that camera to avoid trying to sync an 8GB file to the cloud .

    A few other issues I've encountered:

    I've noticed on motion capture movies for the 2332L, although I have it set to 2 seconds pre-capture, it always includes 20 seconds of pre-capture data. Otherwise it works fine for motion capture movies and still images.

    Security Spy was dropping video from the 2332L about once a day (and crashing, although I don't know if these were happening at the same time) -- all it would show was black, although if I logged into the camera directly I still got live video. I changed the stream from H.264 to MPEG-4 and the crashing and dropping stopped. (I tried turning time lapse movies on again after that, but no change, it still made multi-GB files.)

    Is there some setting I might have wrong? This camera isn't listed in the pull down menu so I set it up manually:
    Device type: Manual Config.
    HTTP port: (blank -- default)
    RTSP port: (blank -- default)
    Encryption: unchecked
    Format: RTSP
    Request: live1.sdp
    No recompression

    On the camera:
    7FPS max frame rate

    Continuous capture settings:
    Frequency: 60 seconds between frames
    Playback rate: 15 frames per second
    Create movie: Daily

    The same settings work fine for the other two cameras.

    (I put in a ticket for this last week but since the first response I haven't heard anything . . . I'm starting to wonder if everything is getting trapped in a spam filter somewhere. I can't find anything in mine.)
  • Hi, what you describe does sound like it could be a bug. I will do some testing here and see if I can reproduce your issue.

    The difference could be down to the different codecs in use (MPEG-4 on your 2332L vs. JPEG on your other cameras).

    Try instead using JPEG for the 2332L camera (the settings in SecuritySpy will be HTTP for the format and video.mjpg or video/mjpg.cgi for the Request). Does that fix the capture problem?

    As for the long pre-capture time, this is probably due to the temporally-compressed nature of the MPEG-4 or H.264 video stream. You can reduce this effect by reducing the "I-frame interval" setting (sometimes called GOV length or key frame rate) in the camera, if it has such a setting.
  • Hi Ben,

    I just switched to JPEG and turned time lapse capture back on. I also switched to 4 FPS to reduce the load on my local wifi network. Switching to JPEG appears to have fixed the 20 second pre-capture. I don't see a key frame rate setting I an change. I'll let you know how it works for time lapse.

    -- Brian
  • The time lapse movies are also normal now. I also see there's a firmware update for the camera, I may install that and try mpeg-4 again.
  • I am a new user and have been very happy with all the great features. I felt I should add the behavior I am seeing to this thread. It appears there is a difference based on the codec.
    I have 2 Q-See QCN8004B (Coscto 2-pack) 1080p cameras that are using h.264, and am running on an iMac. I am using the timelapse settings of 7 seconds between frames and a final playback of 30 frames per second. This works fine with the iMac's built-in iSight camera, but the same settings with the Q-See h.264 cameras do not. With the h.264 cameras I get a full real-time playback with all recorded frames (file size agrees). For the h.264 cameras, it does not matter what settings I use for the time-lapse, it is always a straight real-time video.

    - Cory
  • Cory, have you enabled the "No recompression of video data" setting in the Video Device Settings window in SecuritySpy? This tells SecuritySpy to capture the video data directly from the device to disk. In this mode, the frame rate of the video cannot be changed (due to the temporally-compressed nature of the H.264 codec), so your capture frame rate setting is ignored.

    If you disable this "no recompression" option, does the capture frame rate work as expected?
  • That was it! Thank you Ben. I unchecked the "no recompression" for both cameras and the timelapse is functioning as expected. Sorry for the false alarm.


    - Cory

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!