Skip to content

Eufy Indoor Cam 2K

edited June 2020 in SecuritySpy
Has anyone had any luck getting the new Eufy indoor cams to work properly in SecuritySpy? I'm getting at best 1fps, usually closer to 1 frame every 4 seconds. The RTSP feed gives the full expected 15fps in VLC and in Synology's Surveillance Station, so I assume it isn't an issue with the feed itself.

Here's my settings: https://i.imgur.com/ZHqCYYD.png and the settings provided in their guide: https://i.imgur.com/ZMIMjFB.png.

Any ideas or tips from a successful setup? Thanks in advance!

Comments

  • Bit of an update: I'm getting the full 15fps after setting it up again with the same settings, but the image quality is garbage.
  • I'm interested in the same thing. Not sure why the quality would be anything less than 2K. Another consideration is the web server that lives inside the little Eufy router, if there was a way to mate that to Security Spy, that's be great. Little 2K cameras that run on battery for year is pretty cool. I have 4 cameras set at a rental property, little them so far. But, I really would like to mate them to SS.
  • @lapetitebaker copied your settings but cant get an image and I am using the correct IP for the camera.
  • I wrote a scathing review on Amazon for the Eufy 2K indoor camera...Amazon wasn't a fan and wouldn't publish it. The short version is that Eufy is, in my opinion, falsely advertising this product. The 2K image looks great, especially for the price, when used with their app. If you enable HomeKit *or* RTSP, you disable the 2K stream and get this super compressed, oversaturated, garbage-looking stream to work with. Unless they update the firmware to support the 2K stream going through RTSP, you're stuck with the Eufy system (or SD card) for recording at 2K.
  • I'm not sure what could be going wrong here - with this method of obtaining the video, SecuritySpy is simply accepting whatever stream the camera provides, and has no control over the resolution or frame rate.

    One thing to check is the "Packet loss" column in the Camera Info window in SecuritySpy to see if there is any loss reported here - if so then this could be a clue.
  • Hello, I have the same problem with the Eufy 2K outdoor cam.

    It works great with a Zoneminder server (15fps) , with Homebridge ( (15fps) with the Cam Ui plugin) but not with SecuritySpy

    I have max 1fps, packet loss is 0. Same network, same conditions and all others Wifi cams on the Spy server are ok.

    Any idea ?

  • It's difficult to tell why this could be happening, and we don't have one of these cameras here to test with. Would one of you be willing to put your Eufy camera online temporarily so that we can connect to it from here to run some tests? If so, please email us at support@bensoftware.com and we will send instructions on how to do this.

  • GusGus
    edited May 24

    Hi, I just tried adding a Eufy 2K and it was pretty inconsistent.

    I think the default setting in Eufy Security was to record "Events". I changed that to "Continuous Recording" and it seems to be working, but it's only been running a few minutes. The frame rate in SS is being reported as (15/13).

  • GusGus
    edited May 24

    Update: I added the Eufy to ViewCam directly (not getting the feed from SS), and the frame rate on VC dropped to 1fps. Once I disabled the camera on SS, the VC frame rate jumped up to 15fps.

    On both SS and VC, the frame does a little jump every 2-3 seconds. It's mildly noticeable and annoying. Similar to what my Reolink used to do.

    On re-reading the thread, l am skeptical about the resolution of the stream too.

  • Thanks for your feedback.

    I did more testing and I found that:

    • if you open more than one rtsp stream and one of them is sspy, the frame rate drops to 1fps with massive packets loss
    • if you disable the audio part in sspy (set to none in the cam setup), the frame rate drop to 1fps, even with only one stream open.
    • I get 15 fps in sspy if audio is enabled and with only one rtsp stream (the one in sspy)
    • I get 15 fps with 2 streams open with homebridge and zoneminder


  • Interesting. I tried disabling audio, but it didn't seem to have any effect. Cameras: Audio: Audio Device: None.

    I launched ViewCam, and both streams were 1fps, not just the second stream.

    Quit VC and SS frame rate recovered. Launched VLC and both streams died to 1fps. Quit SS and VLC stream recovered. Launched VC, and both VC and VLC streams died. Not that I'd ever have VLC and ViewCam running on the same computer at the same time, but I wanted to test the combination to be thorough.

  • It sounds like this camera has trouble producing multiple RTSP streams simultaneously (i.e. when multiple clients are connected). Perhaps its processing capabilities are quite limited.

    In addition, perhaps it prefers UDP transport (which many clients use by default), and TCP transport (which SecuritySpy uses by default). This could explain the different testing results reported above with Homebridge vs. Zoneminder vs. SecuritySpy. To test this theory, select "RTSP UDP" as the Format setting in SecuritySpy and see if this makes any difference to the reliability of the frame rate.

  • RTSP UDP doesn't connect at all (I use TCP for all my cams when possible).

    For me, with only one stream, turning off the audio in sspy reduces the FPS to 1.

    As soon as I enable audio, I get 15 FPS. See the screenshot, the last cam in the info window.


  • I switched the Eufy from RTSP to RTSP (UDP) and in the Setup window, the preview is working, but the actual camera window says "Error 461 (see log)".

  • What works for me:

    • only one stream
    • TCP
    • Sound enabled

    With that I get 15fps.

Sign In or Register to comment.