Send email not work
  • I do not understand one thing.
    Capturing images or videos works well.
    I also filled in the "eMail" part in the SS configuration and I passed the email sending test.

    I am using the Gmail SMTP server, I receive the test email.
    On the other hand, during a motion detection I do not receive mail or images.

    How does this section work?

    Thanks
  • If you get the test email, this indicates that the actual SMTP setup in SecuritySpy is working fine.

    The email notification is classed as an Action in SecuritySpy. So in order for emails to be sent, Actions mode must be armed. Can you check that this is the case? The easiest way to arm the camera is to right-click on it (in any video window, or in the Camera Info window), and set the Actions schedule to "Armed 24/7".
  • I have found, gmail request port :465
    The test with simple word Ok but without pictures.
    :465 good with pictures.
  • I can't get mail to work either: the securityspy email relay service does not seem to work. When I try smtp with my me.com I keep getting "Bad username or password" error. But it does not seem to be possible to set the port or select SSL??
  • Hi @p_pissierssens there are no known problems with the relay service at this time, so if you aren't getting the emails this means that there is some problem with your setup, or the emails are being blocked by a spam filter.

    Make sure that emails are actually being triggered: for this to happen, you must set up an email address for notifications under Preferences -> Cameras -> Actions for a camera, and then Arm that camera's Actions mode (if you are unfamiliar with arming and disarming cameras, please see the Getting Started section of the user manual).

    If you are using your own SMTP server and getting an authentication error, this indicates that the username or password you have supplied is incorrect.

    If you need to, you can specify a custom port for your SMTP server by adding it using a colon in the standard way, for example:

    server-address.com:port

    SSL can be enabled using one of the "Encryption" options in SecuritySpy's Email settings. The usual setting for most SMTP servers is "Explicit".
  • I have been trying with the relay service but as there is no way to test (is there?) I do not know if any email is successfully sent. I do not know what else I can try. I have checked and there is nothing in my spambox. I have configured the application and armed the camera for motion detection.
  • ok it seems to be working now with the relay service.
  • Good to hear it's working now. What did you have to change to be able to receive the emails?

    Unlike for the SMTP server setup, there is no test button for the relay service, because there are no user-configurable settings: if there is an internet connection it just works, so a test button would be of limited utility.
  • is Exchange SMTP working with Securityspy? Gsuite did after alloweing external email sending in Gsuite. Exchange will throw the following.

    Connecting to server...
    Communicating with server...
    Error 127036,535 535 5.7.3 Authentication unsuccessful [AM3PR07CA0138.eurprd07.prod.outlook.com]

    Username and pass I checked several times. smtp.office365.com:587 Explicit and I generated a user account with name securityspy@myhomepage.de on exchange so Exchange recognizes the mail. I am trying to log in to SMTP with the admin user/pass
    Anything I have to set on Exchange like I had on Gsuite? Anything I did wrong on SS?

    10 minutes later:
    OK had to enable smtp fot the user under user/mail/mail apps
    Now I get the error

    Connecting to server...
    Communicating with server...
    Error 127040,5480 554 5.2.0 STOREDRV.Submission.Exception:SendAsDeniedException.MapiExceptionSendAsDenied; Failed to process message due to a permanent exception with message Cannot submit message. 0.35250:251A0000, 1.36674:0A000000, 1.61250:00000000, 1.45378:02000000, 1.4

    some more minutes later:
    OK works now but I cant send from another email adress than the user loging in. Any way to make it come from securityspy@ without havein to pay for an inbox at Exchange?
  • I’ve started having send email issues after automatic update to the latest version. Has worked flawlessly for years. Anyone else having an issue?
  • @roads - this sounds like the server is simply rejecting the authentication provided. And the "MapiExceptionSendAsDenied" exception could be because the mail server blocked you temporarily due to the authentication issues. In terms of what is allowed as the sending address, I think you'll have to ask this question to the provider of your mail server. Generally, the sending address should be the same as the username.

    @weatherguy we have fixed a bug related to this in the latest beta version of SecuritySpy (currently 5.2.6b3), could you please test and report back?
  • I too was experiencing the no email send issue after updating to the latest version, the beta version resolved the issue for me
  • Ben, the beta version resolved the email send problem. HOWEVER, the beta version wasn't recording anything for review. It's difficult to define what was wrong with the beta, but I ended up having to use TimeMachine to restore the previous version (5.2.4) and restoring the preference file from that version as well using the File menu option. Now it's working again.
  • I meant restoring to version 5.2.4
    Version 5.2.5 has the email send issue.
    The beta apparently was recording, but most of the motion captures weren't reviewable using the app's browser function. Going back to 5.2.4 was the solution for now.
  • I'm experiencing email problems as well after updating to 5.2.5. No emails are sent when motion is triggered and the test emails fails.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!