Security Spy repeatedly crashed in a loop until I deleted it
  • I'm trying to figure out if I should go with Dropcam (easy to use but $$$ service) or cobbling together something on dlink. Purpose: house monitoring, checking on new neurotic rescue dog. Picture a chihuahua cross whippet cross coyote? and that's him. Cute but mental.

    I'm running a dlink dsc 5040l and a dsc 942l and got them up and running after figuring out the tweaking. It looked good. I wanted to record to an NAS I set up over near my Apple router. Set that up. Was trying to set up a test run of monitoring and the app crashed. It tried to do Apple report while repeatedly pulling up the camera window, then crashing. I had a devil of a time force quitting as it kept trying to return from the dead. Finally I deleted the app so I'm back to square one. Help?
  • I tried to reinstall Security Spy and when it restarted, it remembered the old setup so obviously I hadn't really killed the app yet. The crashing loop restarted again. Sigh. At least it's a wet weekend and with luck no tornados.
  • Here's some of the Apple report of what went wrong. I could send you more if you like. I am definitely out of my depth.

    OS Version: Mac OS X 10.8.5 (12F45)
    Report Version: 10

    Interval Since Last Report: 1876385 sec
    des Since Last Report: 10579
    Per-App Interval Since Last Report: 60883 sec
    Per-App Crashes Since Last Report: 41
    Anonymous UUID: 411F71F8-74F3-4D8C-8D39-5F5CF918BA9E

    Crashed Thread: 0 Dispatch queue: com.apple.main-thread

    Exception Type: EXC_BAD_ACCESS (SIGBUS)
    Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000

    VM Regions Near 0:
    --> __PAGEZERO 0000000000000000-0000000000001000 [ 4K] ---/--- SM=NUL /Applications/SecuritySpy.app/Contents/MacOS/SecuritySpy
    __TEXT 0000000000001000-000000000011f000 [ 1144K] r-x/rwx SM=COW /Applications/SecuritySpy.app/Contents/MacOS/SecuritySpy

    Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
    0 com.bensoftware.SecuritySpy 0x0009187c MyGetDiskNumberFromVolumeRef + 140
    1 com.bensoftware.SecuritySpy 0x0006fcf9 BFWGetThreadForVolume + 41
    2 com.bensoftware.SecuritySpy 0x0006f696 BFWOpenFile + 134
    3 com.bensoftware.SecuritySpy 0x0006f5d9 AFWOpenFile + 185
    4 com.bensoftware.SecuritySpy 0x0004d143 TLOpenFile + 1379
    5 com.bensoftware.SecuritySpy 0x0004ef0d CaptureTLMovieFrame + 253
    6 com.bensoftware.SecuritySpy 0x0002f958 ProcessNewFrameForCamera + 4376
    7 com.bensoftware.SecuritySpy 0x00067f9c NVVideoDataProc + 316
    8 com.bensoftware.SecuritySpy 0x000de309 NVProcessNewVideoFrame + 3881
    9 com.bensoftware.SecuritySpy 0x000d9853 NVProcessNewDataHTTP + 1331
    10 com.bensoftware.SecuritySpy 0x000d5132 BFNCallbackProc + 1842
    11 com.bensoftware.SecuritySpy 0x000e82af BFNService + 383
    12 com.bensoftware.SecuritySpy 0x0000f7f3 MyMainEventLoopTimerProc + 147
    13 com.apple.HIToolbox 0x9832d35c TimerVector + 22
    14 com.apple.CoreFoundation 0x99390406 __CFRUNLOOP_IS_CALLING_OUT_TO_A_TIMER_CALLBACK_FUNCTION__ + 22
    15 com.apple.CoreFoundation 0x9938fda5 __CFRunLoopDoTimer + 709
    16 com.apple.CoreFoundation 0x99374bb2 __CFRunLoopRun + 1842
    17 com.apple.CoreFoundation 0x9937401a CFRunLoopRunSpecific + 378
    18 com.apple.CoreFoundation 0x99373e8b CFRunLoopRunInMode + 123
    19 com.apple.HIToolbox 0x9831cf5a RunCurrentEventLoopInMode + 242
    20 com.apple.HIToolbox 0x9831ccc9 ReceiveNextEventCommon + 374
    21 com.apple.HIToolbox 0x982e17e6 AcquireNextEventInMode + 68
    22 com.apple.HIToolbox 0x982ded7d IsUserStillTracking(MenuSelectData*, unsigned char*) + 372
    23 com.apple.HIToolbox 0x982cc4ae TrackMenuCommon(MenuSelectData&, unsigned char*) + 1724
    24 com.apple.HIToolbox 0x984bddb9 MenuSelectCore(MenuData*, Point, double, unsigned long, OpaqueMenuRef**, unsigned short*) + 426
    25 com.apple.HIToolbox 0x984bedc6 MenuSelect + 171
    26 com.apple.HIToolbox 0x98474c16 HIMenuBar::HandleMouseEvent(OpaqueEventRef*) + 102
    27 com.apple.HIToolbox 0x98474a65 HIMenuBar::HandleEvent(OpaqueEventHandlerCallRef*, OpaqueEventRef*) + 165
    28 com.apple.HIToolbox 0x982f99bf HIObject::EventHook(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 163
    29 com.apple.HIToolbox 0x984719bb _InvokeEventHandlerUPP(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*, long (*)(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*)) + 36
    30 com.apple.HIToolbox 0x982f9394 DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 1343
    31 com.apple.HIToolbox 0x982f8780 SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 430
    32 com.apple.HIToolbox 0x9830c655 SendEventToEventTarget + 88
    33 com.apple.HIToolbox 0x9832c5f6 ToolboxEventDispatcherHandler(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 2188
    34 com.apple.HIToolbox 0x982f983f DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 2538
    35 com.apple.HIToolbox 0x982f8780 SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 430
    36 com.apple.HIToolbox 0x9830c655 SendEventToEventTarget + 88
    37 com.apple.HIToolbox 0x984710b7 ToolboxEventDispatcher + 82
    38 com.apple.HIToolbox 0x98470f79 RunApplicationEventLoop + 240
    39 com.bensoftware.SecuritySpy 0x00002c93 main + 35
    40 com.bensoftware.SecuritySpy 0x00002c35 start + 53

  • Hi - Sorry about this problem, it's highly unusual, and may be related to the drive you have set SecuritySpy to capture to.

    Please try this:

    - As soon as SecuritySpy loads, press cmd-T (this command means "Set all cameras to Passive mode"). This should prevent the cameras from starting recording, and therefore prevent the crash.

    - Reset the capture destination to the Mac's internal drive

    - Try setting the cameras to Active mode again to initiate recording.

    Does this resolve the problem?

    If not, unmount the NAS disk from your computer (via the Finder) and unplug or switch of the NAS. When SecuritySpy next loads it will revert the capture destinations to your Mac's built-in hard drive.

    What version of SecuritySpy are you using?
  • Thanks for being so prompt! I'm using version 3.3. I trashed the Preferences to get the app working again but am having trouble connecting to the dsc-942l now. I keep getting uninstall Perian but I have. Restarting the Finder now.....
  • OK, reset everything. Now it doesn't crash but when I put the cameras into active/on mode, the app crashes and restarts but is stable. The cameras are in passive mode. If I try to put them into active, it crashes and sends me back on a restart into passive. I'd like to record on the NAS which is a Seagate goflex drive inserted into a Seagate goflex net running Pogoplay.
  • Good to hear the crashing is gone. If you are getting the "Uninstall Perian" message then it will in fact be Perian (or some remnant of it still lingering on your computer) that is causing this. It prevents SecuritySpy from decoding incoming H.264 video. Maybe you were using the JPEG format setting for this camera previously, which is why you weren't getting it last time?

    In any case, to uninstall Perian, do the following:

    - Launch System Preferences and click on Perian (swiss army knife) icon
    - Click the "Remove Perian" button
    - Go to System Preferences again and right-click (or ctrl-click) on the Perian icon and select the "Remove Perian" option, so it completely disappears from the System Preferences window
    - Restart your computer

    If you can't see Perian in System Preferences, or the above does not work for any reason, then download Perian, install it, and then run through the above procedure to remove it again.

    Hope this helps!
  • Thanks. I'd restarted already. Per the workaround for the NAS, I thought maybe it wasn't happy with the off-computer recording. I set up an alias "Dog Cam" and put the alias in my documents file on my computer. So far it's robust. Now I get a file which is .unf. What is this? How can I view it? I'm sorry to be so dense but this is all new to me. What getting a neurotic but cute little dog can do to you. We'll be in Basingstoke visiting relations over in the UK and the dog will be here with the sitters and I'm nervous. The Dropcam is seamless but in the long run, the costs will be substantial. I've tried the dlink site, but can't get to see the NAS recording that well and I really prefer how your app "sees" all the cameras. I just have to see if my old PPC Mac Mini will be able to run things whilst we're away. I've got my newer desktop running right now and will have to reinstall on the Mac Mini which I'll run headless.
  • SecuritySpy is fine with recording to NAS devices. The procedure is to enable AFP (Apple File Protocol) on the NAS device (if it's not enabled by default), then mount it on the Mac desktop via the finder (typically using the Connect to Server option in the Go menu). Then it is available to set as a "capture destination" in SecuritySpy in the Setup section of the Camera Settings window. I'm not sure what the particular problem was that was causing the crash above - the crash log doesn't tell me this - but if you ever experience it again there are more tests and troubleshooting procedures we can try.

    I'm not sure about your alias method but if it's working OK then it's probably fine!

    An .unf file is an unfinished movie file, i.e. it's currently being recorded by SecuritySpy. To view such files you can use the Browser feature in SecuritySpy itself, or access the file via SecuritySpy's built-in web server, using any web browser (Safari, Chrome etc.) Once SecuritySpy has finished recording the file, it will turn into a standard .mov (QuickTime Movie) file that can be opened in many other applications (QuickTime Player etc.) besides SecuritySpy.

    Note that SecuritySpy 3.3 is Intel-only. If you want to use SecuritySpy on your PPC Mac mini you'll have to use version 3.2.1, which is available from the page of previous versions of SecuritySpy. We kept PPC support going for as long as we could, but unfortunately had to drop it in 3.3 for various reasons.

    I'm sure once this is all set up it'll make a great system for checking on your pooch and you'll be happy with the results!
  • Thanks for the info about PPC! I'll see how it goes. Now I can't set the DCS 5020l from JPEG HTTP to the H. video standard. The option is greyed out. I've deleted and added the camera several times and no dice.
  • We haven't tested the DCS-5020L in H.264 mode, which is why we currently only support it in JPEG mode (see our list of supported cameras for this information).

    However, it will almost certainly work in SecuritySpy in H.264 mode with the right settings, so please try a few of the other D-Link profiles that have H.264 enabled as an option, and let us know which one works.
  • Great. I've got my ancient Mac Mini now running the older app and seeming both cameras. I plugged in my old iSight (the tube shaped one) into the firewire port but it doesn't appear on the Local Devices. I also have plugged a Philips webcam into a USB port. Both cams work in other applications so they're not duds. I did make sure all other apps which used the cameras were closed out, but neither one is visible. Help again? I'd make you some tea but it would be cold before it get there.
  • Off to Fry's Electronics, our local Mecca for everything you want. Enjoying our rare rain.
  • Good to hear you've got the old Mini up and running :) SecuritySpy should certainly work with the iSight camera, as well as the USB camera as long as it supports the UVC standard. Just make sure that after you connect a USB or FireWire camera that you quit and re-open SecuritySpy so that it will re-scan for local devices.

    Hope this helps! Let me know if you continue to have problems.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!