Error Code 22120 -9461
  • We are running Security Spy at a couple locations with the exact same set up with no issues. For some reason setting up a location today with the exact same set up, has errors on three cameras. All the settings are exactly the same as far as I can tell. We are using Axis Cameras.

    The exact error message is:

    There was an error while running the camera "name" in active mode - it has been set to passive mode (Error code: 22120 -9461)

    Any help with this would be very appreciated. Can't find any info on this error.
  • Hi - sorry about this, it's not something we've seen before. I've made some changes that will hopefully fix the problem and I have emailed you a link to download an updated beta version of SecuritySpy for you to test. Please report back and let me know if this fixes it.
  • This does seem to have fixed the problem. I will let you know if it pops up again but all is well right now. Thanks for the very quick reply and fix!
  • Great, thanks for testing and letting me know. I'll make sure this bug fix is in the next 3.2.2 update, out soon.
  • I've been seeing this error for the past day or so as well. From the log file:
    02-20-2014 1710-26: Error running the camera "Barn" in active mode, it has been set to passive mode 3.2.1,22160,-108 Out of memory, please use MPEG-4 compression instead of H.264
    This happens repeatedly across my 4 cameras and eventually SS unexpectedly quits.
  • Software H.264 compression requires a lot of CPU and memory, so if have set SecuritySpy to perform software H.264 compression and you have lots of cameras and/or cameras with high resolution, this can quickly exceed the amount of memory available, leading to these problems. As the the error message suggests, the solution is to change the compression format from H.264 to MPEG-4 in the Compression Settings window in SecuritySpy.

    MPEG-4 is still an efficient codec that produces small file sizes, and it will make you system run a lot smoother. For any camera that is sending a H.264 stream to SecuritySpy, you can tell SecuritySpy to record this directly to disk using the "No recompression" option at the bottom of the Video Device Settings window. This will produce H.264 video files using the original data directly from the camera, and will result in the best performance and quality with the lowest CPU usage. There's more information on this in the Optimising Performance section of the user manual.
  • I have a Mac pro with 14G of memory and 16 cores. SS runs about 200% CPU (uses 2 cores of the 16) and has claimed 1.7GB of physical memory. The "memory pressure" on my machine runs about at the floor all the time. A memory error makes little sense on my machine.

    I only updated to 3.2.1 about a week ago and this issue started shortly after, now that I think about it. I'll downgrade to the 2.2.4 and check that for stability.

    Sorry, I hijacked this thread; in my mind I though the error codes were the same but looking now I see they aren't.
  • Hi Gerard - even though your Mac has plenty of memory, SecuritySpy, being a 32-bit app, can only access 4GB of it, hence these problems do come up from time to time when using software H.264 compression, which does use vast amounts of memory as I previously mentioned. It's a difficult task to convert SecuritySpy to 64-bit for various reasons but we are working on it. If you switch the compression in SecuritySpy from H.264 to MPEG-4 I predict that these problems will go away.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!