Network change affecting Remote Patrol
  • hey guys,

    Taking off for the holidays and installing my new cameras that Ben helped me get configured, and decided that updating my setup is in order. I decided to change my Mac Mini ethernet connecting directly to my LinkSys router to instead plugging directly into the Switch and then to my LinkSys Router. It's a DLink 4xPOE and 4x100Mbps for 8ports total. It's a Fast Ethernet switch that I had and it works good enough for 4 cameras. I was reading the Network Topology link on the SecuritySpy Home page, and it made sense to make the change and ensure my connections weren't interrupted in any way, especially since my Router is a little old. I made the change and everything locally is working fine, but now I am unable to connect remotely through Remote Patrol. It was working before the connection change. Nothing in my setup has changed, and I am using the web server interface to provide a DDNS link using ****.viewcam.me:### where *** is my name and ### is the port number assigned. My Mini is set to 192.168.1.114 as a fixed IP. I push the test button and get a green light.

    I'm not real savvy on Layer 2/3 type stuff, so I don't know if there is a server problem, Remote Patrol problem, or I have a configuration issue that I inadvertently caused. Would appreciate some guidance.
  • Another note...I cannot go to a browser and enter ***.viewcam.me:### and get through, so if I'm correct, I'm not getting DHCP resolution through the switch, right?
  • Hello!

    It's a good idea to use the switch as the main hub of the network rather than your router. As long as it's connected correctly, adding a switch between your router and computer shouldn't break anything: the switch should just route traffic efficiently around the network to the correct place and doesn't do anything more elaborate than that.

    If you are getting an internet connection from the Mac mini, then this indicates that the switch is working correctly. The green light next to the DDNS indicates that there's no problem there either. You say that your Mac mini has a static local IP address - that's good.

    So as I see it there are two options: one is that the port forwarding is set up incorrectly in the router. The second is that everything is in fact working, but you are not getting a connection because you are attempting to use the DDNS name from within your network. Depending on your router, the DDNS address may only work if you are outside your network (i.e. connecting over the internet). The best way to test this is to use an iPhone with the WiFi turned off, so it's connected over 3G, and use Safari on the iPhone to try to connect to the DDNS address.

    Hope this helps.
  • So it was simple. Can't explain it, but port forwarding was turned off on my router. Very strange, but it is working.
  • Great, glad it's working now!
  • I'm back. I haven't changed any settings personally. This time in SecuritySpy when I go under web settings, there are 2 separate local IP addresses showing up and Remote Patrol will not access. I double checked my port forwarding DHCP table list and only the single IP address for port 8000 is listed. Why or what do you think that am I doing that is generating the 2nd IP address? very strange. Can this be coming from someone outside? Should I be alarmed?
  • OK, I'm pulling my hair out here. After some weird occurrence whereby my port forwarding was disabled, I corrected the problem and it was working fine. I've been out of town visiting family and no one has had access to my computer, but have not been able to access via Remote Patrol for a couple of days. Retracing my steps, the only thing I did was turn on Google Cloud Print, in order to allow me to print from my iPad mini to a local wireless printer that does not support Airport functionality. I turned on my wifi setting, which I now determined was the 2nd IP address that Security Spy (SS) was referencing as access. I didn't have port forwarding pointing to that address, so I turned off the wifi function in order to troubleshoot this issue. No joy! So now I just set up a manual address that I pointed port 8000 to either IP address that comes in. Still no joy!

    To no avail, remote patrol still can't access. I get a green test confirmation in SS. I can enter the DNS address locally via a browser and it comes to the SS web interface. I take my iPhone, turn off wifi, and try to access it via LTE and it cannot access the ***.viewcam.me:8000 address. I am again stumped!! I don't know where to diagnose this. I keep trying things to no avail. I'm beginning to think I have an equipment problem. Anyone have any ideas what I'm missing?
  • reading some other troubleshooting tips on the web, I turned on DMZ to rule out any port forwarding rules and it still did not work.
  • OK, it's late and I'm tired so don't ask me to explain why, but I can explain what. I read some online articles that recommended putting a port tester on my mac (not any of the online versions as they fail). I went to http://www.pcwintech.com/common-problems-fixes-port-forwarding and used theirs. No matter what I did the 8000 port I was using was showing offline and not accessible. Changed to port 9000, updating SS, my router's port forwarding table, and Voila...everything is working fine, including Remote Patrol. As I said, I don't know why port 8000 all of a sudden had to be giving me trouble, but it is. Ben...if any of this makes sense to you, I would sure like to understand it for any future issues.
  • Sorry to hear you've experienced this frustrating problem! It sounds to me like your ISP blocked port 8000 for some reason. ISPs do block certain ports sometimes, but blocking port 8000 is unusual. I hope it will continue to work with port 9000; there's no reason why it should not. Hopefully your experiences will help anyone else encountering the same problem.

    Having two IP addresses usually indicates that you are connected by both wired ethernet and WiFi. If the subnet (the first three numbers of the IP address) is the same for both addresses, then both interfaces are connected to the same network, and it's safe to turn off WiFi and simply use the (faster and more reliable) wired ethernet connection.
  • TluTrick, I feel your frustration. I tried to change wifi connection, ISP gave me a new modem-router that is two in one. So my first thought was that must be the issue. However, I see a duplicate image of my camera on my desk top in network settings when I turn on file sharing. I can not login into my admin to be sure I'm on the right wifi connection, it says this page is not accessible and not available. Something wired is going on with nanny camera as well. Everything was in working order before i got this new modem and router in one device, very frustrating. Did you solve your problem?
  • My first problem is; The wizard says it can not configure my camera even though the light is green and camera is showing in my network settings. I tired wired and wps both seem to be connecting just fine but will not configure.
  • HI Kicker, I'm not sure what wizard you are using to try to set up your camera, but we have our own instructions for setting up network cameras. If you are having problems please report back exactly what is going wrong and we'll try to help!
  • Thank you for your response. I finally figured it out. The wizard I was using was from the cd I received when I bought the camera. I installed the updated software and problem solved with the updated wizard. Thanks again for all your help, you rock! :)

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!