Widget updates slow and remote patrol slow
  • Widgets are taking an extremely long time to update, 30+ seconds. Remote patrol is virtually useless. This happened after I placed four more cameras (Axis) on to the Mac Pro.

    Security Spy 3.1.2
    10.8.5 (updated)
    Mac Pro Mid-2010
    Processor 2 x 2.4 GHz Quad-Core Intel Xeon
    Bonded ethernet connection to the gigabit switch also.
    Internet connection is 50 down and 5 up.

    I recently added a USB 3 card and have a USB 3 external drive capturing video from one camera. At the time of adding the drive and internal card, there was no noticeable difference in operation.

    Any way I can get a copy of the previous version before 3.1.2 so I can test if it was the update (slim chance I figure).

    Any advice?

  • Hi - I have emailed you a link to download the previous version 3.1.1 as requested. However nothing has really changed in the web server between 3.1.1 and 3.1.2, so I'd be surprised if your problems are down to SecuritySpy.

    The widget has a known problem where the first time it is displayed it may not show an image. Hiding and showing the dashboard again is a workaround. To be honest not many people use the widget and we don't get much feedback about it, so it hasn't had much development attention for a while! However I will have a look to see if I can fix this.

    As for Remote Patrol, I don't know of any incompatibility problems between the latest version of Remote Patrol and the latest version of SecuritySpy. If you can describe the problem you're having with it I can make some suggestions.
  • I have updated the SecuritySpy Dashboard Widget. It's now faster and more reliable. Please let me know how you get on with this new version.
  • I have downloaded and installed the Dashboard Widget, and I have setup the widget on two different machines, and neither one displays images. When I click on the widget (pretty much a white, blank rectangle) it launches a Safari browser window that goes to my SecuritySpy Webserver and logs in correctly. What am I missing in setting up the widget?
  • Just to give an update. Our widgets are working great and the problem is fixed. After updating the firmware on the Axis cameras, I had to log back into each camera. When doing this, I was presented with an option to update. I believe it was the Hz setting. I set the setting and all was well.
  • When setting up the widget, make sure that the address is entered correctly, as per the below screenshot, with no forward slashes or "http" or colons etc. Also make sure the port and the username/password is correctly entered as well.
    image
  • Does the widget work with an encrypted connection? I use an SSL connection on port 8001 and all I see in the widget is a blank white window. It worked fine until I turned on SSL
  • @bilcastine - I have made some changes to the widget which enables HTTP support, and make it more intelligent about addresses and ports. Please download and install the new version of the widget, and enter the address using the "https://" prefix if you want to use SSL.

    So for example, if your SecuritySpy server is at 192.168.1.1, instead of entering http://192.168.1.1 (or simply 192.168.1.1) as the address, enter https://192.168.1.1 - no need to enter the port if you are using 8001, as this is SecuritySpy's default HTTPS port and the widget knows this.
  • I'm using the reference widget, but I can't get it to connect to SS with HTTPS. Works fine with HTTP. I also used 8001 and tried to leave the port blank, but the widget fills it in with 8000 if blank.
  • P.S. I love the widget and use it all the time. I had to switch to TLS to prevent passwords from being passed in the clear.
  • Hi mmatyas, if the widget is automatically filling in 8000 in the port box if you leave it blank, then you are using an old version. Please download and install the latest version of the widget. Then, include "https://" in the address that you enter into the widget and leave the port box blank, as described above.
  • Thank you. You were correct. I was using the old widget. Confusingly, when I downloaded the new widget Yosemite appeared to automatically install it, but didn't overwrite the old one. I had to go to ~/Library/Widgets and delete the old one before I installed the new one to make it work.
    Love the new widget even better than the old...
  • mmatyas - great to hear you have this working now. It's strange that you had to delete the old one manually, we haven't heard of this before, maybe it's a bug in Yosemite. We'll make sure to advise other users to do this if they are having problems.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!