Updater installed an unsupported version, killed all my settings!
  • Yikes! The auto-updater has been after me to update. I should have just ignored it, but I let it do its thing. It installed some version that wouldn't launch. (Dialog said it was incompatible with my system, contact the developer). An installer that knowingly installs incompatible software is a poor move, but whatever. I'll go download the latest build that works with High Sierra. I install that and find it's totally lost my cameras and registration...

    This is pretty unacceptable. Anyone know how to restore what I had? I'm not even sure what version it was. The installer didn't just move it to the trash, but nuked it entirely. Another thing an installer shouldn't do.
  • There are three "SecuritySpy Preferences v7X" files in ~/Library/Preferences. They don't seem to be typical plists so I can't plutil them to know if they're my old settings. The plist that is there (com.bensoftware.SecuritySpy.plist) is just window positions.
  • Figured out via my emailed registration that I did have v5. However the current downloads for 5.3.0 don't work on my machine. I found a guy with the same problem on here, and a link to 5.2.5 which does load. My registration appeared, but all but one of my cameras are gone.
  • Up and running after rebuilding my setup. I'd encourage whoever is working on the updater to move the old app to the trash instead of rm'ing it (so it can be moved back). Additionally, it would be good be to understand that some versions of 5 use symbols that don't exist in some builds of High Sierra and not try to update to those.
  • Sorry this happened to you. The installer absolutely does check the macOS system version, and only attempts to install new versions of the software that it thinks are compatible.

    What appears to have happened here is that there is a symbol (i.e. a function or some other entity in an Apple API that SecuritySpy uses), that is marked by Apple as being available in macOS 10.13. However it turns out that the symbol in question is only in the latest 10.13.6 release, but not in earlier 10.13.x releases of the system. Therefore, if you attempt to run SecuritySpy v5.3 on some older release of 10.13, you get this error.

    It's hard to know what we could have done to prevent this. There is no indication in Apple's documentation that the symbols we are using are not present on earlier releases of 10.13, and we can't really be expected to test the software on all point releases of all macOS system versions; only the latest available of each supported system. Virtually all users would either be on the latest 10.13.6 release by now (after being prompted constantly by the system for the last 3 years to update!), or else would have updated to a later macOS version by now.

    Unfortunately, in this case, it won't be easy to avoid using this symbol, as it is required for some of the newer eGPU features added to SecuritySpy. However I'll see what we can do for the next update. Otherwise, I'll get our auto-updater to recognise this problem and prevent installation.
  • Understood. Thanks for your reply and your efforts.
  • Just to follow up on this, we have now set our auto updater to test for a minimum system version of 10.13.6, rather than 10.13.0, so this should prevent this situation arising for anyone else.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!