Action not being triggered
  • I have an action set for motion trigger as a POST to a local REST server (curl -X POST -d "announcement=Someone is at the front door!" When I run the shell command it works fine, but when I tigger the camera capture, the video shows the triggered action but the script is not run. This in on MacOS 10.15.7. Any suggestions?
  • The first thing to check is that Actions mode for this camera is armed, for example on a schedule such as "Armed 24/7". So you should see an orange "A" indicator in video windows and the Camera Info window for this camera, that turns red when motion is detected. Could you please check this?
  • Yes - Action is armed 24/7 and the "A", along with the "M" turn red when motion occurs, and after a few seconds the "A" goes back to yellow.
  • That's strange. If you click the "Run" button next to the shell command under Preferences > Cameras > Actions, does it execute as expected?
  • Yes it does - works every time. Actually as an update, it started working, but not consistently. I can't see any server responses to see if that's the issue, but I'll see how this goes - thanks
  • As an update - after a power failure and re-boot of the Mac running Security Spy - the curl action is no longer being triggered. In fact, I can't remember the last time it was triggered so it failed at some point. In preferences I can manually trigger the action (/Cameras/Actions/Run Script). This particular camera records motion videos, so the capture settings appear to be correct. FYI - I had Action delay set to 0 and Action reset time to 10 (the defaults). I reset those to 2 and 30 respectively - still no action triggered. Is there a log that I can use to debug this?

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!