Time Lapse Broken in 5.2.7
  • Hello Ben and community. One of my cameras is tasked with creating a daily time lapse video from sunrise to sunset. Up 'til now I've achieved this by setting a continuous capture rate of 0.006 frames per second (which is around 22 frames per hour). The video created each day plays back at 15 frames per second -- lovely effect.

    After upgrading from 5.2.6 to 5.2.7 (and not having changed any preference settings) the video produced ended up being a realtime recording of the whole day from sunrise to sunset. Lots and lots of gigabytes.

    My question is: is there a new method in this latest version that needs to be employed for recording video at much-less-than-one frame per second rate? Thanks in advance!
  • Hello - currently, 5.2.7 is a beta version, is this what you are using?

    Assuming your camera is sending a temporally-compressed format (H.264 or H.265), in order for SecuritySpy to change the frame rate of the incoming video, you will have to enable the "Recompress video data" option under Preferences > Cameras > Device. Is this option currently set?

    Perhaps with the update, this option was unset accidentally, or perhaps the format of the incoming video changed somehow?
  • Hi Ben. Apologies, I misspoke. It was the automatic update from 5.2.5 to 5.2.6 when the change happened. I did not download the beta version.

    Sorry for including the wrong version number so prominently in the title.

    I've reverted to 5.2.5 and everything went back to normal.

    The camera is an old IQinVision 705 model (so the video is probably motion JPEG?). The Recompress Video checkbox is unselected.

    I'll do a study tonight and report back: I'll screen grab all the preference option pages for that camera and run the update and check for any changes.

    Thank you!
  • I've done a bit more testing here, and it looks like this is a bug in 5.2.6. Sorry about this, I'll investigate further and let you know when this is fixed. The bug seems to happen when using JPEG video specifically.
  • In the meantime I updated to 5.2.6 again and selected Recompress Video for that camera.
    Today's time lapse video came out perfect. Thank you for looking into it and for suggesting a perfectly good workaround!
  • Great to hear the workaround worked. In fact, since the incoming video is in JPEG format, recompression to H.264 is probably the best thing to do anyway, as you will end up with much more efficient captures (saving the camera's JPEG data to the movie file will give you much larger files than getting SecuritySpy to recompress this to H.264). Just make sure that the camera is set to a high compression quality setting, to minimise the quality loss due to the recompression.

    Meanwhile, I've identified the problem and it will be fixed in the next update, which will be released soon (hopefully next week).
  • Thanks again and thanks for that advice!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!