5.2.4b7 shows SW decode
  • I ran into issues with 5.2.3 and not recording anything despite being armed and not overridden (previous version was fine) so I updated to 5.2.4b7 and am hoping that fixes the issue, but I noticed something interesting. The 6 low-res streams that I'm using for motion detection show "SW" for decoding.

    I'm running OSX 10.13.3 with an nVidia GeForce GT 730 with the default (OSX-provided) drivers. Is this expected, or did I do something dumb to kill HW decode support? All the cameras spit out h.264 on two streams, a 1920x1080 stream and a lower quality 352x288 stream.
  • What is the Mac model? Hardware decode depends more on the CPU than the GPU.

    Each Mac will have a limit to the number of streams it can decode in hardware - perhaps you are simply exceeding this limit.

    The other possibility is the video codec - enable the "Format of Incoming Video" column in the Camera Info window, and verify that the format is indeed H.264 (if, for example, the format is JPEG, then this can't be decoded in hardware).

    The other possibility is the video resolution. When decoding a video stream, SecuritySpy always requests hardware decode (unless the user has disabled this using the new options), and it's up to macOS to decide whether to actually do the decode in hardware or software, depending on some opaque criteria. It's possible that either this video size can't be decoded in hardware for some reason, or the system decides that it's not worth using the hardware for such a light task.

    In terms of recording, this does sound like a settings issue (there is no known bug in v5.2.3 in this regard), so if you are still seeing this problem, please email us and include screenshots of your recording settings, and the Camera Info window, so that we can check everything over.
  • aha; this is a first-gen i7 (i7-950) hackintosh that works very, very well, but those first gen i7s did not have any of this acceleration. I might move the SS install over to a mid-2011 Mac Mini.

    I'm using the reduced-resolution streams because continuously decoding 6 1920x1080 h.264 streams maxes out one of the cores on the i7; my CPU load went from 114%-ish to under 10% with the reduced resolution streams.
  • That's right - the i7-950 does not have Intel's Quick Sync Video module for hardware video decoding. The mid-2011 Mac minis have Sandy Bridge CPUs, which was the first generation to include Quick Sync Video, but I believe these can only handle one stream in hardware, so your Hackintosh will probably still be faster overall. The latest Intel Core CPUs can decode 16 simultaneous H.264/H.265 streams in hardware, so the technology has come a long way since it was introduced back in 2011.
  • Hi Ben, great addition to the info window. I am using a late 2012 Mac mini quad i7 for 10 cameras.
    I see that the "HW" is only enabled when "Enable video motion detection" - Triggers, is selected. This puts resources on the CPU. If that option is not enabled, the CPU sits at 0%, with a description of " ... "

    What does " ... " describe?

    All streams are H.264

    Thanks as always for the great work with the software!

    Chris
  • Well, I sorta figured it out.
    I am taking it that " ... " is just in a direct stream state.
    When I open SS on iOS the description immediately switches to "HW".
    Nice to know this 2012 quad i7 mini is still a beast!

  • Hi Chris,

    In the new Video Decode Status column, the indicator "..." means that decoding is not happening (yet) for that camera. This could be because the camera is in the process of connecting, or it could be because you have enabled the "Decompress incoming video frames only when required" option in the General Preferences, and no decoded video frames are required at this particular moment in time. We thought of using "N/A" here instead, but that's kinda ugly. Let me know your thoughts.

    Yes, the 2012 quad-core Mac minis are still fantastic machines!
  • Yes, I have the "Decompress incoming video frames only when required" enabled. That explains it. Thank you.
    I like the current feedback of " ... " opposed to N/A also.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!