RTSP Video Stream, ++stream results in 404
  • Hello,

    I'm trying to pull an RTSP stream out of SecuritySpy but I get a 404 File not found error from SecuritySpy when doing so.

    The URL looks like this

    SS v5.2. I feel like I'm missing something simple. Any ideas?

  • Okay, I got it to work in VLC using rtsp://

    Now my question is: Can this work with SSL? I tried rtsps:// but just get an error.

    I have a valid SSL cert and host name working in SecuritySpy. I intend to put this behind nginx, but for the sake of being simple I'm doing my initial testing without nginx.
  • Next Question: Enabling web logs does not show the RTSP requests from VLC. Any way to show RTSP logs?
  • Good to hear you got it working - as you discovered, you need "rtsp://" at the start of the url, not "http://".

    Yes, SecuritySpy does support RTSP over SSL, however this isn't well supported in clients, and as far as I can tell, VLC doesn't support RTSP over SSL. Instead, you could use another copy of SecuritySpy as RTSP viewing software if you want to achieve RTSPS streaming.
  • Thanks Ben. I managed to get Monocle Cam working with securityspy. It requires their proxy tool to work, which I was trying to avoid. I actually wound up pointing the proxy at the cameras RTSP streams directly. When viewing RTSP from SS it's almost always 10 seconds behind. Using the proxy to go directly to the cameras works OK, but it's not the best experience I've had. The Alexa device viewing the cameras cannot reach the cameras directly, so the proxy bridges the two networks (much like SS does). Re: https://monoclecam.com
  • Hi TwitchCaptain,

    I'm trying to get the Monocle Proxy to work with Security Spy but am not having any luck. My Alexa device is an Echo Spot v1. I can get Hikvision cameras to work directly but not via Security Spy.

    Can you share which Monocle settings you used (tags, auth method, ect.) and the Security Spy rtsp url?

    I've tried every combination of tag with basic and digest auth. No luck. My url is below.


    Thanks in advance,

  • Monocle has a very difficult time working with security spy. I had to point it ay my dahua cameras directly. And the quality into my Amazon Echo Show was terrible and slow, so I pretty much gave up on it. Sorry I don't have any good or useful info to provide. :(

    Good luck!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!