Remote Access issue
  • Hello,

    I am running Security Spy on a Mac mini and everything is running great except I cannot gain remote access (iOS app). It works on my local network.

    I followed the steps in the manual (setup manual address) and have all the setting correct that I can see. I have an Airport Time Capsule and put in a DHCP reservation on the address.

    Is there anything else I need to configure?

    Thanks
  • With AirPort devices, SecuritySpy can configure everything automatically, so manual setup should not be necessary. This should be a simple case of enabling the web server, and enabling the "Allow access from the Internet" options, under Preferences -> Web.

    Note that for this to work, you must have the "Enable NAT Port Mapping Protocol" option enabled in your Time Capsule (to access this setting use AirPort Utility to edit the device, click the Network tab, and click the Network Options button). This option is turned on by default - did you have this option turned off?

    To set this up manually, you not only need a DHCP reservation, you also need to add a port mapping (again under the Network tab in AirPort Utility, as described above). Click the plus (+) button under the "Port Settings" box, and enter the details as follows:

    Public TCP Ports: 8000,8001
    Private TCP Ports: 8000,8001
    Private IP Address: [the reserved IP address of your Mac]

    Then save and reboot your AirPort device.
  • Thanks for the information. I have Enable NAT Port Mapping Protocol enabled on the time capsule. I have removed the manual configuration and went back to automatically. I still get a "connection failed" error in the IOS appp.
  • OK, could you please email us and include screenshot of the Web settings in SecuritySpy, as well as the Time Capsule "Network" configuration - it may be best to help you with this directly.

    Also please check that you are using the latest version of SecuritySpy.

    Note that it's fine to have the DHCP reservation in either case - the problem here sounds like the port forwarding not working for some reason.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!