Notifications on home wifi vs LTE Issues - delay and no snapshot when on home wifi
  • Just posting this here while the devs address my support ticket to see if others are having similar issues

    Long story short:

    (1) iOS notifications when I'm on my home wifi = 30 sec delay from motion trigger and no snapshot
    (2) iOS notifications when I'm on LTE = immediate on motion trigger and snapshot included every time

    Now, I don't know if this is related to the following, which all occurred around the same time, give or take a few days:

    (1) Had to get my router replaced (for other reasons)
    (2) Installed macOS Catalina and my SS server is running on that same machine (Mac mini)
    (3) SS came out with a software update to make it fully compatible with Catalina

    I tried

    (1) resetting network settings on my iOS devices (which I should have done anyway after getting the router replaced)
    (2) rebooting router, POE switch and regular switch
    (3) made sure I have automatic port forwarding turned on in SS and have UPNP enabled in my new router configuration
    (4) deleted the server on the SS app on my iOS devices and then let it auto discover the server again and added that to the app
    (5) and, of course, confirmed that I can access the camera feeds via the SS app when on home wifi and when on LTE

    Anybody running into something similar?
  • Yes I see exactly that. But I also have an iPad Pro running side by side the iPhone just on WiFi and that works perfectly every time. Also worth mentioning that My Mac OS is 10.13 i have SS on a media Mac that has not been updated to Catelina but did install the ss update ) and tried the ss latest beta)
  • Interesting that your iPad is working fine

    My iPad mini, running the same iOS version as my iPhone, has the delay and snapshot issue too (it’s a WiFi only iPad, so can’t test LTE)
  • I finally figured it out!
    I reverted back to V4.X of SS and it was still broken on the iPhone.
    I dug out an older iPhone running IOS 12.4, still broken.
    Messed about with DNS settings no change.
    Then finally realised that the iPad was connecting using HTTP, which worked perfectly.
    The iPhones were connecting via HTTPS which does not work perfectly, at least not for me!

    In the IOS app signout of the server, create a new server connection but MANUALLY add the HTTP port and it all works perfectly. I'll keep digging to see if I can find out why the HTTPS only works via VPN or 4G but this is good enough for now.

    Hope this helps others, it was really annoying me as I used that for various alerts and couldn't trust it
  • What exactly are you inputting in the manual fields? I keep getting a failure to connect when trying to add the server manually
  • OK, assuming that you have the server set up correctly (I think you must have or you'd not have any notifications at all...) Press and hold on the Security Spy line in your IOS servers list and you'll get the details of your current connection. Mine was XXXXX.viewcam.me:8002. That is the default port for the HTTPS connection.
    You need to sign out of that. Then select connect, adding the same info, but instead of letting it auto select, you type in port 8001 (assuming that you've not changed the defaults in security spy setup)

    Its quite possible (probable) that on your Mac you could just go to security spy preferences, then web and deselect HTTPS at the top and it'll probably then just work without making the above changes to the iOS app, but I haven't tested that...
  • Making sure that HTTP IS selected of course :)
  • Thanks I will try again

    I wonder what the security implications may be by not using https
  • Here are my thoughts on this issue:

    The lack of notification, and the 30-second day, are both the same issue. What happens is that the text-based notification gets pushed to the device via Apple's servers; iOS then wakes our iOS app, which then attempts to obtain the image from the SecuritySpy server; if it cannot obtain the image within 30 seconds it will give up and display the text-only notification.

    As discussed above, the HTTP vs. HTTPS connection type seems to be related to this issue, but it's not entirely clear what specifically is going wrong yet.

    @evansgo - one thing that I notice in the discussion above is that you are using port 8001/8002 for HTTP/HTTPS. These are not SecuritySpy's default ports - the default ports are 8000/8001. It shouldn't make a difference, but perhaps this is causing our iOS app to get confused about the protocol type and causing a failed connection.

    So, could you please reset to the default ports of 8000 and 8001 and see if this resolves the problem?
  • Ah ok thanks. I must have changed them in the past for some reason, I’ll run some tests using your real defaults and get back to you.
  • @ben Would making the changes on the server side (ie, SS Mac app Preferences) in the form of unchecking the https option effectively be the same as what @evansgo described in the iOS app?
  • @pinkoos - yes, this should have the same effect. With HTTP turned on and HTTPS turned off on the server, the iOS app will auto-discover the HTTP connection details and use those. After making the change, you'd have to delete and re-add the server instance to the iOS app to allow it to pull in the new connection details.
  • @Ben Thanks, I'll try configuring that way and see what happens
  • @Ben Seems I can't connect to the 8000 port only (http). I unchecked the https (8001) options in "Enable Web Server" and "Automatic Port Forwarding", applied those preferences, quit and then restarted SS on the Mac, deleted the SS server in the iOS app, let it auto discover the server again and I get the message, "Connection Failed: Unable to connect to the server"
  • OK, I reset the ports to the default 8000 and 8001 (good spot Ben, I must have changed them years ago) and it all works perfectly on HTTPS! Looks like there is a quirk in there somewhere and I was unlucky. Probably if I'd chosen a totally different pair of ports it would have worked fine...
    @pinkoos have you tried manually entering in the server rather than letting it auto discover?
  • @evansgo Yes, I tried manually but still get the Connection Failed message
  • @evansgo - great to hear that. It should be fine to use custom ports generally, but if you use either of SecuritySpy's default ports (8000 or 8001) I think the iOS app must be making some assumptions about whether to use SSL, and this must be what was preventing the connection before.

    @pinkoos - I'm seeing the same thing as you with auto-discovery: once you've set it up with HTTPS, if you then turn off HTTPS, then delete and re-add the server, you get the connection failed message. We'll have a look at this as it's unexpected behaviour. However, in this circumstance, I am able to add the server manually, so please try this again. Use the Bonjour name displayed via the "How Do I Access This Server" button under Preferences -> Web (the one ending "local"), along with the port (8000) and valid account username/password, and you should get a valid connection.
  • @Ben Question - the Bonjour server will only work on the local network, correct? If I'm off the local network, will I still be able to access the feeds if the only server set up in the iOS app is the Bonjour one? Thank you
  • Bonjour is a method of device discovery for local networks - this allows devices to find each other, and also negates the need to use IP addresses, which can change from time to time unless you are using manual IP setup.

    When you add a server manually - either with a Bonjour address, some other domain name, or an IP address - the SecuritySpy iOS app will automatically try to determine the correct details for connecting from both the local network (LAN) and from the Internet (WAN). This is determined based on the Web settings, Bonjour status, and a record of successful past connections to the web server.

    The iOS app will then retain two different addresses for future connections: one for the LAN (either Bonjour or IP address), and one for the Internet (either the viewcam.me DDNS name, some other custom domain name that may be in use, or the WAN IP address).

    So there are a few complicated mechanisms going on here under the hood in order to overcome the difficulties with making connections both locally and remotely, but there is no "Bonjour server" as such - Bonjour is just to help the addressing and device discovery on the local network.
  • @Ben Okay, I added the server manually using the Bonjour name and it was able to connect normally and using port 8000, but the notification delay and lack of snapshot problem is still present when on the home network
  • Hi Pinkoos, I think no preview images in delayed notification's locally only (if you can remotely monitor, as well as receive motion image alerts without delay remotely too). Is due to your Router not supporting "Loopback" which is rare nowadays, albeit still the case for relatively few Routers. Hence not being able to sort this issue for you in SS (despite repeated attempts).
  • Thanks @Rod, but as I had mentioned, I did enable NAT Loopback on my router and that didn't solve the problem

    Still working with @Ben to hopefully resolve this issue

    Thank you for the continued support

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!