Not receiving Push Notifications
  • Using SS 5.0.1 on Mojave 10.14.6 and iOS 13.1.1

    I think this has only happened since upgrading to SS v5, but I am no longer getting notifications on my iPhone.
    I am still getting emails through with images, etc.

    In the log, I found the following:
    26/08/2019 09:11:23: Could not send Apple Push Notification for the camera "Kitchen" 5.0.1,31150,-25300
    ...
    01/10/2019 11:58:55: Could not send Apple Push Notification for the camera "Kitchen" 5.0.1,31150,-25300
    01/10/2019 12:09:34: Could not send Apple Push Notification for the camera "Kitchen" 5.0.1,31150,-25300
    01/10/2019 12:19:59: Could not send Apple Push Notification for the camera "Kitchen" 5.0.1,31150,-25300
    01/10/2019 12:33:48: Could not send Apple Push Notification for the camera "Kitchen" 5.0.1,31150,-25300
    ...
    02/10/2019 15:58:31: Could not send Apple Push Notification for the camera "Kitchen" 5.0.1,31150,-25300

    Those are the only instances with this message in the whole log.

    I've gone through the FAQ.
    I've clicked on File-Debug-Clear all iOS Notification Devices, I've disabled and re-enabled Notifications in the iOS app, and I've re-installed the iOS app, but still not receiving any notifications.

    Is there a way of troubleshooting this please? Is the issue with SS, MacOS or iOS?

    Paul
  • Hi Paul, sorry about this problem. It's definitely a problem on macOS and not iOS - but it's unclear at the moment whether this is a macOS or SecuritySpy problem. I know it sounds obvious, but have you tried restarting your Mac?
  • Hi Ben
    I had restarted my iMac as part of installing 10.4.6, so I discounted doing it again.

    Anyway, I did restart my iMac on your advice (which also installed 10.4.6 Supplemental Update 2), and this time, notifications started working again!

    Not sure if the restart or the update resolved the problem (or both), but just happy SS is working properly again.

    Thanks, Paul
  • Great to hear that! It could very well have been the Supplemental Update, we have heard that fixes a number of issues.
  • Unfortunately, it only worked for a number of days. I saw this in the logs today:

    17/10/2019 13:55:30: Could not send Apple Push Notification for the camera "Kitchen" 5.0.1,31150,-25300
    17/10/2019 13:56:02: Could not send Apple Push Notification for the camera "Living Room" 5.0.1,31150,-25300

    I was running iOS 13.1.2, Mojave 10.4.6 Supplemental Update 2, and SS 5.0.1.

    I've rebooted my iMac again and it also updated SS to 5.1.0 and am receiving notifications once more, but I will keep an eye on things.

  • There have been some changes to the handling of certificates in the latest beta version of SecuritySpy (currently 5.1.1b6) so please download and install this, and let me know if you see any problems with it.
  • Thanks Ben for your shift response.
    I'll download it and give it a go.
  • Hi Ben, I have been having this same notification problem on Catalina. This was originally on your latest pick I released of SS: after a few days notifications stop and the logs say “keychain item not found”.

    I’ve tried your latest beta as of 2 days ago (b11 I believe) and the fresh launch started working (after I had to bypass Catalina security to enable the app to launch) so I assumed it was fixed. But here after a couple days again the notifications stopped with the same errors notes in the log files again.

    So the Keychain issue does not appear to be resolved. Please let me know if there is anything I can do to help because I love the software otherwise, but I really need the notifications to work. Thanks!
  • OK I have looked into this more thoroughly and believe I have found and fixed the problem now. Please download and install the latest beta version of SecuritySpy (currently 5.1.1b16), run it for a few days, and report back. Thanks.
  • Thanks! Just installed and will report back.
  • There is a new b17 beta up, with further improvements related to notifications, so please all continue testing with this one.
  • So far b16 hasn’t failed sending notifications for me after about 5 days. Will update to b17!
  • I am having this same problem, restarting Security Spy seems to fix it, but I will try the beta as well.
  • 5.1.1b20 is sending timely notifications.
    Jay
  • also not receiving push notifications.
    clicked the link above to install the beta and got an error that it had been replaced...
  • 4.2.12 is the version I am using.
  • As the beta page says, the beta has now been superseded by an official update, available from the SecuritySpy download page.

    Also, please follow the troubleshooting steps in this FAQ: I'm not getting iOS notifications - how can I troubleshoot this?
  • I did the update to version 5 and I got some notifications. YAY.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!