SecuritySpy is crashing my network, need help turning off UPNP
  • Been having ongoing issues with our whole house network crashing every so often over the past few weeks

    My home network/automation dealer has been working on trying to figure out what has been going on and he (along with our router manufacturer - Araknis) narrowed it down to SecuritySpy

    Basically, Araknis is saying that the frequent UPNP requests for port mapping is causing the WAN port to lock up causing network outage to the house

    If there are steps in the SecuritySpy software that allows us to turn OFF UPNP my dealer can then manually open the ports on the firewall for the remote server

    Ben, if you or somebody else is able to help, please chime in, thank you
    ============================================

    Here are the pertinent lines from the router's logs:

    Oct 1 11:30:56 2019 System Log NSD SUCCESS WAN[1]
    Oct 1 11:20:16 2019 System Log NSD FAIL WAN[1]
    Between these 2 NSD Failures, logs show these lines every 60 seconds (SEE BELOW WHERE IT SAYS THESE LINES REFERENCED ABOVE)
    Oct 1 06:27:56 2019 System Log NSD SUCCESS WAN[1]
    Oct 1 05:48:27 2019 System Log NSD FAIL WAN[1]


    These Lines Referenced above
    Oct 1 11:10:09 2019 Kernel upnpd[538]: AddPortMapping: RemoteHost: Protocol: TCP ExternalPort: 8001 InternalClient: 192.168.1.175.8001
    Oct 1 11:10:08 2019 Kernel upnpd[538]: AddPortMapping: RemoteHost: Protocol: TCP ExternalPort: 8000 InternalClient: 192.168.1.175.8000
    Oct 1 11:09:09 2019 Kernel upnpd[538]: AddPortMapping: RemoteHost: Protocol: TCP ExternalPort: 8001 InternalClient: 192.168.1.175.8001
    Oct 1 11:09:08 2019 Kernel upnpd[538]: AddPortMapping: RemoteHost: Protocol: TCP ExternalPort: 8000 InternalClient: 192.168.1.175.8000
  • This feature is controlled by the "Allow access from the Internet" settings under Preferences -> Web. If you turn these options off, SecuritySpy will not issue UPnP packets.

    I'm surprised these packets are causing problems - SecuritySpy's UPnP implementation is fairly standard, and we have not have any reports from other users of any similar problems. There is no reason why UPnP packets should cause this. Please report back and let me know if turning off UPnP does indeed resolve this problem - if so, I would have to conclude that your router has a buggy UPnP implementation.
  • So if I uncheck both those options, does my dealer still need to do something in the router configuration, like mentioned above (manually open the ports in the firewall)?

    By the way, thank you for the quick response. This issue has been going on since September 11 and we've been slowly trying to figure out what was going, thinking maybe it may be a hardware issue (router, switch, etc.), a camera/POE injector issue (thought highly unlikely throughout the trouble-shooting process) or something else we couldn't think of. My dealer finally dumped the logs, analyzed them and got on a long call with Araknis who looked them over and discovered this issue.

    We were literally a day or two away from replacing the switch as it seemed that rebooting the switch only (ie, not the router) was the only way to get the network back up each time it went down!
  • Instructions for enabling Port Forwarding (to SS/Mac) manually on the Router nearest your internet connection (with any/all between it & SS/Mac, set to "Bridge" mode) are to be found under "Port Forwarding - Manual Setup" in the Installation manual, here: http://www.bensoftware.com/securityspy/installationmanual/#port-forwarding-manual
    With instructions for your specific model of Router, potentially available on www.portforward.com
  • Thank you
    I went ahead and unchecked those two boxes that Ben referenced above and then tried remote access and it all still worked, so it's possible I may not need to do anything at all on the router side of things
    Does it make sense that it would still work with the automatic port forwarding turned off (ie, unchecked)?
  • The router is probably still remembering the UPnP port forwarding, which it will forget after a period of time and/or a router restart. So yes, you will need to set up manual port forwarding.
  • Yes, that's why my dealer thinks too - he's going to reboot the router remotely and then I will test again
  • Somehow it's still working, even after a router reboot
  • Ugh, network just went down again even though I turned off automatic port forwarding (though we never had to set anything up manually after that as the remote server was still working)
  • Next step is to keep the NVR software turned off (ie, not running) and unplug the POE injector so that those two things are completely taken out of the equation and see what happens over the next couple of days
  • I think if there is no firmware update for your router that fixes this problem, I would encourage you to use a different router. It sounds like your current one is simply not reliable.
  • I went into the router configuration page just now and it's still showing SecuritySpy 8000 and 8001 ports as being forwarded under UPNP even though I turned that off in the SS Web preferences and despite the router being reboot a couple of times already

    I took a screenshot but not sure there's a way to attach it here
  • Hi, UPnP is enabled (only) on a Router, and then when Automatic Port Forwarding in SecuritySpy is enabled, SecuritySpy can use this (UPnP) capability provided by the Router. Thus disabling UPnP on the Router should be enough to prevent this issue (although feel free to disable Auto Port Forward in SS as well if you wish).

    While for further assistance, it may make more sense to reply to your email (ticket number 49087) as you can attach screenshots to this, plus supply make/model and firmware version of your Router too.
  • Okay, I will respond to the ticket, thank you very much for the help
  • Hi, glad turning off SecuritySpy confirmed issue wasn't with SS (as Router crashing was still present) as per your ticket. While I've replied to your other post regarding recording/remote viewing etc, a fifth camera in a four-camera license.
  • Yes, thank you Rod for all the help with the ticket, I really appreciate it

    Definitely made my decision to buy the 4 camera license a no brainer after experiencing great service from you and Ben
  • Great, many thanks!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!