Snapshot not being included in the SecuritySpy IOS app
  • OK now this is definitely being caused by something I have done, but I’m hoping someone can help me diagnose it.
    I’ve recently installed a new firewall at home (pfSense) and i’m Learning about it, and this is where the issue is.

    If SS triggers movement, it sends the notification to my iPhone as it should (so the port forwarding works ok) and if I have my phone VPN on then I get the little picture in the notification, but if I don’t have the VPN on then I sometimes don’t get the notification and never get the included snapshot.
    Can anyone tell me what may be blocking this? I have tried the logs but I must be looking in the wrong place as I see nothing helpful
  • The notification itself is sent to the phone via Apple's servers, and just requires that SecuritySpy has an outgoing Internet connection.

    Once the notification reaches the phone, iOS then activates our app for a short time in order to obtain the notification image. For this to work, SecuritySpy's web server must be set up with remote access from the Internet (i.e. this is an incoming connection to SecuritySpy).

    So for the notification images to work, you must have set up Remote Access to SecuritySpy over the Internet. You can check if remote access is working by opening our iOS app on your phone and seeing whether you can view your cameras.

    It sounds to me that there is some problem with your port forwarding that is preventing remote access - check out the above link for instructions on how to set this up, and if you can't get this working please email us and include screenshots of all relevant settings (mainly SecuritySpy's web settings and your router's port forwarding settings if you have configured these manually).
  • Hi
    Thanks for the detailed reply, but remote access is working perfectly externally as is everything else apart from the image :). It may be that because it request is incoming and not a response it’s being blocked I’ll keep digging
  • OK some more info and I do understand that this is a very specific issue, so very much appreciate any help you can offer.

    I can see the live stream on the iOS app both locally and remotely.
    If I activate it from the wifi, then the alert sometimes comes through, but no image. However if I turn on my VPN OR switch to 4G then straight away it all works and usually I will get several at once, its as if they are queued up. Unfortunately the firewall logs are not helping me much...
  • OK I've finally found the issue, obvious once you know! In case it affects anyone else, I was using pfSense firewall and with that you need to enable NAT reflection (hairpin) for the pass rule to work when using internally on a LAN, which was why it worked with the VPN and the 4G connections.
  • OK, great to hear you found the issue. This must also have been blocking general viewing of your SecuritySpy server in the iOS app too, right?

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!