Foscam G2 Capture FrameRate
  • I currently have two Foscam Cameras. (1) FI9900P works flawlessly. I recently purchased another one. I didn't realize it is model number G2. I am receiving a really choppy video feed to SecuritySpy. I am using the profile Foscam H.264 format H.264 RTSP. Anybody have any thoughts. The feed looks great through the Foscam App.
  • I just started receiving this error. (Failed to decompress incoming video frame 22185,-12909 Image data decompression failed - bad data)

    I went back to using a network cable to connect to see if that helped. But it did not.
  • It sounds like SecuritySpy is having trouble decoding this camera's video stream.

    The first thing to check is that you are using the latest camera firmware available from Foscam.

    Secondly, log on to the camera using a web browser (Safari) and locate the camera's video encoding settings. If possible, select "Baseline" H.264 encoding, with VBR (Variable Bit Rate) rather than CBR, with a medium quality setting, and a key frame rate setting around double the frame rate.

    Does this fix the problem?
  • Within the web browser I cannot find the Encoding Settings. I do have the following options set. Resolution 720P, BitRate 512K, Frame Rate 15, Key Frame Interval 30, Rate Control Mode VBR. I tried changing some of the settings but are still getting the same results within SecuritySpy.
  • I also validated that I have the latest firmware.
  • I'm afraid I can't think of anything else try try apart from the camera's encoding settings and firmware. The other thing I would have suggested is to try connecting the camera by wired Ethernet, but you said you already tried this.

    Are you perhaps able to return this problem camera and get something else (not Foscam)?
  • I'm also seeing a similar error on a dahua camera

    Error from camera "CAM-04", it will be closed. (22185,-17690)
  • Hi @mustangthz this is a different error, related to video decompression. According to Apple, this means "decoder removed", but this itself is cryptic and there is no further explanation.

    Could you please let me know which version of SecuritySpy you are using? Are you seeing any video from this camera at all? Or just this error?

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!