v380 Shenzhen IP camera
  • Has anyone had any luck getting an inexpensive Chinese Shenzhen WiFi IP camera set up with SecuritySpy? Like this one https://www.ebay.com/itm/323626421368

    The camera supports ONVIF and SecuritySpy detects it as a ONVIF camera but it just times out when trying to connect to it.

    The only record in the log just says this....

    02/01/2019 11:27:59: Error communicating with the network device "Network camera". 4.2.9,70900,800 Failed to obtain video frame from network device. The operation timed out.
  • I had a similar issue with a completely different make of camera, and the following helped me:
    - In the Cameras section of the Preferences window, create a new network device.
    - Under the Device tab, set the device type to "Manual configuration”.
    - Enter the camera's IP address (192.168.0.xx) but leave the Port fields empty.
    - Enter the camera’s username and password.
    - Select "RTSP TCP” from the Format menu.
    - Enter onvif1 as the Request.


    might be worth a try in your case, only takes a second to give it a go...
  • thx for the response .... unfortunately for me it didn't help :(
  • does it work with vlc? that is always a first step for me just to make sure it is working...
  • no, ive not been able to get it to work with vlc either
  • That error code indicates that the ONVIF negotiation succeeded, but the video stream connection timed out. This indicates that perhaps the video stream is running on an unusual port, rather than the default of 554 (this should be automatically detected during the ONVIF negotiation, but perhaps this is not happening for some reason). Check the camera's settings pages for any indication of which port it is using for RTSP.

    The next thing to try is the "Auto-Detect Profile" button in the Device settings in SecuritySpy (under Preferences -> Cameras -> Device). This goes through all known camera profiles, to attempt to find one that works.
  • thanks for replying. The auto-detect didn't find anything. As far as I can tell it's suppose to be using port 554 but is there any way for me to tell for sure? I have a number of these cameras so it sure would be nice to be able to get them working with SecuritySpy if possible
  • I found this thread that has a link to new firmware http://community.netcamstudio.com/t/v380-stream-url/2778/9

    Once flashed I get the camera to come up, but I frequently get timeouts (more often than not) Is there a way to set the amount of time SecuritySpy waits for the stream?

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!