Error 400
  • I have a Midas-Link ML-223SD PTZ dome camera. They went out of business shortly after I purchased it (and some 206 bullet cams: anyone know how to reset these to factory defaults - no button to be found???)
    It worked fine until dislodged from its perch in a hurricane a couple of years ago. It was tested and seemed fine but has been waiting to be reinstalled.
    It now produces Error 400 when added to SecuritySpy - 11/18/2018 12:45:42: Error communicating with the network device "PTZ". 4.2.3,8440,400 Failed to obtain video frame from network device.
    It is connected as ONVIF, RTSP TCP as previously
    Looking at it using ONVIF Device Manage on a Windows laptop, the video displays and the PTZ works. No errors. Everything seems fine.
    rtsp://192.168.1.182:554/stream1 also produces video using Safari/VLC on a Mac.
    Any ideas why it is failing in SecuritySpy?
    Any suggestions to get it working most appreciated...
    Jeff
  • Hi Jeff,

    You are using a rather old version of SecuritySpy - please download and install the latest version of SecuritySpy - does this fix the problem?
  • Thanks for the suggestion, Ben.
    Unfortunately it is still the same:
    11/19/2018 19:59:56: Error communicating with the network device "PTZ". 4.2.9,8440,400 Failed to obtain video frame from network device.
  • 15 minutes later it is suddenly working - after just changing the IP address and putting it back again and saving.
    I'll take it...!
    Thanks again...
  • That's strange! Well I'm glad to hear it's all working again.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!