Foscam R2C - Bad Image Data Error
  • I am not sure if anyone has tried the R2C camera. I have had good luck with Foscam with SecuritySpy in the past. I can access it via their mobile app and the webpage. But cannot get SecuritySpy to connect.

    I keep getting the error "Bad Image Data". Not sure where to go next to resolve.

    The following profiles were recommended via the "Auto-Detect Profiles" option when setting up the device:

    - Foscam H.264 with format "H.264 RTSP"
    - ONVIF with format "RSTP TCP"
    - ONVIF with format "RSTP TDP"

    I have validated it is not a password issue.

    Any suggestions on how to debug would be great!


  • Solved my own problem. Not clear why, but had to adjust the Video quality settings to the following:

    Resolution: 720P
    BitRate: 512K
    Frame Rate: 15
    Key Frame Interval: 15
    Variable bit rate: yes

    It is what I had a FI9829P set to as well. Hope this helps someone.

  • I am having this problem but I don't see where this is done. I am guessing that these are camera settings in the camera itself. But I don't see where I can make these changes on my R2C camera. I will ask FOSCAM for assistance.
  • Didn't need to contact FOSCAM support. I have my camera working with SecureSpy now. I couldn't get the downloaded software to work so I had to find my camera's IP address another way. Once I had that I could login to the camera. I only had to change the Key Frame Interval from 30 to 15.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!