iOS App Crashing on iPhone Xs Max
  • I have the new iPhone Xs Max and when I use the mobile app, I can see thumbnails fine. But, when I go to view a captured file, the app crashes and even causes the iPhone to do a hard reboot. If the capture is a low resolution camera (such as VGA) it will view it. But, I have a few 2K cameras and the captured files cannot be played back on the iPhone. Anyone else experiencing this. Thanks. Marty
  • I was hoping the update to Security Spy and going to MacOS Mojave would solve this issue. It's still the same. I can view video of low resolution camera, but the higher (like 2K) will only play a black screen, and if I scrub through the video, it crashes and totally reboots the iPhone. Anyone else at all experience this. I am on the iPhone Xs Max. Thanks much.
  • One additional thing I’ve discovered. The web interface does the same thing. If I try to play the video on high-quality it’s just a blank screen but low-quality I can view.
  • Hi Marty,

    This sounds like a bug either in our app or in iOS itself. You are the only one to report this as yet, which may indicate that it's a certain resolution or encoding particular to your setup that is triggering the problem. Also if it is rebooting the phone itself, this indicates an iOS issue. However we will look into this and hope to have a fix soon.

    As for the problem with playing back in a web browser, please see this FAQ: Why can't I play back captured files in a web browser?.

    If you modify your encoding settings to get the videos working in a web browser, it would be interesting to see if this also fixes the iOS problem, so please let us know what you find.
  • Ben, it worked on my iPhone 7 plus. It’s only on the iPhone Xs Max That crashes the app and reboots the phone. I have iOS 12 on some iPads and will try it there as soon as possible. My wife is traveling and I will try it on her iPhone 7 Plus with iOS 12 when she arrives home. I have no problem playing back on the mac. It’s only on this phone Which is less than a week old. I know that resolution scaling is different on this phone and I feel like that is part of the issue. I do not think it’s in the app whatsoever. It’s something about the resolution of this phone. After more testing I will let you know. Thanks much for your response.
  • Ben, I've been testing, and I can view captured footage just fine on an iPad air running iOS 12 via the Security Spy iOS app as well as accessing the server via Safari on the iPad. I can view the captured files fine from everywhere expect an iPhone Xs Max. I can view the live cameras and thumbnails of the captured files. But, when I hit play, it's a black screen and if I scrub forward and back on the black screen the phone reboots. This is some issues with me and the iPhone Max. I'll work to get to the bottom of it. I do have "zoom" mode enabled on the iPhone and changed to standard, but that did not help. I can't even view the captured files via Safari on the iPhone Max. If anyone has any suggestions, I would appreciate it. I'll keep researching. I can view fine on anything expect the iPhone Max. Marty
  • Ben, I was able to fix it by check "recompress video from this camera." That is all I did. I changed nothing in the camera nor any other settings in Security Spy. What did this do exactly. I know Security Spy will us more resources, and I've never had to do that before. I'm very thankful to get it working. Now, I'm going to try changing the video codec in the camera and see if I can uncheck to recompress the video.
  • to follow up: No matter what changes I make in the camera (h264, h264.B or h264.H) the iOS app will only play back if I have recompress checked. This is what I'll do so I can view captured files remotely on the iPhone Xs Max. It's an Amcrest 2K camera, and something about the encoding directly from the camera caused issues on the iPhone. I have five cameras like this, and so I'll recompress all and see how much of a CPU usage increases it causes. All other cameras work fine uncompressed (Some Axis and two Panasonics).
  • well, all is back to normal without recompression. I set the camera to VGA and that worked. I then went to 720p then up to 1080p. (I have some cameras that are 2304 x 1296 so I'll see if this works with them as well.) As I walked it back up, it kept working and is working with all original settings. Somewhat odd, but it's working fine. I appreciate you looking into it. I just need to do this for the other cameras. I depend upon the iOS app to do quick checks when away and really missed when I could not view captures.
  • One more comment, and I hope maybe last as not to clutter up the forums-- The 2304 x 1296 cameras will only work with recompress checked in Security Spy. I honestly cannot still really an CPU difference with five cameras having "recompress" checked. Since I made no other changes in Security Spy (such as overlays, etc) I would assume that much extra work is being done by Security Spy. I wonder what this fixed it. It had always worked without it, but on this phone, I seemingly much have that checked. But, the bottom line-- all is working perfectly at the highest resolution of each camera.

    Somewhat unrelated. Do you recommenced H264 or H264.H? 264b puts artifacts on the camera stream.
  • This is all very interesting. When you have the "recompress video data" option enabled, SecuritySpy will decompress the incoming video from the camera, and then recompress it based on the compression settings set in the Preferences for the captured movie files.

    Without the "recompress" option enabled, SecuritySpy takes the camera's data and writes this directly to the movie files. So it is apparently the camera's H.264 video data that is crashing your iPhone XS. We know the camera's H.264 video data is perfectly fine, because there are no decoding issues on your Mac or other iOS devices, so the fact that this is crashing your iPhone XS definitely sounds like an iOS bug.

    I would suggest you enable the recompress option until Apple has fixed this bug. If you can email us a short example movie file that causes this problem, we can file a bug report with Apple.

    H.264B is "baseline" encoding, which is the simplest profile. H.264 is standard and H.264H is "high", which just means that it uses more complex processing to produce a lower bit rate at the same quality (at the cost of higher encode/decode processing requirements). I would generally always recommend baseline as this is the most compatible with decoders, but if you are seeing better results with the standard H.264 setting then you should use this instead.
  • Thanks for your detailed response, Ben! This helps very muc and I agree that it seems to be a bug in iOS. Regardless, I’m thankful everything is working and I will email you an example that is uncompressed that crashes the phone. I will look for a contact email at the top of the website.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!