PreCapture Time issue with new camera
  • I'm having an issue with the precapture time on a new Hikvision camera that I added to my camera list.

    I am recording movie motion capture only on this camera and I have the precapture time set to zero. What I'm noticing is that there is 7- 8 second pre-capture recording before the actual trigger is captured, despite the zero precapture setting. (I've tried changing the precapture to 1 or 2 seconds; it doesn't make any difference.)

    (The placement of the camera is on a window sill and the usual trigger is a car driving by in front of my house.) I've watched the motion detection mask turn red while a car is going by, but when I watch the video recording made, it still has that precapture of 7-8 seconds!)


    I've ruled out other objects in the video that are prematurely triggering the capture. It captures the cars predictably without problem, but I can't eliminate the 8 second precapture on the video. I haven't seen this with my other cameras. How can I debug this?
  • H.264 video streams are temporally compressed, comprising infrequent "key" frames (I-frames) with multiple "delta" frames (P-frames) between them. The key frames are independent, whereas the delta frames depends on the previous (and/or next) frame. Recording has to start on a key frame, so when there is a motion trigger, SecuritySpy has to go back and start recording on the last available key frame. If your key frame interval is very high, this can give you a long lead-in of video before the motion event in the recorded files.

    To avoid this, you need to find the key frame interval setting in the camera's encoding settings (this is sometimes called "key frame rate", "I-frame Interval", "GOV length" or "Intra frame period"). Connect to the camera using a web browser (e.g. Safari) to change its settings. I would recommend a key frame interval that is 2x the frame rate - then the maximum length of time between key frames, and therefore the maximum duration of this lead-in period in recorded files, will be 2 seconds.
  • Hi Ben,
    Thank you! That solved the problem!
    (frame rate was 8fps and the i-frame rate had been set at 50; I changed the i-frame rate to 16 and the problem was solved!)

    Glenn

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!