Connect SS to a camera at a remote location?
  • I need to put a camera up temporarily at a new location where no Mac is available. By plugging the camera into a router I can use the camera manufacturers software to view the feed on either my iPhone or my home iMac, but the software is pretty poor and not suitable for my needs, unlike the wonderful SecuritySpy.

    So, although I doubt this very much, is there any way I can add this remote camera to my original SS setup so that it is seen as just another camera on my network? I know the ip of the remote router and the internal ip of the camera, so any way of accessing the feed here?

  • Yes, this is possible with a bit of setup:

    Firstly, at the camera's location, you will need port forwarding rules in the router to forward incoming connections from the Internet to your camera on ports 80 (HTTP) and 554 (RTSP).

    Some cameras can do this automatically (check for a feature called "UPnP" that you can turn on in the camera's settings). But most have to be set up manually. To do this, firstly give you camera a static IP on its local network. Then find the port forwarding settings in your router (sometimes called "port mapping" or "virtual server"). And create rules to forward TCP connections on ports 80 and 554 to the camera's IP address.

    If you have a static IP address for the Internet connection at this location, you can then simply use this IP address in SecuritySpy. However, most ISPs (Internet Service Providers) will give you a dynamic IP address that can change from time to time. If this is the case, you will need to use a DDNS (Dynamic DNS) service to give yourself a static hostname that will be updated when the IP changes.

    Many cameras have DDNS features built in, so this may be a case of signing up for a DDNS account with one of the providers supported by the camera, and then entering these details into the camera. Similarly, some routers provide this feature too.

    For example, No-IP and Dyn are two well-known companies that provide DDNS services.
  • Thats great info, thank you very much! I doubt it will work for me as I have a history of not being able to get stuff going but it actually looks pretty straightforward.
  • Well, no success so far but can't really work out why...

    The Reolink camera I am using has got a setting for UPnP so I ticked that, which gives me this in the router (a Sky SR102, the internal IP address of the camera is 192.168.0.45):

    UPnP Portmap Table
    help
    Total Entry: 6
    Index Active Protocol Int. Port Ext. Port IP Address
    0 YES TCP 9000 9000 192.168.0.45
    1 YES TCP 80 80 192.168.0.45
    2 YES TCP 443 443 192.168.0.45
    3 YES TCP 554 554 192.168.0.45
    4 YES TCP 1935 1935 192.168.0.45
    5 YES TCP 8000 8000 192.168.0.45

    I then put my IP address in the address box in the camera settings, leave the port boxes blank and put my login and password in the usual place, but when I go to the 'Setup' screen it just shows 'connecting' and then times out.

    So, I tried it a different way, I unticked the UPnP setting on the camera, which left the router UPnP Portmap table blank as expected. I then went to the router 'services' tab created a service for the firewall as follows:

    Services table help
    # Service Name Service Type Ports

    7 spareCam TCP 554...554
    8 spareCam2 TCP 80...80



    and created a firewall rule which is as follows:
    IPV6 Firewall
    Enable IPV6 firewall



    Enable Inbound IPV6 IPSec firewall


    # Enable Service Name Action LAN Users WAN Servers Log

    8 spareCam ALLOW always 192.168.0.45 (554:554) 0.0.0.0 (1:65535) Never
    9 spareCam2 ALLOW always 192.168.0.45 (80:80) 0.0.0.0 (1:65535) Never


    (Sorry if the formatting isn't very easy to read)

    So, any ideas at all, I can't see what I have done wrong, or not done at all, but this port forwarding thing is a little new to me so as always and advice would be much appreciated.

    Thanks,
    Karl



  • Hi Karl,

    It looks like the port forwarding is correct in both cases (UPnP and manual).

    So then let's look at the address you're using. How are you obtaining this IP address? You need to find out the external IP address of the Internet connection at the site where the camera is. The router/modem at this location should display this information somewhere in its web interface. Or, from any device connected to this network, go to portforward.com and your IP address is displayed towards the top right, where it says "External IP".

    But as I said, this IP address will probably change from time to time, in which case you will need to use a DDNS service.
  • Thanks for the reply, think it is solved! When I am viewing the cameras locally I use the ONVIF profile as the Reolink one doesn't work, naturally I tried that for the remote camera. Turns out I need to use the Reolink profile for that one for some reason, even though I had previously had it working locally on ONVIF, not sure why but it now seems to be working,
  • Great! It's possible that ONVIF uses a different port that isn't being automatically forwarded, so that could explain it. With the Reolink profile, SecuritySpy only needs to use the RTSP port and nothing else, so there is less to go wrong. Glad to hear it's now working.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!