Motion detection issues
  • Hi Ben,

    First off, I want to say Security Spy is one of my most used Mac applications. I really do love the ease of use and flexibility of the program. Fantastic software.

    Ok, now on to my issues. I have a macpro running El Capitan, plenty of processing power, memory and ssd disk space. Im running Security Spy on that machine. Im also running Surveillance Station on a Synology NAS. I like the setup because of the redundancy. If one system goes down the other system will take up the slack. My three cameras feed into both SecuritySpy and Surveillance Station. On all of these cameras I use external motion detection lights to illuminate the area of coverage. I dont use the IR lights that are on the cameras because they are behind glass.

    Over the past few months, I have noticed that the Surveillance Station software picks up night events where the motion detection light goes off and the camera records the event. On the SecuritySpy side for the same event, the event is not recorded. Not just a single event, twice in one night.

    I have tried changing all of the various motion detection settings in SecuritySpy for that camera but to no avail. I know that the camera works for both software systems because I have identical recordings of other motion events.

    I guess Im ready to shrug my shoulders and say “c’est la vie”. Its not a show stopper but Im a little disappointed. I hope its a technical issue and perhaps I dont understand they way the settings work. I hope thats it because I much prefer SecuritySpy over Surveillance Station.

    - Nigel850
  • Hi Nigel,

    Thanks for your kind words about SecuritySpy!

    SecuritySpy's motion-detection has a filter to ignore whole-frame changes. These are typically the result of the camera moving, sudden lighting changes, or the camera's iris adjusting to changes in ambient light. So, in most cases, a whole-frame change indicates a false-positive detection.

    It sounds like when your motion-detection light comes on, this is causing so much motion across the whole frame that it is being ignored by SecuritySpy as a false-positive.

    Let me know if you think this fits with what you are seeing. Perhaps we can add an option to turn off/on this filter in SecuritySpy.
  • Ben,

    Yes, that sound like whats happening, the external motion detection light comes on and changes the lighting immediately for a majority of the frame. Thanks for the information!

    -Nigel850
  • I am seeing something similar - an external motion sensor light triggers, but SecuritySpy does not trigger (unless there is lots of subsequent external motion.)

    An option to disable the "whole frame" motion-detection filter would be nice.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!