Cam Bug-fixing Advice?
  • Hi -

    I have a pair of Samsung SNO-L6013R cameras, which I was previously delighted with.
    https://www.hanwha-security.eu/business-security-products/sno-l6013r/

    After 2.5yrs of constant operation one of the cams has suddenly started rebooting every few minutes. The reboot obviously kills the recording and throws error messages, as well as generating many spurious videos as the IR cut moves at night.

    Since the cameras are ~£120 each I'm reluctant to just replace it and move on. So far I've tried the following, and I'd be interested in anything I've missed:

    - Update PoE switch firmware, move camera to different port (nothing else on the switch is unreliable)
    - Updated cam firmware
    - Reset everything to factory defaults except network settings
    - Removed cam from mounting and checked for physical damage to cable and cam
    - Disabled LED-IR illuminators
    - Ran a logged ping to the IP address to validate the drops in connectivity
    - Checked the timestamped log in the cam - typically looks like this: https://d.pr/free/i/fssdkW
    - Set the cam to a very low bit rate and small image size - no change to reboot schedule

    It's out of warranty so next step is probably to replace, unless anyone has any ideas?

  • Check that the ethernet cable connectors have not corroded. Try the camera on a different cable. If that clears things up, you may need to replace the ethernet plug.

    After that, the most common components to fail after several years are the electrolytic capacitors. Unless you can test, desolder and replace those without incurring much cost, you are probably better off replacing the cameras. Because you are asking this level of question, I suspect you don't already own the equipment to check ESR and replace suspect capacitors.

  • Hello -

    Thanks for the reply. I'm not a CCTV pro and have never taken a cam apart. I'll open the case before it goes in the parts bin to see if there's anything amiss. My testing equipment only goes as far as a decent auto-ranging multimeter I'm afraid.

    Luckily all the network connectors were inside the house, so if there's a problem it should be in the camera body. I did wonder if the wire had been too compressed in the weatherproof grommet, but when removed it looks OK. Cheers!
  • I guess you could go blindly replacing all the caps, but the chances of success are low.

    The one "up" side of a camera failing, is that it's a chance to upgrade to a better camera. They keep getting better of the years. The jump in day and night time image quality going from my old bullets to 2MP Starlight Dahuas was stunning. It wasn't even a close competition with 0.006 Lux sensitivity. That grainy night b&w advancing to very clear b&w or pretty good color! Worth looking around.

    I've gotten quite a few cameras from Empire Technology

    https://www.aliexpress.com/store/product/Starlight-2-7mm-12mm-motorized-lens-2MP-WDR-IR-Eyeball-Network-Camera-IPC-HDW5231R-Z-free/1200032_32837842126.html
  • Just ordered a Reolink 4MP POE camera from Amazon for £59, which has the same form factor as the Samsungs.

    https://www.amazon.co.uk/gp/product/B01AHXEHYY

    We'll see how much of an improvement it is. And yes, I have read the thread about Reolinks(!) One thing I really liked about the previous cams was the lens distortion correction and very fast & effective auto-gain control. Hopefully the new cam will be trouble-free. Thanks for your advice. :-)
  • Probably a good decision.

    Repairing something in this price range isn't a winning proposition. It's like the "Big Profit" always sought in Wheeler Dealer. Ed's labor was always "free" and didn't count against the "profit." :-)
  • OK, so a couple of hours of testing with the ReoLink and it's not looking good. The 1440P looks worse than the 1080P, and the low-light / noise performance seems really poor to me. And despite setting bandwidth on the H.264 on the camera it seems hungry for network.

    A bit of a deal-breaker is that I don't think it's possible to disable the on-board IR LEDs on these cams, which means that rain leads to Gb-sized movement files of passing raindrops. I need this feature because I use a 940nm IR illuminator (the invisible one) and I don't want a red circle of LEDs at the install location.

    Any tips from 410 users before I send it back? Very tempted to just buy another identical Samsung/Techwin TBH.
  • I have 3 of these and they all look great at 1440p.

    My settings are:
    Stream: Clear
    Resolution: 2560x1440
    Frame Rate: 30
    Maximum Bitrate 6144
    H264 Profile: High
    Anti-Flicker: Off
    Exposure: Anti-Smearing
    Shutter: 0-32
    White Balance: Auto
    DayNight: Auto
    Backlight: Off
    3DNR - Disabled
  • I would advise asking Reolink whether it's possible to turn off the built-in IR LEDs. It normally is possible in most cameras, perhaps the setting is a bit hidden. Their tech support is good.

    As for the false-positive motion detections with rain and built-in IR, this can unfortunately be a difficult problem. The normal solution is to increase the "trigger time" setting in SecuritySpy (try 2.5 or 3 seconds) as this should really help with this problem.

    However if you are really unhappy with the video quality, then you may want to send this camera back anyway. In that case, try a Zavio or Dahua bullet camera.
  • Thank you for chipping in! I've sent Reolink an email, but a web search suggests maybe the LEDs are hard-coded for the time being. Should be a firmware fix I think.

    As it is I've bought a refurb Samsung, but this time an SNO-6011R, which is a little bigger and has variable focus and defog (so more prosumer I suppose).

    Chubsta - I'll apply your settings and see how it looks :-)
  • https://d.pr/free/i/29z6Nl

    Still very noisy! For comparison, here's the Sammy camera without illuminator:

    https://d.pr/free/i/bfhLnD

    Of course, it's possible my Reolink is faulty in terms of noise performance....
  • You're right that image does look quite noisy, though it could also be due to compression artefacts if the bit rate is set too low. The best compression setting is typically Variable Bit Rate (VBR) encoding with a medium-to-high quality setting, so if this is not currently set for your camera I'd recommend trying this.

    Also, to make sure you are comparing like with like, check that the exposure setting is the same for both cameras. If the Samsung is configured with a longer exposure time, its image will be less noisy, but at the expense of greater motion blur. The exposure time should not be set faster than around 1/30 (a 30th of a second), otherwise moving objects (cars/people etc.) will have too much blur.
  • Just heard back from Reolink (you're right, excellent customer service):

    "Thank you for contacting us.
    The models that support turning off LEDs:
    RLC-423, RLC-423S, RLC-423WS,
    C1, C2, C1 Pro,
    Keen, Argus, Argus 2.

    For other models (e.g. RLC-410), they don't support this feature due to hardware limitations. We are truly sorry if this caused inconvenience to you."
  • I certainly don't seem to have the noise that you are suffering from, here is a little bit of footage, sorry about the subject matter but I haven't kept any recent stuff...
    https://youtu.be/hbZXhcQFD-E
  • Right, yes. From your amusing footage I think it's likely I've got a lemon camera. The noise seems to be vignetted around the edges of the image as well. Yours definitely looks much better.

    To confirm @ben I've been using the high H.264 profile and bit rates of 6144-8192kbps. I've also experimented with 1440P and 1080P settings. I haven't found a direct and obvious setting for exposure, but we're looking at ~12fps with the IR illumination.

    In terms of setup I have had to use a PoE injector (annoying because the netgear PoE switch I was using is the other protocol), but apart from that it's Gb ethernet to a high performance NAS with surveillance drives.

    @chubsta, do you have an IR source or another cam in that nesting box? Seems very bright in there! Your vids are remarkably crisp compared to mine!

    I've sent a youtube sample of the video to Reolink, stating that mine looks much worse than any other samples I can find online (even though using an illuminator should make it much better in terms of signal-to-noise). I'll see what they say - backup plan is to use the Amazon return process to send it back faulty. Ho hum.
  • i don’t have any extra illumination, everything is bright enough for me. seems like you may well have a duff unit. have you tried my settings?
  • Yes, tried your exact setup and I got a horrible salt-and-pepper noise mess. :-(
  • i’m out at the moment but will check later tonight in case there is anything i have missed in the reolink and ss settings
  • from memory i can see that i have exposure set to anti smearing and a value of 32
  • and 3dnr set to off, resolution is at its highest and frame rate of 30
  • Yes, thanks. I tried all of those settings but the cam was unusable at night. These are the settings that give me the best picture.... I did find that reducing the sharpness made the noise less intrusive... but it shouldn't be there at all. It's almost like it's a bad CMOS. I had this once with a consumer-grade D-Link wifi cam (terrible noise performance out of the box).
  • These are my current images in SS:

    Screengrab from a 1080p monitor (with hedgehog!) http://s1371.photobucket.com/user/karljeffery1/media/Screen Shot 2018-03-16 at 19.22.05_zpsdhhuig1c.png.html

    Screengrab showing an image full screen on my iMac:
    http://s1371.photobucket.com/user/karljeffery1/media/Screen Shot 2018-03-16 at 19.23.39_zpsoghlbn5s.png.html

    The actual recorded footage is even better as is at a higher resolution that my iMac can show but looks great on a 4k tv.

    Mine are really crystal-clear with only the tiniest artifacting so not sure what is happening with yours...
  • Update - Amazon issued a refund on the camera after ReoLink tech support went very quiet on the image quality issue. Replaced with a Samsung/Techwin SNO-6011R, which seems pretty good so far.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!