iOS App not working after upgrade to 4.1.2
  • Hi there
    I observed that the iOS App don´t catch any live view anymore after upgrading the SS-Server to 4.1.2. I´m on a SSL secured connection on a different port. Back to 4.1. beta 9 everything is normal. Error message is Server received an unexpected...
    Could you pls. confirm? Regards Uwe
  • We can't reproduce this problem I'm afraid. However we have just released an update to the iOS app (version 1.1) so please go to App Store on your iOS device and upgrade your SecuritySpy app.

    Does this fix the problem?
  • I´m sorry, but nope. Downloaded App V.1.1 and newest Server 4.1.2 again and now, when I type the credentials, the error is "The server that respond is not SecuritySpy" I can still access via Webbrowser with the sam credentials.
  • Please could you try deleting and re-adding the server to the app - in the list of servers, swipe left to delete the server. Then, as long as you are on the same local network as the server, it should automatically appear under "DISCOVERED" and you will be able to easily add it again.

    Are you using SecuritySpy's standard ports (8000 for HTTP and 8001 for HTTPS), or have you specified some custom ports?
  • Not even via VPN with the ip address instead of the FQDN. Then the error is the same.
  • Hi - did you try deleting and re-adding? What about the ports? Thanks.
  • Hi Ben, deleted and tried to add them again as follows:
    server: ss.fqdn.de
    port: 32501
    username: xxxxxxx
    pasword: xxxxxxx

    I´m using a Let´s Encrypt Certificate, wich is located as an *.p12 in the SecuritySpy folder. Ann.: After upgrading it was gone, but I added it again.
  • SecuritySpy won't use the p12 certificate - you need to supply the certificates and key in PEM or DER format using certain files names (basically in the same format that Apache uses) - read more under "HTTPS Keys and Certificates" at SecuritySpy User Manual - Web.

    Also, the details you specified don't appear to be correct - when attempting to access ss.fqdn.de:32501, the connection is refused (if it were SecuritySpy I would get a login prompt). Could you check this please?
  • Hi Ben

    no, the server address was just an example. Seems,like I have som further problems with the mac where the SS is running on it. I have to wait until this evening to log in via ARD since I´m abroad atm. I was wondering, where the certificat has been, I couldn´t find it anymore in the SecuritySpy folder after upgrading. I´ll let you know later on, if I could sort it out.
  • Hi Ben
    4.1.2 is definitely not working together with the iOS App anymore. As soon as I switch back to an older Version, it works. Could you please send me a link to V. 4.1.1 since I don´t have it anymore and 4.07 is not working with the new App anymore Appreciate, Uwe
  • Could it be, that you have to be in the same network to advertise the App to the Server? That would be unlucky cause most of my time I`m abroad.
  • Same issue here. Updated the iOS earlier morning and all was OK via 4.1. I then upgraded to 4.1.2 and the iOS app no longer works. I can connect remotely (from WAN) via the web interface, without issue, but the iOS app no longer works.

    I just get an error that says "Connection Failed" and "Unable to connect to the server". Again, I can connect to the server, via the web (Mobile Safari), using the same iPhone the iOS app is running.
  • Also—tried reverting back to 4.1.1 and it doesn't seem to make a difference. Don't have a copy of 4.1 anymore, so can't test going back to that version. And I never actually ran 4.1.1, so can't say 100% if this was introduced in 4.1.2 or 4.1.1?
  • Sorry, one more thing (slightly off topic)—uwe68, I'm also using Let´s Encrypt SSL certificates. I use them for all my servers. SecuritySpy doesn't use the .p12. You just need to use openssl via Terminal to export your .p12 file into the format hat SecuritySpy requires and your gold.

    That said, my SSL certificate is completely valid and works fine when connecting via the web, so I don't think the certificates have any affect on why the iOS app can no longer connect?
  • OK, last one for real this time. While I still can't connect via the iOS app, I also have Spyglass (iOS app) installed installed and it can still connect no problem. The issue is only with the SecuritySpy iOS app for me.
  • Back on my LAN now.

    Once I'm on the LAN the iOS app connects, but now I'm getting an iOS pop-up when I first connect to the server asking me to enter my Username. I enter the Username and it then it asks me to enter my Password. Then it connects like it should.

    If I already have my username and password entered in the server's configuration (within the iOS app), why is it asking me to enter it again via iOS pop-ups?

    And, if I kick off the LAN and connect via the WAN, I get the Connection Failed alert (yet, I can still connect via Spyglass).

  • Switched back to 4.1.1 via TM Backup and everything is fine. Certs being accepted again. Nevertheless, iOS App doesn´t show the camera pictures (Grey fields with red crossed camera) The App is useless atm.
  • Just had a look again. When I enter my credentials (I have a own DDNS which points to my Server), it doesn´t connect. When I look inside the App at the Server it shows me .viewcam.me:32501 but I dont use this service.
  • That means, the server address (FQDN) is not recognized by SS App, that´s I think the reason, why it works via Web Interface.
  • I think this must be a problem related to using your own domain name rather than SecuritySpy's viewcam.me DDNS service. Please try this:

    - Quit your current version of SecuritySpy

    - Download and install the new beta version of SecuritySpy (4.1.3b1)

    - In the iOS app, delete the server instance and set it up again.

    Does that work? If not please tap and hold on the server in the iOS app and it shows you what addresses it's using to connect - what are the addresses shown there?
  • Hi Ben, thanks a lot. I´ll try it in the evening. As said, in the moment when I tap and hold on the server in the iOS App it shows me ".viewcam.me:32501" instead of my FQDN. The Port is the right one "32501" I.ll. let you know.
  • Well that's definitely wrong. This bug will only affect users who have their own WAN addresses and aren't using our viewcam.me DDNS service. SecuritySpy 4.1.3b1 will fix this, and we'll also put out an iOS app update ASAP to address this issue from that side.
  • Good morning. I'm having the same problem since upgrading the iOS app on my phone. While on our VPN, I get the server cannot be reached error. If I delete the server from the app and re-add it seems to connect but I only get a grey screen with a red X for each camera. The web log on the server shows that I've connected at that point. When I'm in the office and on the LAN the app works fine. So it appears to be only related to connecting via the VPN. I've tried the beta version of SS as well with no luck. All was working fine until yesterday when I upgraded the iOS app. Please advise. Thanks.
  • Just want to confirm that the 4.1.3b1 install of SS + re-adding the server instance in the latest iOS app fixed the issue for me.

    Thanks for the quick fix Ben!
    k.
  • I was just coming over here to make mention of this issue. Looks like it has been identified and being worked. Thanks all!
  • @theboyk
    Is it when you´re within your Lan, or also when you´re abroad?
  • I haven't been able to check on the LAN since updating to SS 4.1.3b1, so can't confirm anything LAN-related. But, I can confirm it working outside the LAN (i.e., I'm at work right now and the iOS app is once again working like it should). Will check on the LAN when I get home tonight.
  • Hello everyone - we've just released an update to the iOS app (1.1.1) that addresses this connection issue, so please use the App Store on your devices to update.

    After installing 1.1.1, please delete and re-add the affected server(s) to the app.
  • I can confirm the updated app works for me. Thanks!
  • Still not working with SS 4.1.3b1 an iOS App 1.1.1 Always get the message: The Server that responded is not SecuritySpy. Web Access is still OK.
  • Hi @uwe68 please could you set up a temporary account for us in SecuritySpy (we just need limited access to a single camera), and email the login details to support@bensoftware.com, referencing this blog post. This will help us to effectively debug your issue.
  • Hi Ben

    just sent you an Email.
  • Just an update for anyone else reading this - there is a bug in SecuritySpy 4.1.2 related to encoding of special characters in the names of PTZ preset positions (i.e. accents, umlauts etc.) that prevents the web interface from working with the iOS app. It's fixed in the latest beta version of SecuritySpy (currently 4.1.3b2).
  • Even the latest beta (4.1.3b2) is causing my Zmodo ONVIF outdoor camera to constantly disconnect and reconnect to the point of it being unusable. I've never had a single problem with this camera and Security Spy since 4.1.2.

    I'm currently stating at constant 'Offline' and 'Connecting' messages in the Camera Info window.

    How can I revert to 4.1.1 please?

    Thi is not a Mac App Store download and I don't use the iOS App. It's the server directly reporting the issue. My network configuration has not changed.

  • So I figured out how to download 4.1.1 and all is find now. So 100% confidence - 4.1.2 broke the connection to my ONVIF Zmodo camera. Purely a server issue.

    The latest beta, as mentioned in my previous post does NOT fix my issue.

    I'm not using SSL, an App Store version, nor do I have PTZ enabled (which my camera does not support).

    The camera is set to ONVIF/TCP and is connected on a local IP address.
  • Any idea the cause of this issue? I still have the same problem in the latest beta. Rolling back to 4.1.1 is all good.
  • Hi @acedout this forum discussion topic is about the iOS app - please post to relevant discussions, or create a new one if one doesn't already exist, it makes it much easier to help!

    I'm not immediately sure what this issue with your camera could be. I think the best way to debug this (as we don't have any Zmodo cameras here to test with) would be if you are able put your camera online temporarily so that we can connect to it from here and do some testing - is this OK with you? To do this you will have to set up the port forwarding settings on your router to forward incoming connections to the camera on port 80, 554, and the ONVIF port (if it's not 80) and then email us your public IP address (or DDNS name, which can be set up in SecuritySpy's Web Server Setup window). Let me know if you need more information about how to set this up.
  • Hello everyone, we have just released SecuritySpy 4.1.3, which should fix all connectivity problems with our iOS app. Use the "Check for Update" option in the File menu in SecuritySpy to update, or download SecuritySpy here.
  • I appear to have both Security Spy 4.1.3, and the iOS App 1.1.1 - still can't login (https) - I get "unexpected response from the server" for LAN attempt (auto detection) and if I try over internet through port forwarded to security spy the response is "The server that responded is not SecuritySpy" - I use dyndns.org
    but if I use a web browser to the same HTTPS address & port with the same credentials I can login fine.
    I don't know if it helps or not, but after updating the Mac Security Spy app, in the Web logs, the connection attempts appear to be IPv6 which is not running internally on my network (Apple Airport Extreme) - before the update to Security Spy all connections were IPv4 addresses

    (just got back from a trip for 2 weeks, glad I didn't update remotely while I was gone)
  • reverting to 4.1.1 with iOS Security Spy 1.1.1 restores the ability to connect via dyndns address (HTTPS)
  • tested again with 4.1.4, same issue, have once again reverted to 4.1.1
  • Is there a link anywhere to 4.0 or 4.1.1? Thx.
  • Here is the link to 4.1.1: download SecuritySpy 4.1.1.
  • Hi @BrianM - when using 4.1.3 or 4.1.4 try deleting and re-adding the server to the iOS app, to see if this fixes the problem.

    When on the LAN, the app uses the server's Bonjour name in order to connect to it (this makes setup of your Mac much easier as you don't have to give it a static IP address). So the app will simply resolve the address and use whatever IP address is returned by the system, whether it's an IPv4 or an IPv6 address. Both should work fine. If you want to turn off IPv6 on your Mac, you can do so via the Network system preference (this may be a useful test to see if this has any impact on your problem).
  • @Ben, thanks for link. I'm happy to say that it's no longer needed as I'm now able to log into server via LAN and VPN (with iOS 1.1.1 and MacOS 4.1.4) by simply turning off "Advertise Bonjour" in MacOS app settings - thanks to your suggestion.
  • Hi @xmx - great to hear that! I'm glad we have this sorted now. For anyone else wanting to use our iOS app over a VPN please see the new instructions here: SecuritySpy iOS/tvOS App - Connecting Over a VPN.
  • Yes, I had tried removing the server from the iOS app, and setting it up as new, same issue.
  • OK, same thing here, but not using VPN. I even went back to 4.0.9, and it won't work with security spy iphone app. I get the same message from inside my local network, or outside. "The server that responded is not security spy." Currently running 4.1.4 and the latest IOS app. Definitely busted.
  • I should also note that the web interface works, as does the third party app, IPCAM viewer. Just the security Spy IOS app not working.
  • Hi @hiropro4, so that we can investigate this, please can you allow us to connect to your SecuritySpy server to test with? You can create a temporary account for us with limited access to a single camera, and email us the address and login details.

    Are you running some sort of proxy, or is there direct access to SecuritySpy?
  • If the other person can't make this happen for testing, let me know and I can.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!