Version 4.1.1 - Constant "Operation Timed Out" Errors
  • Hi,

    As the title suggests I am getting constant "Operation timed out" errors on all cameras (5) running SS v4.1.1. Having trouble-shooted things like my connection, I can really only think now that it's either the Mac Mini or the software that is causing the issue.

    There is no patterns to the disconnects it's random but happens several times over the course of 10 minutes. I have tried using the web interface for the cameras and there is no disconnections. Similarly, when I have tried setting the cameras up in Synology's surveillance software on my NAS, it works fine.

    Previously with version 3, I did not have this problem. Nothing has changed recently apart from V4.

    I am running FOSCAM IP cameras - 3x FI9803P V2, 1x FI9900P. They are set up to run through the ONVIF profile. They have static IPs.

    Thanks in advanced for your help,
    Best wishes,
    Colin
  • I am also seeing two out of the 6 cameras on my 4.1.1 system timeout and then never reconnect... If I restart SS then all cameras connect and all is fine. Later when I check its always the same two cameras that are no longer connected. Both are using Foscam H.264 profile. All was working fine with these cameras until I updated to 4.1.1 from that last beta version prior to its release.
  • Ben, I will revert to that the next time I see the issue. I have seen it several times since I updated to 4.1.1 but haven't had the issue today since I restarted when I posted this morning.
  • OK doodah please let me know how things work over the next few days.
  • I have had similar problems with v 4.1.1, but no problems when I go back to either 4.0.10 or 4.1b5.
  • Hi Ben,

    Will try this soon - away from home for a few days but will update at the weekend.

    Colin
  • Same problems with 4.1.1. I am using 4.0.10.
  • I am running 4.1.1 with my 2x Foscam 9803's (one P, one EP) with the Foscam H.264 profile - I found it more reliable than the ONVIF earlier on with the 4.0.x versions
    (also have Foscam 2x C1 with Foscam H.264 profile, 2x 8910E with Foscam JPEG, and an old D-Link DCS-920 with the D-Link profile for it)
  • @Ben Going back to version 4.0.10 has totally resolved my "Time Out' issues. No problems now and my SS log is clear with no entries.

    Thanks,
    Colin
  • It took a few days but I saw the issue again with 4.1.1 and have now put 4.0.10 on my system.
  • I am also having this issue, I have 7 cameras, 4 of them just started doing this about the same time I updated from a 4.0something beta (because of onvif issues a few releases ago) to 4.1.1. I cant say for certain that it was as soon as I updated but it was around the same time.

    All cameras are connected by gigabit ethernet, and cpu load is at 50%. I'm quite sure its not a processing or bandwidth issue as the log suggests...

    "10/03/2017 09:51:58: Error communicating with the network device "FrontSouth". 4.1.1,10,835 Excessive packet loss from network device, the network may be too slow or defective, or this computer may be overloaded. Check the network and/or reduce this camera's frame rate."

    The error log shows (Error from camera "FrontSouth", it will be closed. (22185,268435460)

    The one thing that the 4 cameras have in common are that they are all Hisilicon variants, the ones you have to administer through internet explorer because of some rare activeX plugin. They are running various versions of firmware because i am unable to update them due to not being able to find a current downloadable version. The one camera that I could update through the web UI via online update, has stopped dropping out but the other three still have the issue.

    The other three cameras are not Hisilicon cameras, and can be administered via the web UI through safari in osx.

    At first I thought it was something to do with UDP because only the UDP cameras were having issues, but changing to TCP didnt make a difference.

    Also, the issue occurs whether I use ONVIF or 'Manual Configuration' for the device profile.

    Thats all I got so far, if you would like firmware versions or the exact beta version i was running before then I can look those up, im just not in front of the right mac at the moment.

    Hope this helps!
  • Also I'm fairly certain the cameras are actually being reset when it happens, because they disappear from the network and cant be accessed via web browser to administer OR view streams.

    I've just reverted to 4.0.10, I will advise if the issue is resolved. Cheers.
  • Any updates on if reverting fixed the issue?
    Been testing out SS the last few days and one of my cameras constantly goes offline with the same error "Operation Timed Out".
    For me, I can connect to the camera through other sources (for example, connecting directly to the camera via the web), it's just "offline" in SS.
  • Reverting to 4.0.0.10 didn't fix the issue, I've since replaced one of the affected hisilicon cameras with a chinese version of a foscam camrea (same as one of my other 3) and no issues on that camera now either.

    Hisilicon camera 1 (which had the issue before the online firmware update) is running V4.020R12.00018510.12012.142300.0C
    Hisilicon camera 2 (updated firmware manually from downloaded file) is running V4.020R12.00018510.10010.142300.0C
    Hisilicon camera 3 (unable to find firmware update) is running V4.020R12.00006510.10010.140700 (no IR leds or IR cut built in)

    hope this helps!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!