Trouble setting up webserver, could use some advice
  • I am trying to setup the web server and I am having trouble. I have the current version of Security Spy, Eero Pro wifi and router (currently updated software).

    I am successful at enabling the http web server to view locally on the network on another computer as well as the iPhone security spy application. I am unsuccessful viewing the http server remotely away from the network.

    If I enable the https server, I am unable to view it on the network or remotely.

    On my computer, I do not have firewall enabled.

    On the Security Spy web settings:

    Enable web server: both check and assign different port numbers that match the open port number in my Eero
    Auto Port forwarding checked for both
    Dynamic DNS name has the green dot after testing
    HTTPS security level: 3 - disable cyphers using abc
    general options all checked with the exception of allow screen control for administrator accounts
    User Name and password have been assigned with no limitations on daily access or duration

    On Eero, I have:
    automatic DHCP & NAT selected
    opened the ports for both the http port and the https port (verified correct port numbers). Protocol is TCP & UDP for both
    Eero has the option of using DDNS with an Eero domain name rather than my IP address. Im unsuccessful with it on or off
    Currently IPv6 is on

    Thanks for your help, I do appreciate it
  • From your description, it sounds like your setup is like this:

    Internet <-> Router <-> Eero <-> Mac

    Is that right? If so, then you could be in a "double NAT" situation, described here: I'm unable to access my system remotely - how can I troubleshoot this?

    The normal solution is to set either your router or the Eero to bridge mode instead of router mode.

    If this does not allow you to fix the problem, please email us and include SecuritySpy's debug file (SecuritySpy menu > Debug submenu > Create Debug File On Desktop and we'll help you directly with this.
  • Ben,

    I changed my Eero to ipv4. This did allow me to access remotely from the app as well as through a web browser.

    However, when I try to access the secure https port, I am unsuccessful.

    Any suggestions?
  • OK, interesting, good to hear this fixed it. Have you set up port forwarding manually, or have you let SecuritySpy do this automatically (via the "Allow access from the Internet" options under Preferences > Web)? What is the exact error you get in the web browser when you attempt to connect to the secure port?
  • I have let Securityspy do this automatically. I also opened up the corresponding port on my Eero router. I have verified that I a not running a double Nat situation as well. Here is a partial screenshot of the debug log. I have disabled the HTTP port and currently only have the HTTPS port

    HTTP enabled: NO
    HTTPS enabled: YES
    HTTP port: 8000
    HTTPS port: 8080
    HTTP detected WAN port: 8000
    HTTPS detected WAN port: 0
    DDNS name: XXXXXXX
    DDNS status (0:Untested, 1:OK, 2:Error): 1
    WAN address: XXXXXXX.viewcam.me
    SSL security level: 3
    Allow access from the Internet for HTTP: NO
    Allow access from the Internet for HTTPS: YES
    Write log file of all connections: YES
    Advertise this web server via Bonjour: YES
    Allow screen control for Admin accounts: NO

    Using an iPad on cellular data (not connected to network) I get the following error:

    "Safari cannot open the page because it could not establish a secure connection to the server"

    Chrome on the iPad gives this error:

    "This site can't provide a secure connection
    XXXXXXX.viewcam.me sent an invalid response.
    ERR_SSL_PROTOCOL_ERROR"
  • This error indicates that a connection was established, but there is some SSL error. Could you please email us and include the full debug file, and we will investigate.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!