Issue with remote connection on MacOS 11.4?
  • Hi @Ben

    I just upgraded to MacOS 11.4 this morning and now I can't connect to SS remotely

    I've confirmed that I have the correct remote address in my browser at work and I've also confirmed that SS is running on my Mac at home (by remoting into my Mac)

    I've tried both the http and https addresses for connecting remotely and neither works

    I've also tried connecting via my iPhone and the SS app and same thing happens

    Could this be related to the 11.4 update or coincidental with something else going on?

  • This could be coincidental, although I have seen some macOS updates causing changes to network settings, so this is a possibility. Have you set up manual port forwarding in your router, or are you using automatic port forwarding? If you have set up manual port forwarding, check the Network system preference to make sure the Mac is assigned to the IP address set in the port forwarding rule.

    Also, if your Mac is connected to your network by wired Ethernet, make sure that your Mac's WiFi is turned off, so that it is not connected to the same network twice.

    There are a few other things that can prevent remote access from working too, so if the above doesn't help, please go through the troubleshooting steps outlined in this FAQ: I'm unable to access my system remotely - how can I troubleshoot this?
  • Thanks, I'll have to troubleshoot once I'm back home this evening

    I haven't set up any kind of port forwarding, so I'm guessing mine is automatic

    My Mac is hardwired but wifi is always on as well to take advantage of Apple's HandOff features, etc. Wifi has always been on and never had an issue with SS before

    Hopefully the FAQ will be able to solve the problem, will try to report back once I go through it

    Thank you
  • One easy thing you can try is to restart your router - this often fixes remote access problems where it was working previously.
  • It's interesting, I'm still getting iOS notifications of movement (but no snapshot) while at work (ie, outside my local network) but can't connect to the server via the SS iOS app at all
  • That's not surprising - the text of the iOS notifications is pushed from SecuritySpy via Apple's servers to the iOS device, whereas the image in the notification is pulled by the device from SecuritySpy's web server, so if everything is working apart from web access to SecuritySpy, you will get text-only notifications.
  • Okay, that's good to know, thanks
  • So I'm back home and am able to troubleshoot

    In General-Web of the Preferences, everything looked like your picture in the FAQ except the security level was set to 2 on my Mac and your screenshot is set to 3

    The test button generates a green dot in the Dynamic DNS name

    I reboot my computer as a first toubleshooting step and one thing I noticed and have noticed for the last few weeks is that SS gets a different IP address upon computer reboot - I don't reboot often, but it seems that is something that didn't used to happen

    I have SS web access saved as a tab in Safari as a bookmark and I always have to edit that bookmark with the different IP address upon reboot otherwise it won't connect to SS (this is all at home, on my home network)

    And, this happened before I upgraded to 11.4 this morning

    Anyway, I reboot the router and it looks like that may have done the trick - I'm able to connect on my iPhone with wifi off and using LTE data to simulate being off the network and being at work, for example

    So, in summary I think the one problem may be solved (I'll have to check when I'm at work again tomorrow to see if I can connect), but...

    ...I'm puzzled by the changing IP address of SS

    Any advice about that? Thank you
  • I'm at work and am able to access the SS server/camera feeds, so thank you @Ben for the advice to reboot the router
  • Good to hear the router reboot resolved the problem.

    As for the IP address changing: it sounds like your Mac is set to obtain an IP address from the router by DHCP (which is a protocol for automatically assigning IP addresses). Each time your Mac reboots, it asks the router for a new IP address, and this can be different each time. This is completely normal for DHCP.

    Instead of using the IP address to connect to SecuritySpy, you can use the Bonjour address - this will stay the same even if the IP address changes (to view the Bonjour address, click the "How Do I Access This Server" button under Preferences - Web and you will see it there - it's the one that ends in ".local").

    Alternatively, you can configure your router to give your Mac the same IP address each time. This should be somewhere in its DHCP settings (usually called a "DHCP reservation").

    Another alternative is to configure your Mac with a static IP address on your local network. This is described under the Port Forwarding - Manual Setup section of the SecuritySpy Installation Manual.
  • Thanks, yeah, I had figured out using the Bonjour address should work over multiple reboots, so I had gone ahead and changed my bookmark to that last night

    If that works fine, I'll probably just do that rather than reserve DHCP for the Mac or configure the static IP address

    Thanks again

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!