v380 Shenzhen IP camera
  • Has anyone had any luck getting an inexpensive Chinese Shenzhen WiFi IP camera set up with SecuritySpy? Like this one https://www.ebay.com/itm/323626421368

    The camera supports ONVIF and SecuritySpy detects it as a ONVIF camera but it just times out when trying to connect to it.

    The only record in the log just says this....

    02/01/2019 11:27:59: Error communicating with the network device "Network camera". 4.2.9,70900,800 Failed to obtain video frame from network device. The operation timed out.
  • I had a similar issue with a completely different make of camera, and the following helped me:
    - In the Cameras section of the Preferences window, create a new network device.
    - Under the Device tab, set the device type to "Manual configuration”.
    - Enter the camera's IP address (192.168.0.xx) but leave the Port fields empty.
    - Enter the camera’s username and password.
    - Select "RTSP TCP” from the Format menu.
    - Enter onvif1 as the Request.

    might be worth a try in your case, only takes a second to give it a go...
  • thx for the response .... unfortunately for me it didn't help :(
  • does it work with vlc? that is always a first step for me just to make sure it is working...
  • no, ive not been able to get it to work with vlc either
  • That error code indicates that the ONVIF negotiation succeeded, but the video stream connection timed out. This indicates that perhaps the video stream is running on an unusual port, rather than the default of 554 (this should be automatically detected during the ONVIF negotiation, but perhaps this is not happening for some reason). Check the camera's settings pages for any indication of which port it is using for RTSP.

    The next thing to try is the "Auto-Detect Profile" button in the Device settings in SecuritySpy (under Preferences -> Cameras -> Device). This goes through all known camera profiles, to attempt to find one that works.
  • thanks for replying. The auto-detect didn't find anything. As far as I can tell it's suppose to be using port 554 but is there any way for me to tell for sure? I have a number of these cameras so it sure would be nice to be able to get them working with SecuritySpy if possible
  • I found this thread that has a link to new firmware http://community.netcamstudio.com/t/v380-stream-url/2778/9

    Once flashed I get the camera to come up, but I frequently get timeouts (more often than not) Is there a way to set the amount of time SecuritySpy waits for the stream?
  • Hi @dreed47 SecuritySpy's timeout value is fixed at around 20 seconds. If no data has been received from the camera in that time, it's safe to say the stream is broken and needs to be re-initiated; there wouldn't be any point in waiting longer than that.

    Timeouts typically indicate network issues, so this is the first thing to check. Wired Ethernet is far preferable to WiFi, but if you have to use WiFi then make sure signal strength is good, rule out interference from other devices or WiFi networks, and make sure the distance to the access point isn't too far.
  • I have the same problem with a shenzhen V380 IP Camera. I can view the video feed on VLC using /live/ch00_1 but cant get SecuritySpy to connect using the manual profile. I've run a packet capture with wireshark and it shows the rttp request and handshake of 554 and then it shows the tcp packets being streamed. It seems to me like Securityspy doesn't like something about the video format. I have packet captures and debug dumps I can send to you if that's of any help?
  • Auto detect profile didnt work for me either.
  • Hi @Lamby what is the error shown in SecuritySpy's log related to this (File menu -> Open Log)?
  • 06/03/2020 17:40:26: Error communicating with the network device "Network camera". 4.2.12,70902,800 Failed to obtain video frame from network device. The operation timed out.
  • Just to check, you should be using the "Manual configuration" profile with, with the Format set to RTSP, with the Request set to live/ch00_1 - is this correct?

    Given that you see some packets being streaming in Wireshark, the address and port should be entered correctly, but could you please double-check these too.

    One other thing to try is to set the Format setting to "RTSP UDP". We have seen some cameras that only do UDP streaming, so this is something to check.
  • Thanks guys, I was using Manual configuration profile with RTSP over TCP. request is set to exactly 'live/ch00_1'. As per your request, I tried RSTP over UDP which didn't work either. I've left the port settings blank - and the wireshark comms shows traffic hitting port 554 on the camera and getting responses from port 554 such as 'RSTP/1.0 200 OK'. I can send you a screenshot of the wireshark traffic with ip's removed if you like. the traffic looks to be fine with handshaking occurring over port 554, then lots of RTP packets being streamed from another port in the 60000 range back to a port on my Mac. I'm running wireshark of the mac, so the packets are definitely being received.
  • so after some more research, I think this is just an incompatibility problem with the quicktime decoder that I believe you guys use. I've tried opening the feed directly in quicktime, and it wont open it, while VLC is quite happy.

    I'm going to junk the camera and get another one - after checking your compatibility list this time.
  • Before you junk the camera, try the latest beta version of SecuritySpy (currently 5.2.2b11) as it has some compatibility improvements related to RTSP streaming. If that doesn't work then I would advise replacing the camera.
  • UPDATE -Has anyone had success with this V380 camera problem? They are so cheap ($29) that I got one and now have the exact situation that Lamby described - works w the V380 app, works with Mac VLC on rtsp, and the Security Spy PTZ controls even work, but no video coming through. Another paperweight for my gizmo closet? Thanks, Jack
  • Any update/progress on this?
    It's so disturbing to have it working in VLC with this URL
    But not in SecuritySpy.. :-/

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!