PTZ stopped working for my PTZ cameras Version 5.2.3
  • Title says it all. PTZ worked perfectly in prior versions.
  • Confirmed!
  • Was looking for a 5.2.2 download to fix for now. Is it accessible from somewhere?
  • Sorry about this, could you please let me know the make and models of these cameras?

    If you want to go back to version 5.2.2 for now, you can download it here:

    Download SecuritySpy 5.2.2
  • Any Amcrest
    Avtech is working though
  • Amcrest and PTZ Optics for me. All work fine from direct PTZ control via the browser.
  • 5.2.2 did the trick. Thanks!
  • Amcrest for me too
  • Under Preferences -> Cameras -> Device, are you all using the "Acmrest" profile, or the "ONVIF" profile? Both should work with Amcrest cameras, but I suspect that only one of these is exhibiting this problem. So far we are unable to reproduce this in our own testing; this information will help us to narrow this down.
  • I have the same cameras. Its only broken in 5.2.3 in ONVIF, not in the Amcrest profile.
  • FWIW the Amcrest firmware has recently been a disaster with respect to PTZ. I'm finding that the zero-point calibration that takes place when it turns on gets lost very frequently.

    My presets end up going to the wrong view and the manual controls take some delay before they actually work. I always get "Error sending PTZ command for camera "yCam1". 5.2.3,4430,8800 Connection closed by the other side." messages when using PTZ after a few hours.

    This is reproducible like clockwork now that I know what's going on.

    I've had to script a "recalibration" of sorts via AppleScript before doing anything programmatically. Whether on the Amcrest profile or the ONVIF profile.

    Its definitely the camera itself - all 3 of my Amcrest cameras in fact. Anyway...

    1. PTZ to top-left and hold for 15 seconds
    2. PTZ to bottom-right and hold for 15 seconds.

    While doing both of these you'll hear the camera servos try to rotate the dome beyond the limits of the camera's plastic chassis, but it's mostly harmless, and after that it's re-zero'd and my presets work again.

    Again, this isn’t a SecuritySpy thing, but I figured I'd mention in because it drove me nuckin futs for weeks
  • Hi msy. Thanks for your info on this. I had left my Amcrest profiles set to ONVIF in Security Spy simply because it defaulted to it after having Security Spy auto detect. I've found their software support to not be very good and their browser plugins don't work either. They are very affordable and as always, we get what we pay for.
  • I had this problem too and downgrading to 5.2.2 fixed it. Our PT(Z) camera is an Amcrest IP2M-841EB POE. Thanks for the download link.
  • PTZ problems should now be fixed in the 5.2.4b17 beta version of SecuritySpy - could everyone please test and confirm? Thanks.
  • Great, thanks Doug. This has now been confirmed working by a number of different users, and we have now released SecuritySpy 5.2.4 (download the latest version of SecuritySpy), so I'm going to close this discussion topic.
This discussion has been closed.
All Discussions

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!