Amcrest ASH21
  • I got this cam in today and it works in Ethernet mode. Wont work with Wifi for some reason with SS. Has an AI auto tracking for PTZ and works very well. I haven't been able to get the PTZ controls to work with SS with manual control.
    Anyone have experience with this model?

    Amcrest SmartHome AI Human Detection WiFi Camera, Indoor Pan/Tilt Wireless IP Camera, Baby Monitor Mode, Auto-Tracking, Home Security Camera with Night Vision, Two-Way Audio, Nanny Cam ASH21-W (White)
  • If you set up a camera with the "Manual configuration" profile, then PTZ won't work - have you tried either the "Amcrest" or the "ONVIF" profiles? Either of these should work for PTZ.

    As for the WiFi, this sounds like a network issue; if the camera works over Ethernet but not WiFi then either the camera isn't correctly connected to the WiFi network, or the camera's address that you have entered into SecuritySpy is wrong. Note that the camera will probably have a different address when it is on Ethernet vs. when it is on WiFi.
  • Thanks for the response Ben. I have tried multiple profiles with the same result.
    The camera is connected to my WiFi and can be viewed from the Amcrest app. This is a new camera and feel they have done a different config with it for cloud purposes, which is what I am trying to avoid.
    I am also unable to login to the web server for the camera settings unlike the other Amcrest cameras I have, which makes me conclude they may have made this without one.
    The only way I was able to set it up was with the Amcrest app with limited settings and assigning the IP address for the Ethernet and WiFi with a reservation for each in my router.
  • Amcrest support replied with, “ There is no way to change the port or IP address of this model”
    It is only meant to use with the Amcrest mobile app. No web interface.
    It works in SS minus the PTZ controls, so i think I may return it.
  • OK, this is good to know, we'll put a note on our camera list advising users to avoid these models. Not having a web interface and not being able to set basic parameters such as the camera's IP address is a major limitation.
  • Some more info on this camera, as I have one.
    As stated, I cannot get anything to work to set this camera up.
    However I use LiveCams Pro for iPhone and it does infact connect to the video of the camera.
    This app using their "Amcrest Profile 1" connects with the following details:
    HTTP Port: 554
    HTTP (not https)
    RSTP Port: 554
    Main Stream

    As stated, Tilt/Pan does not work, but at least video is operational.

    I am not sure the internal details of the SS "Amcrest" profiles (I have 2) but they do not connect. So there is SOME way to connect.

    Any help would be great, since the camera can be setup in a passive mode to just track and identify "human" "auto track" then the camera does all the work, and just tracks people. SS could just record.

    Any profile that might fit, I will gladly try, all-though I have tried numerous profiles to see if there is a RTSP profile that fits.

    Ben is probably the only one that would know.
  • Upgraded SS to 5.2.1
    Amcrest Profile Works
    Alternate Setup:
    ONVIF Port: 554
    RTSP Port: 554
    Format: RTSP TCP (Video and Audio)
    Auto-Detect Streams
    Stream 1
    If you are using a previous version of SS (tested with SS 4.2.12)
    Only Stream 2 works.
    Stream: 2 (H264 - 640x480)
    Stream 1, H265 - 1920x1080 DOES NOT WORK
    I tried every other vendor camera, with every profile that any had. ONVIF is the only one that would do anything.
  • I ended up returning the camera. I purchased the IP2M v3 model and it has the same AI pan/tilt tracking. It is also configurable from the web interface. Works with SS no issues.
    it was also the same price.
  • Hi @GGITech - it's good to know that SecuritySpy 5.2.1 works with this camera. There were some improvements in RTSP stream parsing in this update, which could account for this. This will make is way into a v4 update in the near future. We'll still keep the warning about these cameras on our list, because the lack of a web interface or other way to configure their settings is a big drawback.
  • @Ben it seems that 5.3.1 killed this setup and it no longer works. I finally got time to debug this as the camera has been down for some time.
    Camera: ASH21-B / ASH21-W (letter is for color of the camera black/wite)
    Firmware: 2.680.00LR00.2.R.200410
    (I am not sure if this has been updated, but the app for the camera indicates it is 'current')

    Security Spy Setup
    ONVIF: 554
    RTSP Port: 554
    username: admin
    password: **password set that meets the requirement**
    Proile: ONVIF
    Format: RTSP (video and audio) - Note: Assume this is TCP since a UDP is listed below it
    Input or Stream number: 1 or 2 does not work
    Auto-Detect Streams times out, "Error 800 (The operation timed out)"
    Checking Use SSL changes nothing
    Auto-Detect Profiles, TAKES FOREVER, but it don't find anything that seems to work either.

    There is a how-to on getting this to work with the AMCREST DVR, which might lead to some help,
    ---But port 37777 I tried with combinations of 554 and 37777, no luck.

    Any ideas Ben?

  • I can't think of anything that changed in 5.3.1 specifically that would have an impact here. A timeout indicates that the device is not responding at all, or the address for the device in SecuritySpy is incorrect. This is consistent with the profile scan taking a long time (because each profile has to be tried for many seconds before it times out), and not finding anything. We'd be happy to look at this directly via TeamViewer if it would help? If so, please email us at
  • Same here. It works if plugged in via ethernet and even when I them unplug the ethernet. Once it powercycles it doesn't allow it again. Seems like a simple firmware fix. Has anyone had any luck?

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!