Reolink cameras
  • Hi-

    I saw a few posts with people having problems with Reolink cameras. I'd like to throw my name in the hat. I saw Ben said that they have asked about a bad packet that the cameras are sending. This seems consistent to my problems.

    Here's what I notice:

    1. When multiple instances of SecuritySpy try to connect to the cameras at once, you can get errors. I typically have one instance of SecuritySpy running that is licensed, and two other computers that I use for viewing live only. If I leave these other instances of SecuritySpy up, and the cameras do their normal maintenance reboot, the reconnections can be problematic. However this problem seems to have disappeared since the last SecuritySpy version 4.2.4.

    2. Only two instances of SecuritySpy can connect to each camera at once. There are no settings in the web interfaces that indicate there is a limit to the number of streams.

    3. There is a frame rate drop every 4 seconds or so. SecuritySpy doesnt indicate so, but it's clear when you are watching the cameras.

    My setup:

    I have 4 RLC-410s and 1 RLC-411 I bought as recommendation of Ben's post. All are wired, PoE. The cameras are wired into two different switches, both experiencing the same problem. Several are not actually set up outside yet, so the ethernet cords are short and located next to the switch and just hooked up to test my setup). I also have 6 other cameras, mixed of brands and models (2 are PoE). All working fine.

    I'm happy to participate in any testing or debugging.
  • question...why multiple instances of SS?

    in an 'ode to Chubsta' post => I deem my Reolink cameras finally working well with SS.
    There is ZERO question there is some sort of hiccup when the SS goes to connect to the Reolinks of any flavor - no idea if its the SS or Reolink. Any other brand camera opens immediately - reolink always takes a while.
    That said - I needed to rewire everything. Minimize the number of switches, replace cheap switches with name brand (TP Link). Use either AC to the camera (yuck) or dedicated POE box. Be very aware of the total power consumption of the cameras vs POE af and at box/switch. Make sure firmware of cameras is updated. Connected computer via cable to a switch even though I had very good and fast WIFI. Each little bit seemed to lower the errors to the point I have now run 24hrs with 60 minute videos - 8 cameras - with 4 on continuous recording. Plus a few more only recording in Reolink app.
    On a MacBook Pro which is probably my weak link at moment - but might be another month before I can get my MacPro onsite to put my security cam adventure to bed. Now I just need to hire someone to go through all the video that collects and remind me, the whole point was to secure and watch the house and not point them all into the woods to watch the animals!
  • eaglesrus - glad you seem to have it sorted, mine are still working absolutely fine, I have footage of hedgehogs and woodmice and foxes galore and am very glad I persevered, in fact as I type this the first hedgehog of the night is wandering down the path!

    Like you I am not sure where of the actual problem lies, all I know is that a 'perfect' network has been the solution for me, get rid of potential network errors and whatever is going wrong when they occur doesn't happen either, I can live with that, in fact I am awaiting delivery of another 410 to add in somewhere.

    I temporarily put one of my old Tenvis cameras in at our other property to check the wildlife there and it was so blurry and such a poor frame rate compared to the Reolink that I know it was worth the grief to switch over here.

    In relation to the original post, I would just suggest starting with the most simple setup possible, a single camera hard wired in to the router via cable, and then slowly add from there, will be interesting to finally find out the exact cause of the issues.
  • I have a Reolink RLC-423S that exhibits reconnection problems after making changes in SecuritySpy. This happens most often when disabling then enabling a camera or any other task that affects the connection. I think it displays a 999 error. Restarting SecuritySpy works most times, otherwise the camera needs to be rebooted.

    My SecuritySpy connects using ONVIF, but I have tried the Reolink profile. PTZ does not work if I use the Reolink profile. Switching between the two profiles just now forced me to not only quit SecuritySpy I had to reboot the camera with the Reolink app. The camera seemed to be having issues and I had to quit the app then reboot the camera. If I use ONVIF and don't change anything, the system is stable. I don't have the camera set to auto-reboot. The camera powered by a POE+ 802.3at and the switch is connected directly to the Google Fiber Network Box (router). Camera firmware is up-to-date. Sometimes after a power blip or failure the camera has to be rebooted, but that doesn't seem out of the ordinary to me.
  • Let me add some anecdotal information about the reliability of ReoLink Outdoor Cameras. I have had 5 RLC-410 cameras for a little less than a year and one of the five has completely failed, and one keeps resetting itself to factory settings. When they work, they're great-- excellent video, but when they don't it's frustrating. I'm looking for a different brand. The good news: Security Spy handles many, many cameras!
  • I have four Reolink RLC-411 cameras running. one is outdoors and behaves very badly. If it reboots, it ALWAYS resets EVERYTHING including ip settings. Get it started again and it will reboot itself eventually and require manual setup once again. I'll be looking to replace it with a different brand of POE device, Any specific suggestions to replace a RLC-411?
  • Have two Reolink RLC-423WS IP Cams. They work very well with SS and have excellent video. I liked them so much I purchased a pair of Reolink Argus Pro solar-powered IP cams to use in areas without easy access to "normal" power. I am unable to get SS to "see" those cameras. I've tried every profile listed but no luck. I realize the Reolink Argus Pro are not ONVIF compatible, but I assumed I could find a profile that would work. Any suggestions would be greatly appreciated!
  • Hi, has anyone been able to get audio working on Reolink cameras, specifically the 420? I get audio on the Reolink app, but no matter what settings, all ONVIF options, or Reolink profile, I dont get any. I have SS set to use Network Device, but no microphone appears on the preview screen, and I dont hear anything.

    Any ideas anyone?
  • siclark - I have a few 420s and audio works fine so at least I can confirm it is possible so there must be an issue with your set up somewhere. My profile is 'Onvif', RTSP (video dn audio), audio device is 'this network device', options 'record audio with continuous capture movies'. Compression is H.265 and radio is AAC.

    Hopefully this will help!
  • @tucsontico Old thread, but just wondering if you ever got your Argus Pro working with SS? Thanks
  • Without starting a new thread. I jumped on getting two RLC-410s for $36 each shipped with tax. Before seeing all the bad news. Should I just try to sell them new before opening them up? I really don’t wanna spend time with issues and stuff like that. Too many other things I need to spend time on. My other 2 cameras are Annke C800 flashed to Hikvision which have had no problems while using my 30 day eval of SecuritySpy.
  • Senna - I am still very happy with mine, no problems here...
  • Hi @Senna_F1, some users have success, others have many problems with Reolink cameras. If it's easier to return or sell them before opening the packaging, then I would recommend doing that, and instead using cameras shown on our Supported Cameras list.
  • I have two RLC-410 running on SS (in addition to the Reolink NVR) for a couple of years now without any major issues. Since they are non PTZ-Cameras (PTZ with Reolink unfortunately doesn't work anymore with SS) you shouldn't observe any problems.
  • I still have issues, so what’s the secret guys? I’m using a ONVIF profile because I think I had worse issues with REOLINK profile. Been going back and forth with REOLINK. They’re telling me to use the REOLINK profile.
  • Hi @Senna_F1 what exact issues are you seeing? If you are seeing "unexpected data" errors then this is what we have also seen with some Reolink models and unfortunately I don't think it can be fixed (unless Reolink provides some updated firmware to fix this, as this is definitely a camera problem). Or, are you seeing a different issue?
  • Hi Ben... On screen Error 4001 (see log)

    From the log:

    03/26/2021 13:00:04: Error communicating with network device "Reolink-1". 5.3.2,70212,4001 Error from network device.
    03/26/2021 13:00:08: Error communicating with network device "Reolink-2". 5.3.2,10,835 Excessive packet loss from network device, the network may be too slow or defective, or this computer may be overloaded. Check the network and/or reduce this camera's frame rate.
    03/26/2021 13:00:29: Error communicating with network device "Reolink-2". 5.3.2,70212,4001 Error from network device.
    03/26/2021 13:03:59: Error communicating with network device "Reolink-2". 5.3.2,70212,4001 Error from network device.
    03/26/2021 13:03:59: Error communicating with network device "Reolink-1". 5.3.2,70212,4001 Error from network device.
    03/26/2021 13:04:05: Error communicating with network device "Reolink-1". 5.3.2,80199,801 Error from network device. Data from network device not as expected.
  • Ben, I BCC'd you on my latest email to Reolink which includes Wireshark capture just FYI
  • @Senna_F1: Are the frame rates in SS at the same value as they are given from the Cams/NVR? Are the Cams (NVR) rebooting on a certain schedule?
    To those having problems with lost PTZ presets, I think SS is not taking over the PTZ presets which were set on the Reolink Cams/NVR. I encountered that after a (scheduled) reboot of the NVR, the PTZ presets on SS didn't work anymore. Unchecked the scheduled weekly reboot (every Sunday 2AM) on the NVR, and presets remained on the SS. Thats for Information and... maybe improvement.
  • Hi @Senna_F1 I will take a look at the Wireshark capture you sent, but those errors are consistent with the camera sending bad RTSP data that cannot be interpreted. We have seen that this is common with certain Reolink cameras, and we have tried to work with Reolink to find a solution, but at this time there is no solution that I know of. Sorry I can't be of more help with this.
  • I can confirm trouble with Reolink 520 ( ) of the kind described, using SS 5 3 3. Different kind of errors will be displayed as soon as either the camera is re-started, re-connected to a running SS machine or when I quit SS and the immediately start it up again:

    Mostly it will be "Error from network device. Bad video data sent by device."
    and when I leave it at that, it will be "Excessive packet loss" (from Log file).

    When I wait for about 5 minutes after I quit SS and the launch SS again, the Reolink cams will connect, even though they will be the last bunch that connect of all connected cameras to this setup.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!