Skip to content

Amcrest PTZ - controls through WebServer?

I have upgraded my whole SS system with a whole bunch of Amcrest (4MP, 8MP, panoramic, bullet, doorbell) cameras.

I can PTZ control the cams with the primary SS install & iOS app, but I cannot get it to work with a second SS install interfaced with the server on my laptop. Everything else works fine on this install.

BTW - I upgraded to the M2 mini - it's incredible for SS and pretty much everything else.


  • edited August 8

    I have several Amcrest PTZ cams. I recall at one point messing with all the settings in SecSpy thinking I would improve things, but it just made everything non-functional.

    My settings:

    Address: auto-filled by choosing it in Auto-Discovered devices

    HTTP port: blank

    RTSP port: blank

    Username: admin <<- important see below

    Password: kitten123 (juuuust kidding)

    Profile: Amcrest

    Input stream: 1 (default)

    Request: blank

    As I jotted down those settings, I recall that at one point I had tried making a different user on one or more of the Amcrest PTZ cams, and then connecting to it from SecSpy via that username as opposed to using the default 'admin' user, and the PTZ stuff didn't work via the other username. So...try default everything, user 'admin'. I use a self-signed cert generated on the Amcrest cam so it's SSL encrypted on the LAN on the way to SecSpy, all the cloud/internet stuff on the camera is turned off, except for the time server connection, and LAN IP/DNS. Works great. I don't love having to use the admin user on the camera, but it's not a big deal with a decent password, and God knows there's probably more backdoors into these cameras than your average brothel, so as long as they're locked down on your LAN, it doesn't really matter.

  • Thank you for sending your settings.

    I'm able to get the PTZ to work without a problem on the primary install and on the iOS app.

    However, on the remote install (laptop) the camera settings are all the securityspy profile with the input/stream numbers set to the respective cameras. This is where the PTZ doesn't work so I think it has something to do with the SecuritySpy profile interacting with the server.

  • PTZ from the second viewing instance of SecuritySpy should work, and it sounds like you have set this up correctly, so I'm not immediately sure what could be going wrong here. A few things to check:

    • Are you sure that the user account that you are using in the viewing SecuritySpy instance has the required permissions to control PTZ on the main server SecuritySpy instance? This can be configured for the user account under Preferences > Web.
    • Do you see any errors related to PTZ control in the log (File menu > Open Log) on either viewing or server instance?
    • Have you enabled the option for SSL HTTP connections for this device under Preferences > Cameras > Device on the viewing instance? This could prevent the PTZ connection from working if there is some issue with the SSL certificate validation.
  • Thanks for the help.

    • Yes re: user permissions - it's an admin account
    • No re: errors
    • Yes, I do have SSL for HTTP selected. If I deselect, I get this error: communicating with camera "Kitchen". Error from network device. 5.5.8,70280,301
  • Try turning off SSL but also specifying port 8000 for HTTP connections, or leaving the port box blank (it sounds like this is currently specified as 8001). Does this get the PTZ working?

  • I think we are getting to the problem. However, with these settings, now I get a timeout with this error:

    Error from network device. The operation timed out. 5.5.8,70900,800


    viewing instance


Sign In or Register to comment.