Skip to content

FFMPEG will not connect to camera (HomeBridge or HOOBs)


I had HomeBridge running and successfully serving video & stills on the same Mac as SecuritySpy for a while. But, earlier this year it stopped working. I didn't have time to troubleshoot, so just kept using the SecuritySpy app for video on the go.

I received the new HOOBs Pro a few weeks back and decided to try setting up FFMPEG again yesterday. Same result, no video/stills being served up.

- I've confirmed the "-i" is in the string

-I've tried both local and lan settings for the string with no luck.

-I've tried it with and without SSL enabled in the string

Has anyone else run into this and solved it?


  • This is what the configuration looks like in the HOOBs FFMPEG plugin

    (using local network)

  • I've also tested the local network url with VLC and it works. I'm guessing something changed in FFMPEG config requirements in the last 6 months?

  • Resolved... using the local machine name:port wasn't resolving. Replaced with the static IP:port worked.

  • BenBen
    edited August 12

    Great to hear you managed to work this out! It's a pity the error messages in that log aren't more detailed.

    I see a RTSP streaming source in the config (under "source") but not still image source (snapshot). Are you now getting snapshots successfully? I was under the impression that this requires adding a "stillImageSource" URL for a JPEG image.

  • ryandenver, how did you replace the local machine name with a static IP port. Where is this setting located? Thanks.

  • edited August 21

    I can't get any of the cameras I have on SecuritySpy to work with the Homebridge/HomeKit setup:

    I don't have a static IP address, so I am just using the links generated in the URL generator:

    Any suggestions on how to make this work would be much appreciated.

Sign In or Register to comment.