Skip to content

Trigger and mask drawing issue

I downloaded the 5.5.0 version of SecuritySpy this morning and have come across an issue with triggers and drawing a mask.

You see, I noticed one camera with a mask that needed adjustment.

So I went to Preferences. Selected the camera, then the Triggers tab. Everything looks as I'd expect and I draw on the image to adjust the mask.

Problem: I can only remove the mask (it seems like random areas are deleted) and cannot add to the mask.

Clicking the zoom button, and the image is massively enlarged.

Using the scroll wheel on my mouse (up or down), the image becomes correctly proportioned, but I cannot add a mask, only delete.

Returning to "normal" zoom, and the image is now a small rectangle in the bottom left of the window:

I cannot add a mask on any of my cameras, only remove.

I've tried rebooting the Mac Mini (Intel, 2018, MacOS Monterey 12.5) and the issue persists.



  • Thanks for pointing this out, it does look like there is a bug here, we'll get this fixed ASAP.

  • Thanks for the ultra speedy response, Ben.

    Hope it's not too much faff to fix.

  • This should now be fixed in the latest beta version of SecuritySpy (currently 5.5.1b1) - please test and confirm. Thanks.

  • Surely you can work faster? 😂

    I'm pleased to report that the correct mouse pointer is now visible and I can "paint" and delete the mask.

    However ... if I zoom the window, the enlarged view is the same as my top image above, and the mouse wheel roll no longer adjusts the view correctly. It's simply locked.

    Unzooming and I get the compressed image view, as per my second image above.

  • Good progress, thanks for the quick testing!

    How exactly are you zooming the window/screen? This specific issue has been reported by one user a few months ago, but we were never able to reproduce it and no one else reported it, so we have been unable to get to the bottom of this so far. Can you confirm that if you don't zoom the screen then everything works as expected?

  • Just by using the zoom button. I.e. this chap:

    Yes, I can confirm that the window works correctly now, as long as I don't click the above button.

  • Just to add, the issue may have been around for a few versions of SS and it's only this morning that I noticed that the trigger mask needed adjusting???

  • Yes, this is the same issue that was reported previously that we never got to the bottom of. It's strange that this zoom mechanism would work just fine on all but a handful of systems. We'll need to investigate further. In the second screenshot in your first post (unzoomed, with the image in the lower left corner of the box), can you tell me whether the image has the correct aspect ratio, or if it's stretched (looks like it could be stretched horizontally)? Additionally, is it cropped? How many cameras do you have, and do you see this same problem for all of them?

  • edited August 2022

    These are the worst kind of bugs to solve, I agree.

    o the image seems crushed vertically.

    o it is not cropped.

    o I have 8 cameras and it's a universal problem on all of them.

  • I can confirm this bug still being present in version 5.5.0, the current download version. I test it on High Sierra. Some earlier 5.x version I tried did not exhibit this fault. It may have been introduced around the time when SecSpy introduced the actual streaming of H.246 video via the webserver, instead of MJPEG? Or some other video optimisation for Monterey that doesn´t work with previous OS versions?

    The bug:

    Initially the complete video preview shows. When I hit the zoom arrows, the preview view enlarges and the video preview zooms to the bottom left corner of the stream but does not scale to fit the zoom preview window but rather seems to zoom to some much larger format. There will be a black bar at the bottom. Looks like it´s simply scaling to 100% video resolution of the camera but still applies black bars, to reach an aspect ration of the zoomed in preview window.

    When I click the zoom arrows again, the preview window scales back to the small view but the actual camera view is scaled down into the left bottom quarter of the small preview window, distortet (aspect ration wrong).

    Thanks for looking into this. I think it must be a bug that all users if this version experience, when running this version on HighSierra.

  • BenBen
    edited September 2022

    Thank you for the above information, this has allowed me to track down and (I hope!) fix the problem. It turns out that this problem is specific to Macs that don't support Metal, which is mainly 2011 models running macOS 10.13, but it also shown up on any Mac if the user has disabled Metal using the option in the Debug menu.

    So this should now be fixed in the latest beta version of SecuritySpy (currently 5.5.1b17). Please test and confirm.

  • Well done!

    I've been running SS since before metal was available 😀, migrating from one version of macOS to another. The mini's primary function is as a media server that does nothing else really, so it's possible I turned metal off in the distant past to fix compatibility back on my ... was it a Mac mini 2012??? SS is currently running on an Intel Mac mini, 2018, MacOS Monterey 12.6.

    Anyway, the beta works and in fact it now works with or without "Use OpenGL instead of Metal for Video Previews" checked.

    Thank you Ben.

  • Great to hear that, thanks for the feedback @Robbie!

Sign In or Register to comment.