Presets not working
  • HI
    I have 2 makes of cameras running on my system, and none of them will store any presets for the camera positions.
    All other functions work perfectly, including the "home" preset.
    I have tried setting the presets via each camera individually, and although the presets work through the cameras' own software, nothing works through SS.
    Pan/tilt/zoom all work very well.....

    Any ideas?
  • What are the exact makes and models of these cameras?

    Are you using the latest version of SecuritySpy?
  • I’m getting this exact issue myself. It’s a generic camera off ebay but it identifies itself as a "IPC-D41000-BS series” on its config page. I’m using the most recent version of SecuritySpy (v4.23) on macOS 10.11.6. PTZ control works perfectly. It lets me save a preset as best I’m aware.. holding down option and clicking on the number.. it depresses and then returns. Selecting the preset results in no movement of the camera. The alt key is fully working and works for other items.

    It also doesn’t move when using the SecuritySpy app on iOS. (Also out of interest is there a way of setting presets on the app? If not would be nice.. perhaps just press and hold on the selector for the preset you want?)

    Unfortunately this is the only PTZ camera I have at present so I have no way of testing with another model.
  • I've got a new Reolink RLC-423S camera that is having the same issue with presets. They work fine in the Reolink Mac or iOS app, but don't work in the SecuritySpy app. I can create (name) presets, but no PTZ data seems to get written into the preset and none can be recalled. The named presets do appear in the iOS app, but also don't retrieve any PTZ position info.
  • Yes, this is strange because my friend has the same camera with such problem and he can't fix it. Even in service center nobody has helped him
  • Just downloaded latest update and presets still don't work. Wondering if there is a file somewhere I can delete to reset these presets. I should note that the install app asked me if it could "delete preferences" which would have removed all settings. I declined.
  • I am getting the exact same issue.
    Its a VStarcam C38S. I can control PTZ with SSpy.
    I just cannot set any presets via SSpy.
    The web interface does offer 16 presets which can be set and called, however not from SSpy.
    Other PTZ seem to work fine (Tenvis3s).
    It IS the latest SSpy (4.2.6) but it has been a pain for awhile.
    Its a shame because this camera does have awesome quality images. Only downside is I have had to block its propensity to phone home to China.
    Only really bothering now as I had a camera fail and looking to replace it.
  • I hope this works someday. I want to have two positions stored and have the camera move to the positions at specific times of day. I like to keep the camera pointed at the street during daylight hours and then aimed at my cars in the driveway at night. Currently I have no way to achieve this other than remembering to do it myself - which rarely happens.
  • Same here with Reolink RLC-423. No PTZ no Presets. Can we expect a fix?
  • Installed 4.2.6 today and the PTZ presets now work. Interestingly, the presets I had created in previous software versions actually work as expected. I did not have to recreate them. Seems like the issue was with the recall of a preset not the creation or saving of a preset. I did run into a bit of trouble saving a preset again (overwrite). I made an adjustment to one PTZ position and tried to save it using the Option+click command. It didn't work after several tries. I restarted the app and still no luck. My instance of SecuritySpy runs on a headless Mac Mini, and I access it using Screen Sharing. I have noticed that sometimes special keys don't act as expected with Screeen Sharing. I got out an old Bluetooth Apple Keyboard and by pressing option on it and clicking on my MacBook pro, was able to get the preset to save. Maybe some others who are not using Screen Sharing can give us some feedback on how saving presets is working in this version.

    Anyway, I've got PTZ positions saved and have Indigo set up to move the camera at certain times via a plug-in that sends commands to SecuritySpy. So far it's working well, thanks Ben!
  • Having a rough time with 2 Amcrest IP2C-841’s saving most of the presets. New installation...will be forking over about 440-USD :) very soon but it’s early in my learning curve with SS. Not sure what to do about it.

    General comments: I’m years into Indigo and will be doing some integration with that software. Currently, I’m running on the latest mac-mini. 5 amcrest, 3-insteon (foscams actually) HD, and a couple old far.

    AppleTV comments; missing unclipped images all at once? Multiplex works great. I like how you can easilly get to presets.

    iOS comments: a little scarce on details...would like to have IP info available per camera when queried. I do not like how many clicks it takes to get to presets but could be missing the shortcut. Button in titlebar to log onto account does not look like a button. Looks like a title. When I’m away, this is the app I would use most.

    Apple Watch integration: non-existant? Not even text alarms....or maybe I missed the app. Need to look more. Use Apple Watch often without iphone....LTE.

    Mac Mini? May be asking too much. It’s not the slower’s the $700usd model. Most recent. Its the home server. Indigo, email spamseive, growl, printopia, and now security spy....running 24/7. May need to upgrade.

    These are minor issues...I love the software so far. Used EvoCam for years. Still have 24-days left on the 30-day trial. Cheers. :) hope I get the presets working!
  • PTZ saved presets work fine with my crappy Sumpple s610, but the saved presets become unresponsive after a few days and need reprogramming. I suspect this is related to the camera though.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!