NO VIDEO in browser window
  • Hi-

    Some of my cameras are reporting NO VIDEO in their browser windows, though they show files as existing in the left hand file pane. I can browse to those files and play them in vlc so they're there and they seem to work. Unclear as to why security spy doesn't recognize the format. They're all m4vs. Other cameras work fine...
  • When you click on one of the files in the list on the left, the Browser should jump to that position in the timeline, and you should be able to press the play button (or space bar) to start playing that file. Is this not what you see?

    Are you using the latest version of SecuritySpy?

    If you are still having problems, please email us and include a screenshot to demonstrate the problem.
  • Ben, I'm also having this issue - updated to latest version.... videos are listed in the left side, in Mac Finder but nothing in the timeline view! Tried restarting SS, the iMac, installing VLC. Captured videos play fine on web server and the spyglass app.


  • Hi @Boxgrove the particular file that is an unfinished file that is currently being recorded. While you can view these in the Browser, they will gradually grow in size and duration, and you will have to use the Rescan option in Browser in order to view any new footage that has been recorded. The Rescan option is in the Browser menu at the top of the screen (or command-shift-R).

    The files ending ".m4v" are finished recorded movie files, and if you click on these you should be able to play them - can you confirm this?

    Does this resolve the problem?
  • @Ben - tried viewing one of the other files - the time code at the bottom changes, but still displays "No Video" grey screen.

  • Are these timelapse files? i.e. have you turned on the "Recompress video data" option under Preferences -> Cameras -> Device, and specified an artificial playback rate under Preferences -> Cameras -> Continuous Capture?

    If this is the case, the files won't play back in the Browser. The Browser is based around a 24-hour real-time view of each day, and files with artificial playback rates don't fit into this scheme. You will have to view them in the Finder or via the web interface.

    Let me know if this doesn't explain it.
  • Thanks Ben, that fixed it... Had an artificial playback rate. God only knows how I missed the big yellow warning saying I wouldn't be able to playback in the browser!! haha!
  • OK great to hear that fixed it!
  • Similar issue here. Version 4.2.4b1. Files are being recorded and are viewable in Quicktime, but the browser has lost it's way. It worked fine until we moved two cameras off of this system and added two other ones. The browser lost it's link to all of the camera recordings. These are not time-lapse files, but continuous recordings split every 10 min. This has happened before and I was only able to fix it by reformatting the drive and re-setting the camera destination.
  • @TSI - what you are describing is a different problem, though I'm not immediately sure what could be causing it from this information. Could you please email us and include screenshots of your capture settings, the files in the Finder, and the Browser window.

    Also please include the Debug file (hold the alt key and click on the File menu in SecuritySpy, go to the Debug submenu and select "Create Debug File On Desktop").

    Also, please check the Console log (you'll find the Console in /Applications/Utilities/) - do a search for SecuritySpy and see if there are any message there related to the Browser.
  • Ben, thanks a lot for these suggestions. They are really useful and it has helped me to solve my problem
  • Hello Ben,

    Within the browser, what would be causing "NO VIDEO" for some video clips in the "Show All Files" selection, yet if you select "Movies Only", "Motion Capture..." or "Continuous Capture..." I can see that video clip? I can't seem to figure this out.....
  • Hi @meyekle - this shouldn't be happening. Are you using the latest version of SecuritySpy?
  • Yes, 4.1.4. Also my server is still running El Capitan 10.11.6. Would this make a difference?
  • pardon me 4.2.4

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!