SD Card for Storage
  • Hi,

    I am currently using a new external USB hard drive on my Mac Mini for motion capture on my IP cameras. For some reason, occasionally the hard drive disconnects for a few seconds and then reconnects again.

    Would it be more reliable for me to use an SD Card? Obviously they are more expensive per GB but for my needs, I would only really need a 128gb SD Card.

    Regards,
  • You could use an SD card connected to a USB adaptor, but I would be concerned about speed and reliability. If you go down this route, make sure to go for a big-name manufacturer, and make sure the card supports a write speed that's well in excess of what you need (check the bandwidth data in the Camera Info window to find out the data rates of the incoming video streams). Also make sure you get a fast (ideally USB 3.0) SD card reader.

    You might also want to investigate why your external drive is disconnecting, as this is not normal. Run First Aid on the drive using Disk Utility, and perhaps try connecting it to a different USB port on your Mac. If all else fails, try reformatting the drive.
  • a USB drive disconnecting like that is likely faulty - or a problem with the USB port. If the port is ruled out and Ben's other suggestions, try a different USB cable then power supply (assuming it isn't USB bus powered)... if all of those check out, it could be a problem with the drive or USB/sata controller board.
  • Ok. Will check the ports & HDD. Thanks for both of your suggestions.
  • On the subject of SD cards I did a bit of experimentation of using an SD card (built-in on my Mac mini) to store frame captures taken when I had motion detection active. Built I found out that (at least with up to and including 4.0.8, SecuritySpy really, really, doesn't seem to like the idea of storing them anywhere but the default location in "Documents".

    Am I doing something wrong in specifying a storage location or is it something in the app itself?

    Cheers,
    Mike
  • In Preferences - Setup near the bottom is where you set the destination.
    All of my cameras are saving to a different drive, never had an issue.
    You might have to format the SD card to MacOS Extended (or ExFAT) if it comes FAT32 - video files might grow too big to fit on fat32.
  • As Brian says, you should definitely format the card to Mac OS Extended - use Disk Utility for this. Let us know how you get on.
  • The SD card is formatted correctly and SecuritySpy does write a "Network Camera" folder and a subfolder with todays date, but no files are found in it. A quick look over in User Documents doesn't show any stored there either. I use another video analytics software and it seems to be storing on the SD card OK. Bit of a mystery...
  • Please check the following:

    Make sure you have enabled some capture settings. E.g. if you want SecuritySpy to capture continuously, enable the "Capture movie continuously" option under the Preferences -> Cameras -> Continuous Capture section.

    Make sure to arm Continuous Capture mode and/or Motion Capture mode as appropriate. Use the Control menu at the top of the screen, or right-click (control-click) on the camera in any window and select the "Arm" option.

    Once armed, you will see the Camera Info window indicate "C" or "M" under the Status column, representing Continuous Capture or Motion Capture respectively. When these are red, you know that SecuritySpy is actually recording video.
  • Checked all those items and SS is doing frame captures that I've set. Alert sound is set too which is triggering OK with Motion. I don't get a Camera Status data in the window, the window is there, but no camera data is displayed. My Pelco Sarix IXP21 is a streaming H264 cam so I'm using the "ONVIF" setting, so I thought that may have something do do with the missing camera data. Looking at the SD card in the finder after a capture will sometimes show a JPEG picture file or files, then mysteriously they disappear. Going back to the Destination default setting restores things to normal, it just seems it has trouble writing to the SD Card.
  • Oh, check in Settings "General" - specifically look at how much free space "On other volumes" it's set to keep - the card may not be big enough so is triggering immediate removal.
  • That was it! I was using a 16 Gig Sandisk SD Card and since the default setting was 20 Gigs, it was being removed from the card just about as fast as it was being written to it, which seems to be why the files were disappearing. Alls well now ;-). Thanks.
  • Good catch, @BrianM :)

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!