Foscam C2 not loading in Security Spy... anyone gotten it to work yet?
  • Foscam's C2 is on the list of supported hardware:

    http://www.bensoftware.com/securityspy/helpcameralist.html

    I've followed the exact same settings as in this helpful blog post but am only getting the blue "Communication error" screen.

    http://bensoftware.com/blog/review-foscam-c1-hd-wireless-ip-camera/

    Obviously my camera has a different IP, username and password but everything else is entered exactly the same. I figured that the Foscam C2 would work with the same settings as the C1.

    Any ideas how I can connect my C2 to Security Spy? I just learned of this software and it looks like exactly what I need (I’m migrating away from a Synology Surveillance Station which the C2 works fine with FYI).

    Also should note that I’m running the latest (just downloaded tonight) version of Security Spy (3.4.10) and my Foscam C2’s firmware is up-top-date (1.11.1.6_2.72.1.18).

    My week trial of Security Spy will be over soon! Hope I can get it working before then. Thanks!

    -Michael
  • Hi Michael,

    This camera should work in exactly the same way, but perhaps there are some minor differences in the firmware versions between the one we tested and your C2.

    Can you connect to the camera using Safari on your Mac (the Mac that is running SecuritySpy), using the same IP address that you have entered into SecuritySpy?

    The first thing to try is both port 88 and then 554 in the RTSP Port setting in the Video Device Settings window in SecuritySpy. Some Foscam cameras use the former; some the latter.

    By the way, the SecuritySpy trial lasts a whole month so you should have plenty more time for testing.
  • Hi Ben,

    Thanks for your response. Yes, I am able to connect to the camera using Safari over port 88 (but not port 554 FWIW). I'm able to see the video in Foscam's web viewer and make any adjustments to the camera's settings. (This is happening on the same Mac as I'm running SecuritySpy.)

    [insert a few min of me playing around with it more...]

    Ok, got it to connect! Though not totally sure if this is ideal: I've got SecuritySpy to successfully see the camera by setting BOTH the HTTP and RTSP ports to 88 (instead of RTSP port to 554). Does this have any affect on security? I hadn't tried this before since the blog post instructions had the different port numbers filled in but I just tried this on a whim and it worked. Any idea if it's okay to leave and use like this?

    Thanks again for your help!
  • Great to hear you managed to get it working. The standard RTSP port is 554, so this is what SecuritySpy uses by default. However, many Foscam cameras instead use the non-standard port 88, including the C2 apparently. There is no particular disadvantage to doing so, except that it makes setup more troublesome, as you have discovered, so it really would be better if all manufacturers would stick to using standard ports!
  • Thanks Ben! Appreciate your help!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!