Foscam FI9821W
  • Hello,
    I was wondering if anyone has had any connection issues with the new Foscam FI9821W HD / PT camera. I have been running the foscam outdoor cameras with SecuritySpy for almost 2 years without issue. The camera itself works perfectly when used with it's built in web server, but no luck finding it with SecuritySpy. I thought it would be super easy considering SecuritySpy recently added this camera to the list. Any help is much appreciated! Thank you!
  • I had the same issue. Couldn't get SecuritySpy to connect at all - trying so many different ways. In fact, I ended up returning the 9821w because it wouldn't work right with the Mac. I spent 2 hours with different techs at Foscam and they told me to return the 3 cameras I bought. The older ones work fine - albeit low resolution.

    Trying to find out how SecuritySpy can be made to work with other cheaper cameras that I find on Ebay that have megapixel resolution
  • Having the same issue. The release notes for v3.0.4 it includes support for the Foscam FI9821W network camera. I've even tried updating the firmware on the camera to

    Has anyone been able to get this camera to work? Any guide to how to configure with Security Spy would be appreciated.
  • We have tested this camera ourselves and it does work. Firstly you will need to install the firmware onto the camera. You will also need version 3.0.4 of SecuritySpy.

    It's also important NOT to change the default web interface port in the camera's settings: it must remain set to 88.

    In SecuritySpy, in the Video Device Settings window, create a new device, select the FI9821W profile, and make sure to leave the port boxes empty (this is important). Select H.264 RTSP as the format.

    The above settings are confirmed to work. If it doesn't work, try restarting the camera. In our testing, it seems that the camera may go offline periodically, requiring a restart. Foscam has informed us that a new firmware update to address this issue is imminent. Hopefully this will be released soon and will fix all remaining firmware bugs.
  • Thanks for the reply. My firmware and SecuritySpy versions are correct. I've factory reset the camera, the only change I make is adding a user account. I'm using a wired connection just to make sure i'm not having any issues on the wireless side.

    In Security Spy, the settings are like you say, I set the profile to FI9221W and H.264 format. Until I enter the user/password, I get an Authentication Error. Once those are entered it just keeps trying to Reconnect (which leads me to believe it's at least connecting to the camera enough to do the authentication).
  • The authentication error indicates your IP setup is correct. Note that the default authentication is "admin" as the username and nothing as the password - is this what you're using? What is shown in the log (select "Open log" in the File menu in SecuritySpy)?
  • Well there's the problem...

    "13-06-03 1534-46: Error communicating with the network device "Network camera 1" 3.0.4,70197,-2053 Codec feature unsupported. If you have Perian installed on your computer, uninstalling it should fix this problem. "

    Removing Perian and restarting SecuritySpy seems to have fixed that issue. Video looks great, only now it's timing out and reconnecting every 10-20sec or so... I'm guessing this is the bug you mentioned Foscam is working on their firmware?

    That's so much for your help!
  • After a couple more restarts, the reconnect issue has reduced as well.
  • That's great to hear. Yes Perian can prevent SecuritySpy decoding H.264 video so it does need to be removed for this to work.

    The issue with the camera going offline I referred to happens about once every 1-2 days in our testing, and requires a camera reboot to fix. If you are getting the camera reconnecting frequently then this is a different issue and this points to a possible network problem. Check WiFi interference and reception, and/or change the WiFi channel on the router/access point, or connect the camera by wired ethernet to debug this problem.
  • I have downloaded and install the firmware upgrade but it didn't solve none of the issues mention before.
    Please advice.
  • I have the latest firmware installed on one of my 9821W cameras, hard wired into my network as wireless was useless and I still have lockups. I set a power timer to cycle the power daily which has helped but I still have an occasional lockup. I haven't even taken my second 9821W out of the box yet as I'm still trying to decide if this will eventually be a reliable camera. When it works, it works pretty well.

    I should also state I have security spy recording the feed from this camera 24/7 if that makes any difference.
  • Ok, I have used the suggestions to reset the camera along with the instructions by Ben. The camera is up and running and has the quality of video I expected from the HD device. The only thing now is the PT controls are very delayed. I was running it before with a Jpeg stream and although the video quality was horrible, the PT responsiveness was spot on.

    The other thing was the two way audio. Do you think that we will ever see that feature work in SS ? Any ideas around these items Ben? Thank you for your help with this.
  • Ok, I have used the suggestions to reset the camera along with the instructions by Ben. The camera is up and running and has the quality of video I expected from the HD device. The only thing now is the PT controls are very delayed. I was running it before with a Jpeg stream and although the video quality was horrible, the PT responsiveness was spot on.

    The other thing was the two way audio. Do you think that we will ever see that feature work in SS ? Any ideas around these items Ben? Thank you for your help with this and keep up the great work.

    Just a quick note to everyone:
    - Camera is connected with Cat5.
    - Camera has been up for 12 hours with no disconnect from SS.
    - FPS is 10 during night hours and 22-27 during day hours.
    - PT Controls seem to have gotten much more responsive after one final reset.
    - "Mirror" Setting on the camera does not match the PT Controls (Left is right, etc)
    - 2 way audio not functional in SS, but works through Safari browser (If anyone has figured this out, please let me know)
    - Video quality in SS is outstanding compared to FI8904W and FI8905W @ 640x480.
  • Ok, I wanted to post another update..... I have had the camera up now per the above instructions for just over 24 hours. I checked on it periodically throughout the day with my phone app and it was spiratic on whether or not it was up and running or not. Now that I am home, it is accessible from the web server, but not SecuritySpy. I just have the blue screen. After a reboot, it picks back up in SS, but is going in and out. Does anybody have any thoughts on this?

    Also, does anybody have any experience with the non-HD Foscam PT cameras? At this point, I am much more concerned about stability than the video quality.

    Thank you!
  • After hours of reading through blogs, youtube and foscam website. I did at least get my Foscam F19821W view in video window. It worked perfect for a while, noticing now that it does flicker intermittently but does not turn off. Firmware Devise settings I put in my ip in the address field, left port and rtsp port blank format H.264 RTSP audio and video. Audio working good so far on recorded playback of captured video. Hopefully more work on this from foscam can get even better.
  • I am currently running Security Spy 3.0.4. I have the Foscam FI8921w camera installed using the built-in Foscam 8921w profile within security spy. The camera itself is set to Stream 0/720P/25FPS/1M and has system firmware version and app firmware version . Within Security Spy the camera will periodically blank out and go to a blue screen with a "unrecognized request error" and a reconnect count down and then it will reconnect. This happens every so often. Roughly every 20-40 minuets. Other times the camera will occasionally go to a gray screen and then come back within a few seconds. This happens maybe 3-4 times a day. Please let me know if anyone has any updates or fixes. Thanks!
  • Hi, this is a known issue (by Foscam) in the cameras RTSP server firmware implementation (Timeouts, preceding an RTSP server stream crash on the camera). Which is why only shutting down & restarting the camera (& not SecuritySpy) fixes this. I.e it's the camera not SecuritySpy thats having this issue.

    We support Open formats/protocols, where as Foscam's own software uses a propitiatory protocol, which has more stable support in it's firmware, unlike RTSP. Foscam had outsourced their Firmware dev, which at least in part, contributed to the firmware issues these cameras have had (4 updates & counting). Although they were supposed to be taking this (Dev) in house to resolve these issues, this at a minium delayed/postponed updates to RTSP support.

    If tuo need to get rid of these timeout's & eventual RTSP server crash's, you'll need to pressure Foscam for this.

    In the meantime, make sure your running the latest (least buggy) version of this cameras firmware, available on
  • Rod: I have been in steady contact with Foscam support to try and address these issues. Can you please let me know what exactly is occurring and I will send him a message to get these issues resolved hopefully and rapidly. Thanks!
  • I wonder if the latency of my 9812 Foscam is typical. When I walk through the camera's field of view, I get an email, as I should, that motion has been detected. In almost all cases, the picture taken is after I've left the area. Are the bad guys supposed to pose? Also I've not succeeded in taking movies-just pictures. I need to know how to access the SD card on the camera from Security Spy. Can someone tell me? Thanks
  • Richinwal: Try reducing the "trigger time" setting in SecuritySpy (Camera Settings -> Setup) to "1 frame", this should fix the issue with the email images being too late. I will make sure this is fixed in future versions of SecuritySpy so that the other trigger time settings don't affect the emailed images in this way.

    To capture movies, enable the "Capture movie when motion is detected" option in SecuritySpy (Camera Settings -> Motion capture).

    SecuritySpy canot access the SD card on the camera; SecuritySpy does its own recording.
  • Ben, once I made the suggested changes, the camera started recording every few seconds even though no motion was apparent to me and flooding me with emails.
  • Also I'm only getting jpegs in the emai, not movies that I specified in the setup.
  • Ben, I'm having trouble getting an image from the camera. I can see it in Safari but not in Security Spy...just a blank blue window with a red X on a white square in the center. I've followed your directions from the June 2 comment above, upgrading the firmware first, and just installed SS 3.1 today. The camera has been running wirelessly, but I have it connected via ethernet to the Airport Extreme right now trying to get SS working. Running OS 10.8.4 on a mid-2012 iMac.
  • Note that there was a new 9821 firmware released by Foscam today (I got the urgent update emails). I suspect that part of that was a fix for the directory traversal hack that had been publicly identified in the media recently for other cameras?
  • Yes the firmware update released today by Foscam appears to simply be a fix for the security flaw, it doesn't mention anything about improvements to streaming or stability in general. Can someone try it and see if it improves the general performance of the camera please?
  • I've got 2 of the 9821W Foscam cameras with the media port. I made some posts in their US support forum about stability problems and received the following suggestion which seems to work for me.
    Make sure you are running the latest firmware which I believe is 13.

    In your router reserve some IP addresses so DHCP can't allocate, for example I set DHCP to max out at 199 so 200-255 are available for manual assignment.

    In the camera settings turn off DHCP and set a manual IP address using one from the range you set in your router as non-DHCP, set the other settings manually etc...

    Now both my 9821W camera's are hard wired to my network, before the above fix they would shut off just about every day. Now they stay up for a week or more. Accessing them a lot through my phone or web browser does seem to make them less stable so I just access them through SS.

    While not totally perfect it seems to be working pretty well stability wise. Maybe DHCP in the camera is unstable?

    Hope this helps others,
  • Hello, I have both the Foscam 19802W and 19821W, and both aren't working through security spy. They do work through my web browser, as well as my iPhone/ipad app LiveCams Pro.
    And, I use both a local ip address for some computer's access, mainly my basement server that records videos off them; as well as a DynDNS linked IP named address. Again, iPhone/iPad apps work fine, so I know the links all work.
    I did follow your discussion above, and had original reset the http port to 80, to make connections easier, but I put it back to the default 88.
    Notwithstanding your directions to 'leave the ports blank', on my laptop, I need to use my DynDNS linked IP name to access home. I do this on my other 8 cameras by putting the forwarded port in the camera setup window. what do I use, if I have to leave the 'port' entries blank?
    any other suggestions on getting them to work? They are both updated with the Foscam latest software, as well, as using SecuritySpy ver 3.11
  • Hi Graydon, the instruction to leave the ports black is because the camera uses non-standard ports. The standard HTTP port is 80 and the standard RTSP port is 554, however the camera uses 88 for both of these protocols. SecuritySpy knows this, but if a user doesn't know this, he might enter one of the standard ports into SecuritySpy, which would then not work. If you have port forwarding and are using a different external port (which is forwarded to the camera on port 88), then you should indeed enter this external port into SecuritySpy, for both HTTP and RTSP.
  • I bought a Foscam FI9821W V2, System Firmware Version and, after I had configured every thing, I was surprised that the Camera is not working on SecuritySpy.
    I have already read this topic and tried several recommendation...nothing solved the problem. The cam has been working on Safari Browser and VLC utility.

    Is there any thing to be done in order to solve this problem ?

    Thanks for all,
    Best Regards

    PS.: I am using updated version of SecuritySpy (3.1.1)
  • We are looking into getting the V2 camera to work. According to the information we've received from Foscam, it should work with exactly the same settings as the V1 camera (although the V1 has not proved to be reliable enough for us to officially support it, which is why it's not on our camera list). I'll post back any further information that we find out.
  • In addition:
    I've tried the URL "rtsp://IPADDRESS:88/videoMain" and "rtsp://IPADDRESS:88/videoSub" on VLC and they worked pretty well.

    Thanks for all,
    Best Regards

  • Hi Francisco,

    If the camera works in VLC then it should work in SecuritySpy. Please try this:

    - In the Video Device Settings window in SecuritySpy, create a new network device.
    - Set the device type to "Foscam FI9802W, FI9821W".
    - Enter the camera's IP address but leave the Port boxes empty.
    - Enter the camera's username and password.
    - Select "H.264 RTSP" from the Format menu.

    Does that work?
  • Unfortunately, I did the configuration, following your instructions, and it did not work.

    I confirmed again it works on VLC.

    Thanks for all,
    Best Regards

  • That works for me (at least with the demo version 3.1.2) but I had to uninstall Perian and put 88 in port boxes for that. Ben, I think I deserve a license :)
  • I just installed a FI9821W V2, as well. I upgraded to the latest firmware (Sys:, App: immediately. It is on my hard wired Ethernet network. I initially tested this while running SecuritySpy 3.1.3.

    My post is primarily to report that I have a problem where the Pan/Tilt arrows no longer work in SecuritySpy 3.2 (although it seems the center home button does still work). Downgrading to 3.1.3 fixes the issue. Going back to 3.2 recreates the issue.

    It doesn't look like there is anything in the release notes that indicates this functionality would have changed, so I might be mistaken, but I tried to be thorough and troubleshoot the issue.

    Any thoughts on this?


    I thought I'd share my whole saga, in case it helps shed light on this camera / SecuritySpy, in general or specifically with this P/T issue.

    I used the default FI8921W V2 camera settings and got the H.264 stream to show in SecuritySpy 3.1.3, but every 20 seconds or so, the image went blank in SecuritySpy (green screen), and the reported frame rate went from the typical 30fps up to 100fps, down to 5 fps and then eventually stabilized back to 30fps.

    I lowered the camera's frame rate (in the camera's web interface settings) and played with the video settings (more on this later) until I found something that appeared to be more stable, but I was still getting dropouts.

    On a side note, I also tried enabling and using the MJPEG stream (there is a post on the Foscam forum which describes how to enable this and then I just used the SecuritySpy FI9821W driver with settings: JPEG Stream, Port: 88), but found that it was only low resolution (VGA, not 720p), which is not acceptable for my situation (I have a VGA camera that I was replacing due to the need for higher resolution)

    During all of this, I had been reconfiguring other cameras on the system, which could have added some confusion.

    I then tried upgrading to SecuritySpy 3.2. I also tried using the ONVIF configuration for the FI9821W, which seemed to pick up the stream ok. I thought it was all good, but found the Pan/Tilt controls for the FI8921W no longer worked. I then slowly worked back all of my changes, including trying the FI8921W SecuritySpy driver, factory reset of the camera and eventually erasing the SecuritySpy preferences files. No luck.

    Reverting to SecuritySpy 3.1.3 and the re-erasing the preferences files seemed to fix the Pan/Tilt issue with the FI9821W.

    These are the SecuritySpy 3.1.3 settings I am now using for the camera:

    Device type: Foscam FI9802W, FI9821W
    Address: DHCP assigned, but a static entry in my router's lease table
    HTTP Port/RTSP Port: blank (note: had to set this to 88 to get the JPEG HTTP format to work)
    Encryption: not checked
    Username/Password: set appropriately
    Format: H.264 RTSP

    And these are the FI9821W video settings I ended up with that seem to be stable with SecuritySpy (I put the same settings in all of the streams, 0-3):

    Resolution: 720P, Bit Rate: 2M, Frame Rate: 15fps, Key Frame Interval: 10

    Note that the default settings that came with the camera were 30 fps. I am, however, ok with a lower frame rate so that was the first thing I tried sacrificing to get a stable stream.

    I haven't run this for more than an hour or so (and haven't tried it during the daylight), so can't say the the interruptions in the video stream are cured. If I see them come back, I'll try a proper static IP address. If that doesn't help, I'll follow-up here with another post.

    Thank you,
  • One more thing, sorry - has anyone had any luck using the P/T presets in SecuritySpy with the FI9821W V2? They work in the camera's web interface, but not in SecuritySpy.

    The presets look like they are handled differently in the FI9821W V2's web interface than they were in the FI8910W's web interface, so perhaps this is the source of the problem?

    I understand that this camera is no longer officially supported, but if there's some guidance on what I can do to get this working, I'd be happy to put in the effort.

    Thank you,
  • Hi Jordan, thanks for the detailed information, it's useful to find out from customers what works and what doesn't with these cameras.

    As you say, the FI9821W (V1 or V2) is not officially supported by SecuritySpy due to reliability problems. We have found that the camera goes offline regularly requiring restarts, and also that it sometimes sends bad RTSP data that cannot be decoded. Having said that we do have some customers using them with various degrees of success.

    Unfortunately, between V1 and V2, Foscam changed the command set for controlling PTZ. Fortunately, they also added ONVIF support (and so did we). Unfortunately, the PTZ commands that SecuritySpy sends are still rejected by the camera. Fortunately, we have found and fixed the problem.

    So the next version of SecuritySpy (3.2.1, which will be released shortly), will support video, audio, and PTZ from this camera using the ONVIF profile - even though we will still not officially support the camera due to the above-mentioned problems, until Foscam brings out a firmware update that addresses them (hopefully they will at some point).
  • Hi Ben,

    I am new to your software as of today and I ordered 3 of these FI9821W-V2. Should I return them and order something else?


  • Jeff - I think that's probably a good idea if you can return them. Some users have had success, some haven't, and I have seen the reliability problems first hand.
  • I'm running the latest Indigo and SecuritySpy on a brand new installation of OS-X 10.9

    I had problems with the cameras staying connected, then upgraded them to .19 version of the firmware. I'm running them on HTTP and not ONVIF and so far no problems.
  • Any ideas on what is a more reliable, affordable, H.264 HD, WiFi camera that is available in the US?
  • Foscam's firmware download page only shows a .18 version of the firmware for the FI9821W V2 - where are you getting the .19 version from? It's great to hear you are having success with it, hopefully the firmware is getting more reliable.

    To find alternative cameras, have a look at our searchable camera list.

    For an alternative camera with similar specs to the FI9821W, that we have tested and confirmed to work well with SecuritySpy, have a look at the TRENDnet TV-IP672WI or the Zavio P5116.
  • Only problem I am seeing is the screen goes from video, then green for a second, then back to video, but usually stays on just fine.
  • Hi Ben,

    I installed SecuritySpy 3.2.1. Leaving alone the profile (i.e. continuing to use the Foscam 8921W profile), P/T was working again (as it was in SS 3.1.3), so that seems fixed from 3.2.

    I migrated the profile to ONVIF (using the Foscam default port of 888) and it seems to work as well as SS 3.1.3, with the added benefit that I can now set P/T presets. However, I cannot change presets (i.e. I have defined a preset in SecuritySpy, but need to move it slight... reprogramming the preset doesn't seem to work). As a work-around, I can log into the camera directly, delete the preset (i.e. "ss6", which I assume is the 6th preset set by SecuritySpy) and then recreate it.

    I also had some issues where while I was setting presets, I lost connectivity to camera through SecuritySpy (i.e. the PT controls no longer worked). Restarting SecuritySpy seemed to immediately resolve the issue. I can't consistently recreate the problem, so I can't tell you what is causing it. I also had to try the speed setting at the bottom of the SecuritySpy PTZ window a couple of times to get it to take, but again, I can't recreate this issue/share what was happening. Now that my presets are set, I'm happy with the system.

    Thank you for the quick update and resolution of this issue.


  • Sorry, .18
  • Jordan - there's a problem with the Foscam implementation of presets via ONVIF. According to the ONVIF specs, if the client (i.e. SecuritySpy) attempts to set a preset that already exists, the preset should be overwritten with the new location. However, as you have discovered, the camera refuses to overwrite existing presets, requiring them to first be deleted. To do this from SecuritySpy, hold the alt+cmd keys and press a preset button - this will tell the camera to delete the particular preset, so that it can be set again. This functionality is hidden in this way in SecuritySpy because it isn't required for any other camera we have come across.

    Re the green screen issue, we have seen this also. This happens when incomplete video frames are delivered to SecuritySpy, so that when they are decompressed the result is a green screen. The most likely cause is network bandwidth, so the solution is to connect the camera via wired ethernet rather than wirelessly, and/or reduce the frame rate and bit rate settings in the camera.
  • Ok Ben, I am at my wits end with foscam. The outdoor cameras that I have had for 3 years are finally giving out and I really want to replace them with the HD cameras (NOT the fi9821w). What do you recommend for the best reliability/stability with SecuritySpy? +-$200? I am not apposed to using an outdoor enclosure as I am already using one for my FI9821W (In 640x480 mode). Thanks for everything.

  • Hi Ken, if you don't need PTZ, then the Dahua IPC-HFW2100 is a great choice at around $160. If however you need PTZ, then the price goes up significantly - the Toshiba IK-WB16A is a good choice at around $400.
  • I just replaced one of my older F18918W with a FI9821W V2 (was wanting something with higher resolution). I was having trouble getting SecuritySpy to work with it until I upgraded to 3.2.1 (was on 2.?.? ) and upgraded the firmware in the camera to (system) and (App). Was working pretty good, but got dropped a little too often. Worked much better when I switch the Device Type to ONVIF.

    If I had read this thread before I ordered the camera I would have probably ordered something else, but I'm glad I didn't. It works great now just like the camera it replaced. Actually better. Much higher resolution and records sound. Never had sound before from any of my other Foscams. PTZ controls are much faster too. I'll probably replace my other ones fairly soon.

    The new camera has other features I like. This camera sits in a window looking outside. Before I had to get creative and write a script that runs several times a night to turn off the IR lights (nothing but glare when they are on when dark outside and they wouldn't stay off). I also had to adjust brightness and contrast with a script to switch between night and day. This new camera I can turn off the IR lights and they stay off. It's also much better with auto brightness and contrast. No more messing around with scripts.

  • @34bwood - What settings are you using under ONVIF? Would you please run down your settings window for me? I am wondering if you are having better luck with the V2 model. I have looked at them, but am very hesitant with the luck i have had with the 9821w. Thanks in advance.


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!