d-link dcs-2670l setup
  • Hi, i have a D-Link DCS2670l but i can't find the right setup (is not in the profile list). It works fine as 'Onvif' but i can't make the built in microphone works... someone have a suggestion?

    ps: i have read that D-Link camera can be difficult tu set up
  • Unfortunately D-Link cameras can be difficult to set up as they don't have a consistent API across all models. However, as this camera supports ONVIF, this should actually make it easy and I'm surprised you're not getting any audio with this method.

    The first thing to do is to log on to the camera with a web browser (e.g. Safari) and check the camera's settings to make sure that audio is actually enabled. This camera apparently supports both G.711 or AAC. Try both, and if they both work, then AAC is going to be the better format to use.

    The next thing to check is that you have enabled audio in SecuritySpy under Preferences -> Cameras -> Audio. Here, the "Audio device" setting should be set to "This network device".

    To see if audio is coming through, check the Camera Info window in SecuritySpy: if there is a black speaker icon in the Audio column this means that the audio is working. If you click this speaker icon you will hear the audio via the Mac's speakers.

    If you continue to have any problems with this, please email us and include SecuritySpy's log file (File menu -> Open Log).
  • Hi, sorry for the delay but a lot of things happened in this months....

    here some data on the camera i'd like to test.

    -DLink DCS-2670L Onvif compatible
    -Audio is enabled and it works with D-Link ios app
    -Web settings page don't have options to change audio format (G.711/AAC)
    -in 'Preferences cameras Audio', Audio Device option is set to 'This Network Device' and the others option are greyed
    -no speaker icon is visible on the top corner of the main view windows and, in 'Camera Info' window, the speaeker icon is visible but is greyed.

    here what i get in Open Log:
    13/08/2020 13:45:40: Error communicating with network device "Camera". 5.2.5b3,99999998,1650549857,'bada' Error from network device. Bad audio data.

    PS: i also have an old DCS932 and in this case audio works fine

  • Hi Marco,

    Your settings sound fine. It's likely that the camera is sending AAC audio, but SecuritySpy is having trouble decoding it. The latest beta version of SecuritySpy (currently 5.2.5b6) has some compatibility improvements related to audio support, so please try that and let me know whether this works or not.
  • Thanks!
    i tried with beta 5.2.5b6 but is the same. No speaker icon in the top right corner and no audio.

    i read, in the camera specs that is G.711 compatible:

  • Hi Marco,

    Thanks for sending the link to the spec sheet - this indicates that the camera supports both AAC and G.711 audio. There must be some setting to choose between these two options, somewhere in the camera's settings pages - perhaps this is hidden under some advanced settings somewhere?
  • Hi, i opened a ticket at d-link and asked the way to find this option but they wrote me this:

    "if you want to connect the camera to a device with audio support: • AAC (32 kbps) / • G.711 (128 kbps) is compatible. You will not find in the DCS-2670L configuration interface any buttons that allow you to change one format to another."
  • This is unusual, though not inconceivable if the camera makes both options available during the RTSP negotiation process. Could you please email us and include the debug file (SecuritySpy menu -> Debug -> Create Debug File On Desktop) and we'll take a look. Please also let us know the name that you have given this camera in SecuritySpy so that we can identify it in the debug file.
  • ok thanks!
    i sent you the debug file.
  • For anyone else with this camera, the audio problem is now fixed in SecuritySpy 5.2.5 onwards (currently available as a beta version).
  • Thanks a lot!!! it seems it works now!!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!